OS2 World.Com Forum

Subject  :  Null drivers for Keyboard and mouse ?
Author  :  Kim
Date  :  26 Mar, 2003 on 23:23
Was a while ago since I last looked around for this; but are there any good null drivers available for OS2 so one can run a system without having the keyboard and mouse connected and only use any kind of remote software (Desktop On-Call or NetOp) to controll it.

Subject  :  Re:Null drivers for Keyboard and mouse ?
Author  :  Kim
Date  :  01 Apr, 2003 on 10:49
Got suggestion about removing the mouse drivers and adding parameter to keyboard driver to run without any keyboard. But, I guess then that if I'm using NetOp or DOC that either of the apps wouldn't work with keyboard and mouse support - Or ? Suggestions ?

/Kim


Subject  :  Re:Null drivers for Keyboard and mouse ?
Author  :  BigWarpGuy
Date  :  01 Apr, 2003 on 15:27
Have you thought of using a KVM (keyboard, video, mouse) switch? Perhaps it could fool it into thinking those are attached? (just a thought).
OS/2 Warp-ed to the very end.

Subject  :  Re:Null drivers for Keyboard and mouse ?
Author  :  Kim
Date  :  01 Apr, 2003 on 21:41
It's just that I don't want to have kvm switch since the cheap ones tends to drop the keyboard once every while. When running linux boxes I more or less never have any keyboard or mouse attached to the system. 99.5% of the work can be done remote. I want to have the same possibility with OS2. And you actually have that almost except I don't want to have the keyboard or mouse connected. So the suggestion is ok; but I want to go one step ahead

/Kim


Subject  :  Re:Null drivers for Keyboard and mouse ?
Author  :  Gregg
Date  :  02 Apr, 2003 on 02:55
The IBM base device keyboard driver (IBMKBD.SYS) supports the /none switch for this purpose (booting OS2 without a keyboard). I believe that since the mouse driver is a device as opposed to a base device the system will boot and work fine without a mouse driver.

Gregg


Subject  :  Re:Null drivers for Keyboard and mouse ?
Author  :  Kim
Date  :  02 Apr, 2003 on 19:38
Right then, sort of getting blind when reading the inf text... But it worked fine using the /none swtich on the ibmkdb and just unplugged the mouse and tried to logon with NetOp and it works without any problem. So running the system without keyboard and mouse is no problem then. Thanks for the suggestion.

/Kim


Powered by UltraBoard 2000 <www.ub2k.com>