OS2 World.Com Forum

Subject  :  Anyone running Ruby on OS/2 or eCS?
Author  :  Roger
Date  :  15 Sep, 2006 on 07:07
I decided to create a Ruby development environment on OS/2 similar to the one I have on Windoze machine. So, I installed Ruby 1.8.1 (from Hobbes), EMX and two DLLs. I also wrote a small REXX program to launch irb and have been running some sample programs. No problems, so far.

For Windoze, I found a neat program called InstantRails that installs a complete Ruby on Rails environment, including Ruby, Apache, MySQL and PHPMyAdmin. It occurred to me that since all of these items have been ported to OS/2, it should be possible to create a Rails environment for my favorite OS.

Does anyone know if this has been done or know of someone that is developing a Ruby on Rails package for OS/2?


Subject  :  Re:Anyone running Ruby on OS/2 or eCS?
Author  :  obiwan
Date  :  19 Sep, 2006 on 02:13
Can you be more specific about what the difference is between an InstantRails-like project for OS/2, and just downloading and installing that handful of packages individually yourself?

Subject  :  Re:Anyone running Ruby on OS/2 or eCS?
Author  :  Roger
Date  :  19 Sep, 2006 on 07:09
InstantRails is a "turn-key" package, you just download it into a (172MB) directory and execute InstantRails.exe. The project site shows the console, link to a screencast on MattGriffith's page, and some more information. http://instantrails.rubyforge.org/wiki/wiki.pl

I thought it would be nice to have it on OS/2. More important is to find/make some of the components missing from the OS/2 side--like a current Ruby 1.8.4, mod_ruby, MySQL/Ruby driver, SCGI. Was hoping that someone had already found or built these and wrote a procedure. Wishful thinking.

Roger


Subject  :  Re:Anyone running Ruby on OS/2 or eCS?
Author  :  Edu eduard@totcontes.com
Date  :  19 Sep, 2006 on 21:49
I've seen in a japanese site a "diff" for Ruby 1.8.4

http://bauxite.sakura.ne.jp/wiki/mypad.cgi?p=OS2/emx/ruby/porting;f=ruby-1.8.4-os2emx-diff-20060122.zip

With this version you can run offical "Ruby/mysql" ( http://www.tmtm.org/en/ruby/mysql/ ), which _only_ requires ruby 1.8.2 to run ( no other libs ).

Let me know if you can do pm programming with TK, also.

Edu


Subject  :  Re:Anyone running Ruby on OS/2 or eCS?
Author  :  Roger
Date  :  21 Sep, 2006 on 05:04

Edu (19 Sep, 2006 21:49):
I've seen in a japanese site a "diff" for Ruby 1.8.4

http://bauxite.sakura.ne.jp/wiki/mypad.cgi?p=OS2/emx/ruby/porting;f=ruby-1.8.4-os2emx-diff-20060122.zip

With this version you can run offical "Ruby/mysql" ( http://www.tmtm.org/en/ruby/mysql/ ), which _only_ requires ruby 1.8.2 to run ( no other libs ).

Let me know if you can do pm programming with TK, also.

Edu


Thank you for the links and for asking about TK. I had not tested TK until today and find that it does not work on OS/2 or Windoze. OS/2 is missing the TCL/TK library, which I found on Hobbes ( tcl835x1.zip ). Windoze is missing at least one library, tk84.dll.


Powered by UltraBoard 2000 <www.ub2k.com>