OS2 World.Com Forum

Subject  :  Has anyone successfully run FireFox 1.0?
Author  :  cytan
Date  :  11 Nov, 2004 on 20:33
Hi,
I just downloaded firefox from mozilla.org for OS/2 and after unzipping it I tried running: firefox.exe

But get the following in my POPUPLOG.OS2:

11-11-2004 13:34:59 SYS3175 PID 0842 TID 0001 Slot 011a
D:\FIREFOX\FIREFOX.EXE
c0000005
1d99c0a4
P1=00000001 P2=0000005c P3=XXXXXXXX P4=XXXXXXXX
EAX=0011ff28 EBX=0011f5d0 ECX=0000005c EDX=80004005
ESI=0011ff9c EDI=0011ff20
DS=0053 DSACC=f0f3 DSLIM=ffffffff
ES=0053 ESACC=f0f3 ESLIM=ffffffff
FS=150b FSACC=00f3 FSLIM=00000030
GS=0000 GSACC=**** GSLIM=********
CS:EIP=005b:1d99c0a4 CSACC=f0df CSLIM=ffffffff
SS:ESP=0053:0011f570 SSACC=f0f3 SSLIM=ffffffff
EBP=0011f588 FLG=00092202

XPCOM.DLL 0001:0005c0a4


Has anyone successfully run firefox?


Subject  :  Re:Has anyone successfully run FireFox 1.0?
Author  :  davidfor
Date  :  11 Nov, 2004 on 23:32
The most likely problem is that it is picking up the wron XPCOM.DLL. Either:

  • You have Mozilla or IBM Web Browser in your LIBPATH
  • You unzipped the new version over the existing version and something didn't get replaced properly.

    ---
    David

  • Subject  :  Re:Has anyone successfully run FireFox 1.0?
    Author  :  cytan
    Date  :  12 Nov, 2004 on 16:32
    Turns out that if I have Mozilla running, firefox would crash with the above error. Once I exit mozilla, firefox runs without a hitch. I tried using set beginlibpath so that it points to the correct xpcom.dll, but it still crashed firefox with mozilla running. I guess firefox uses xpcom.dll in memory that was loaded by mozilla.

    Subject  :  Re:Has anyone successfully run FireFox 1.0?
    Author  :  ShyGuy shyguy@shyguysite.com
    Date  :  12 Nov, 2004 on 20:08
    The Warpzilla tips page http://www.os2bbs.com/os2news/Warpzilla.html

    has instructions for Running Multiple Versions Concurrently, scroll down the page.


    Subject  :  Re:Has anyone successfully run FireFox 1.0?
    Author  :  cytan
    Date  :  13 Nov, 2004 on 16:49

    ShyGuy (12 Nov, 2004 20:0:
    The Warpzilla tips page http://www.os2bbs.com/os2news/Warpzilla.html

    has instructions for Running Multiple Versions Concurrently, scroll down the page.


    Yep, the tips at the url is the key. Unfortunately, firefox seems to be really slow for me compared to mozilla. Is there anything I can do to speed things up?


    Subject  :  Re:Has anyone successfully run FireFox 1.0?
    Author  :  Kim
    Date  :  13 Nov, 2004 on 17:00
    Wouldn't that be a bit odd? I mean and correct me if I'm wrong, but aren't the same code base used?

    Powered by UltraBoard 2000 <www.ub2k.com>