Home | Gallery | Forum | Services | Webmail | Archive | Links | Contact Us | About Us
OS2 World.Com Forum
OS2 World.Com Online Discussion Forum.
Index / OS/2 - General / Applications
author message
copying files to samba share
Post a new topic Reply to this Topic Printable Version of this Topic Forward this Topic to your Friend Topic Commands (for administrator or moderators only)
sarameggs
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 2
since: 22 Oct, 2004
1. copying files to samba share
Reply to this topic with quote Modify your message
Hi,

I am a total ignorant when it comes to OS2. My background is unix mostly. My problem is I am trying to test a samba confg by copying files from C: into the shared drive using xcopy. The copy seems to go OK until it hits the Desktop dir, where the Xcopy stops, with the error :

SYS1693: the system cannot create the directory.

Is this happening because there is something special about Desktop? Is xcopy the best tool to use in this case or is there a better method of running the copy? Or, is copying c drive just totally stupid and I should try something else.

Thanks so much, sm

Date: 22 Oct, 2004 on 03:18
BigWarpGuy
Premium member
in staff

View this member's profileSearch all posts from this memberSend an email to this memberhttp://home.comcast.net/~tomleem
posts: 2298
since: 12 Jan, 2001
2. Re:copying files to samba share
Reply to this topic with quote Modify your message
Are you using xcopy from samba or from OS/2 command line? It could be it can not create a directory if the OS/2 drive is formatted using HPFS(?).

---
BigWarpGuy
- - - - - - - - - - - - - - - - - -
OS/2 Warp-ed/eComStation-ed to the very end.
- - - - - - - - - - - - - - - - -
Date: 22 Oct, 2004 on 17:08
Cris
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 124
since: 20 Nov, 2003
3. Re:copying files to samba share
Reply to this topic with quote Modify your message
Hi,
you should be telling a little more about your situation.
I don't understand where are you copying things FROM and TO.
The destination is an OS/2 box? And the source?
What do you want to achieve with your test?

BTW, the desktop IS a special directory, if you're copying TO the boot disk of an OS/2 box. But then you probably already have a desktop dir in the destination... so are you trying to overwrite it? If so, OS/2 (with a running Workplace Shell) won't let you.

Hope this helps..
Bye

Cris

Date: 22 Oct, 2004 on 17:21
sarameggs
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 2
since: 22 Oct, 2004
4. Re:copying files to samba share
Reply to this topic with quote Modify your message
Hi,

you are right, I am very sorry about the lack of info. I was testing the samba connection by trying to xcopy all of C drive to the samba share.

unix OS: linux kernel 2.4.21
samba: 3.0.7-1
OS2: ECS (not sure how to tell what version)

I have recompiled the kernel of the unix box to add in handling of extended attributes in filesystems, and have configured the unix filesystem to allow handling of extended attributes (user_xattr, acl). I have also added
ea support = yes
to my smb.conf file to configure samba to handle extended attributes.

I connected using:
net use z: \\unixhost\share
no problems with this. the drive just popped up. As the OS2 machine I am using for testing has no other data on it, I thought I would test it out using xcopy of the C: drive using:

[C:\]xcopy c:\*.* z: /S /V /e /t /h /r

This progresses until the copy reaches the Desktop dir, then it just stops.

Thanks so much for your responses so far.

sm

Date: 25 Oct, 2004 on 06:50
maxi
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 1
since: 26 Oct, 2004
5. Re:copying files to samba share
Reply to this topic with quote Modify your message
I've exactly the same problem.
Sometimes during the Xcopy command to a Samba share (SUSE Linux Enterpise Server 9) Xcopy fails with:

SYS1693: The system cannot create the directory.

Any help would be appreciated.

Date: 26 Oct, 2004 on 16:59
copying files to samba share
Post a new topic Reply to this Topic Printable Version of this Topic Forward this Topic to your Friend Topic Commands (for administrator or moderators only)
All times are CET+1. < Prev. | P. 1 | Next >
Go to:
 

Powered by UltraBoard 2000 Standard Edition,
Copyright © UltraScripts.com, Inc. 1999-2000.
Home | Gallery | Forums | Services | Webmail | Archive | Links | Contact Us | About Us
OS2 World.Com 2000-2004