Home | Gallery | Forum | Services | Webmail | Archive | Links | Contact Us | About Us
OS2 World.Com Forum
OS2 World.Com Online Discussion Forum.
Index / OS/2 - General / Networking
author message
OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Post a new topic Reply to this Topic Printable Version of this Topic Forward this Topic to your Friend Topic Commands (for administrator or moderators only)
dljone9
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 93
since: 13 Jan, 2003
1. OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
My employer is running OS/2 Warp Server (pre Aurora - latest 16-bit
TCP/IP stack) on Token Ring, and wants to run Win XP clients on an
Ethernet network - obviously, they will reside on a different ring. The
network folks are loathe to turn on source route bridging...and we
need NetBIOS functionality.

I have enabled Netbios over TCP/IP on the Warp Server, and on the XP
clients. They can ping each other - but no drive mappings are possible,
or any NetBIOS functions. I have an LMHOSTS file composed correctly
and living in the Windows subdirectory on the XP system.

Any networking experts out ther got any suggestions?? I am hoping my
employer will continue to use OS/2 (they have maybe 400 OS/2 servers
and many thousands of WSOD clients) - so any help would be appreciated!

Date: 28 Jul, 2004 on 00:58
ddelcol
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this memberhttp://www.os2world.com/rdbms
posts: 24
since: 17 Oct, 2002
2. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
This link should help you.

http://www.os2world.com/cgi-bin/news/viewnews.cgi?category=33&id=1076169226

Date: 28 Jul, 2004 on 03:06
dljone9
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 93
since: 13 Jan, 2003
3. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
Thanks for the input, I had seen this article and while it is quite good, my
situation is exactly the opposite - an OS/2 domain, XP workstations.

Anyone had experience with the above mentioend scenario?? Thanks!


ddelcol (28 Jul, 2004 03:06):
This link should help you.

http://www.os2world.com/cgi-bin/news/viewnews.cgi?category=33&id=1076169226[/quote]

Date: 28 Jul, 2004 on 10:18
bjorso
Normal member
in staff

View this member's profileSearch all posts from this memberSend an email to this memberhttp://www.bjorso.com
posts: 7
since: 01 Aug, 2003
4. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
Try this link http://signon.comtarsia.com/index_en.html

I am using Logon Client version 2.0 and have WinXP clients on a OS/2 network with WSeB as server, should work with older servers too.

//Mvh
Björn Söderström

Date: 28 Jul, 2004 on 11:48
mobybrick
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 38
since: 23 Jul, 2004
5. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
Hi,

Can you do a simple NET USE from the XP workstation to the OS/2 server? If not, then you have network/communication problems that need to be fixed before the logon client will help IMHO Even if the NET USE reports "Access Denied" then that at least indicates that transport is working.

How are the ethernet and token-ring networks to be bridged? What vendor is the networking gear from? SRB is very easy to set-up if using Madge, a little harder with IBM or Olicom. In fact, Madge equipment will allow combined SRT/SRB with SRT+.

If you are not using a switch to join the Ethernet/Token-ring (i.e. using a router) then I would recommend that you install ethernet adapters in the OS/2 servers and have them operate on token-ring and ethernet simultaneously and not bother with the other translation device (have done this in the past... used to look after a 3,000 user site with diskless RIPL clients).

Regards,
M

Date: 28 Jul, 2004 on 12:14
dljone9
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 93
since: 13 Jan, 2003
6. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message

bjorso (28 Jul, 2004 11:4:
Try this link http://signon.comtarsia.com/index_en.html

I am using Logon Client version 2.0 and have WinXP clients on a OS/2 network with WSeB as server, should work with older servers too.

//Mvh
Björn Söderström



Thanks much, I'll take a look at it. Have you been able to get this
logon application working with the above described scenario??

Date: 28 Jul, 2004 on 12:43
dljone9
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 93
since: 13 Jan, 2003
7. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
No indeed - no NET USE functions work. After a *lengthy* wait, you
do get prompted for a userid & password, then you gat an "access Denied" message. So I arrived at the same conclusion you did.

LOL - that's the problem - the network guys are not willing to help
in any way, as far as bridging. They are terrified of anything that
isn't IP. Don't have details on the hardware (hubs) - I am kind of
new with this employer. But I assure you - this employer of mine
undoubtedly purchased the hubs that were the least expensive!

Thanks for the Ethernet/TR suggestion - I may have to do that, and
I would be most appreciative if I can appeal to you for more help -
as you certainly know more about this than I do.


mobybrick (28 Jul, 2004 12:14):
Hi,

Can you do a simple NET USE from the XP workstation to the OS/2 server? If not, then you have network/communication problems that need to be fixed before the logon client will help IMHO Even if the NET USE reports "Access Denied" then that at least indicates that transport is working.

How are the ethernet and token-ring networks to be bridged? What vendor is the networking gear from? SRB is very easy to set-up if using Madge, a little harder with IBM or Olicom. In fact, Madge equipment will allow combined SRT/SRB with SRT+.

If you are not using a switch to join the Ethernet/Token-ring (i.e. using a router) then I would recommend that you install ethernet adapters in the OS/2 servers and have them operate on token-ring and ethernet simultaneously and not bother with the other translation device (have done this in the past... used to look after a 3,000 user site with diskless RIPL clients).

Regards,
M


Date: 28 Jul, 2004 on 12:49
bjorso
Normal member
in staff

View this member's profileSearch all posts from this memberSend an email to this memberhttp://www.bjorso.com
posts: 7
since: 01 Aug, 2003
8. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
Thanks much, I'll take a look at it. Have you been able to get this
logon application working with the above described scenario??

I have only one segment in my small network so I am using TCP/IP and pure Netbios in the server and on clients. It works fine for logon, homedirectory, file-sharing etc. If you have more segments you can use Netbios over TCP/IP instead. I can't imagine that will disturb TCP/IP? Routing between differnet nets has to be solved in server or other router. But first of all you must solv the network so it's possible to logon (requester). All that is taken care of from Logon Client, it's buildt for large networks so you have to dig a little in their documentation.

//
Björn Söderström

Date: 28 Jul, 2004 on 13:54
dljone9
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 93
since: 13 Jan, 2003
9. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message

bjorso (28 Jul, 2004 13:54):
Thanks much, I'll take a look at it. Have you been able to get this
logon application working with the above described scenario??

I have only one segment in my small network so I am using TCP/IP and pure Netbios in the server and on clients. It works fine for logon, homedirectory, file-sharing etc. If you have more segments you can use Netbios over TCP/IP instead. I can't imagine that will disturb TCP/IP? Routing between differnet nets has to be solved in server or other router. But first of all you must solv the network so it's possible to logon (requester). All that is taken care of from Logon Client, it's buildt for large networks so you have to dig a little in their documentation.

//
Björn Söderström



Well, no luck so far - I tried using the above refernced logon client,
and got nowhere. I placed an Ethernet card in the server, so it has
both Token Ring and Ethernet cards that appear to be fine (the
Ethernet card has an IP and can ping, etc.) Still can't logon from the
Windows XP client, or map drives.

To mention another point of interest - this is a Novell network, but
neither the XP box nor the OS/2 server will be using Novell when
this image is built and deployed.

I think what I will do - is load up an OS/2 box that is using only TCP/IP and Netbios over TCP/IP - then put him on the Ethernet network, and see if he attaches to the OS/2 server. That will tell me if the issue is with the XP client (which I suspect is the case).

Any other feedback is welcomed, much obliged!

Date: 29 Jul, 2004 on 13:32
dljone9
Premium member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 93
since: 13 Jan, 2003
10. Re:OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Reply to this topic with quote Modify your message
I have this situation resolved now, using the dual Ethernet/Token
Ring card method. It took a bit of study, as mpts.exe did not seem
to update the IBMLAN.INI correctly, and the route statements in
setup.cmd needed tweaking. But it's good now - thanks to all for
the helpful feedback!
Date: 05 Aug, 2004 on 16:18
OS/2 Warp Server (pre Aurora) and Win XP clients - diff. ring
Post a new topic Reply to this Topic Printable Version of this Topic Forward this Topic to your Friend Topic Commands (for administrator or moderators only)
All times are CET+1. < Prev. | P. 1 | Next >
Go to:
 

Powered by UltraBoard 2000 Standard Edition,
Copyright © UltraScripts.com, Inc. 1999-2000.
Home | Gallery | Forums | Services | Webmail | Archive | Links | Contact Us | About Us
OS2 World.Com 2000-2004