Home | Gallery | Forum | Services | Webmail | Archive | Links | Contact Us | About Us
OS2 World.Com Forum
OS2 World.Com Online Discussion Forum.
Index / OS/2 - General / Hardware
author message
WD hard drive refusing to be formatted under LVM
Post a new topic Reply to this Topic Printable Version of this Topic Forward this Topic to your Friend Topic Commands (for administrator or moderators only)
hausmaus
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this memberhttp://outpostbbs.net
posts: 87
since: 11 Aug, 2004
1. WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message
Hi, everyone.

I have a working WD (Western Digital) Expert 313500 (13.6GB) IDE drive that absolutely refuses to work under OS/2 Warp 4.52. The drive, which I pulled out of my current personal system (running W2K), is recognized by OS/2 just fine, but LVM complains that the partition and MBR are corrupted and that it cannot create a volume (LVM reports that the free space cannot be used).

I know for a fact there is nothing wrong with this drive as I've formatted it with NTFS and then FAT-32 (in an effort to get OS/2 to see it). I've also used DOS's FDISK and FORMAT (from a Win98 setup disk) to make sure that the drive is okay, but OS/2 is absolutely refusing to work with it.

Does anyone have any ideas or suggestions to what I could do? I'm wanting to build a new personal system for me running Warp 4.52 here (it's an 850mhz system that will run OS/2 fine) with this hard drive. I just can't afford to go out and get another drive at this time.

Any and all help is appreciated!

Thanks,
Sean

Date: 22 Nov, 2004 on 21:43
cytan
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 115
since: 05 Dec, 2003
2. Re:WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message
I think Win2k$ screwed around with the MBR. You can download dfsos2 and do a new MBR. I think this should fix it. However, like all free advice: YMMV.
Date: 22 Nov, 2004 on 22:24
Trident
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 49
since: 18 May, 2004
3. Re:WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message
you did not say how you are going to use the HD, 1. keep the current
partition or reformat the HD...
The second is obvious, just boot to the lvm don't worry about the
corrupted partition message, and delete all the volumes\partitions, then
reboot...
If you are trying to keep the partitions you have again boot to the lvm
delete bootmanager, then reinstall it... and add the partitions...
if required...
you can also go to the command line and excute
/newmbr....
Best
ps: there might be other options, let us know what happens...
Date: 23 Nov, 2004 on 16:40
hausmaus
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this memberhttp://outpostbbs.net
posts: 87
since: 11 Aug, 2004
4. Re:WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message

cytan (22 Nov, 2004 22:24):
I think Win2k$ screwed around with the MBR. You can download dfsos2 and do a new MBR. I think this should fix it. However, like all free advice: YMMV.

Wow, that's a really nice program... I'd never heard of it before... guess I had my head stuck in the sand! I think that is what I'll use to fix it-I hate Partition Magic because it's so limited... thanks for your advice!

Date: 23 Nov, 2004 on 17:15
hausmaus
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this memberhttp://outpostbbs.net
posts: 87
since: 11 Aug, 2004
5. Re:WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message

Trident (23 Nov, 2004 16:40):
you did not say how you are going to use the HD, 1. keep the current partition or reformat the HD...
The second is obvious, just boot to the lvm don't worry about the corrupted partition message, and delete all the volumes\partitions, then reboot...
If you are trying to keep the partitions you have again boot to the lvm delete bootmanager, then reinstall it... and add the partitions... if required...
you can also go to the command line and excute /newmbr....
Best ps: there might be other options, let us know what happens...

Well, I've already blown the partition several times using DOS's FDISK. I also attempted to do so with LVM, but LVM absolutely refused to work with it at all, so I think I'll try DFSee and see what happens. Thanks for your advice, I appreciate it.

I'll probably get to it next week as I'm busy this week, but I'll keep everyone posted.

Thanks again!

Date: 23 Nov, 2004 on 17:17
Radek
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this member
posts: 121
since: 17 Jul, 2003
6. Re:WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message
It need not help. I have seen a similar problem when I allowed winblows NT partition on my disk.
LVM refused to have anything common with the disk. No partition could be added, deleted, or manipulated somehow. MBR is corruped. Period.

I used DOS 5 FDISK for removing the NT partition. It worked, thanks god! Then I was able to repartition the disk and install eCS.
On the other hand, I was able to install both winblows 2000 and eCS 1.1 on my computer.

As to the current problem, if no partition needs to be preserved on the disk then I recommend the following:

1. Search long time uninspected places for DOS 5. If you find any, then start DOS 5 from a diskette, cancel DOS 5 installation, and run FDISK from the diskette. Delete all partitions on the disk ignoring senseless data about partitions. Deleting will work, no matter that FDISK will be confused as far as partition types and sizes are concerned.

2. If you want winblows 2000 on your HD then install it NOW.

3. Install boot manager now. Mark the winblows partition as bootable.

4. Install OS/2.

Date: 23 Nov, 2004 on 17:32
hausmaus
Normal member
in user

View this member's profileSearch all posts from this memberSend an email to this memberhttp://outpostbbs.net
posts: 87
since: 11 Aug, 2004
7. Re:WD hard drive refusing to be formatted under LVM
Reply to this topic with quote Modify your message
I'll check it out... I have DR-DOS 7.03 here but I don't know if it'll work. Thanks for the advice and I'll check it out.
Date: 23 Nov, 2004 on 22:34
WD hard drive refusing to be formatted under LVM
Post a new topic Reply to this Topic Printable Version of this Topic Forward this Topic to your Friend Topic Commands (for administrator or moderators only)
All times are CET+1. < Prev. | P. 1 | Next >
Go to:
 

Powered by UltraBoard 2000 Standard Edition,
Copyright © UltraScripts.com, Inc. 1999-2000.
Home | Gallery | Forums | Services | Webmail | Archive | Links | Contact Us | About Us
OS2 World.Com 2000-2004