Author Topic: Intel 82566MM Gigabit NIC  (Read 1127 times)

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 233
    • View Profile
Intel 82566MM Gigabit NIC
« on: April 20, 2016, 12:59:42 am »
I finally got OS/2 running on my ThinkPad X61 today but it wouldn't load  the Intel PRO/1000 Gigabit driver that was installed (e1000.nif).

I also tried the e1000e.nif but that wasn't recognised either.

According to Lenovo's website http://support.lenovo.com/gb/en/downloads/ds002618 it's likely to have an Intel 82566MM Gigabit Network Connection.

Is there any chance of finding an OS/2  driver for this NIC?



Per E. Johannessen

  • Full Member
  • ***
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Posts: 102
    • View Profile
Re: Intel 82566MM Gigabit NIC
« Reply #1 on: April 20, 2016, 06:13:04 pm »
Suggest you get a copy of pci104vka.zip and an updated vendor/device list, pcidevs_20140301.zip, from Hobbes.
Unzip and follow the supplied instructions to find out which chip is in your X61, then have a look at the E1000E section on https://www.arcanoae.com/wiki/multimac/
(The 82566MM is listed as supported.)


John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 233
    • View Profile
Re: Intel 82566MM Gigabit NIC
« Reply #2 on: April 20, 2016, 10:15:42 pm »
Yes, I've gone through all that but on bootup OS/2 said it didn't recognise the device...

There are different drivers e1000b and e1000e but when I tried to add both into MPTS only one showed up. Something strange  is going on with MPTS...

When I added e1000 which works withe the T42, it didn't show up in the available adapters... I had to delete all the other ones before MPTS recognised that one.

Guess I have to do the same on the X61.