Author Topic: OS/2 Warp 4 system font is too large - how to reduce font size?  (Read 7028 times)

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
I recently installed OS/2 Warp 4 (currently at 4.5) and have most fixes applied.  I am having one nagging issue that I am hoping someone could help with.  The system font (System Proportional) is way too large and I would like to reduce the size to something more sane.  I am running at 1280x1024 using the GENGRADD (SciTech Display Doctor/se 7.04) display driver.

I have looked around and have not found much that helps.  I did try the DefaultFont trick and it does help in some regards but it still has its own set of issues (clipping, Help text still has some interspersed large font text, etc.).  It would seem that if I could tell the system to use the system font sizing that is used for 1024x768 that would work.  I am not sure how to do so or if it is possible.

Is there something that can be done?

Thanks!
Scott Gibson



Andy Willis

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 9
  • Posts: 153
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #1 on: April 19, 2013, 08:55:22 pm »
I am not sure when this was introduced but you could try one or both of these:
REM ! SET SDDFONTSIZE = [small | medium | large]
REM ! SET SDDFONTDPI = [96 | 120]

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #2 on: April 20, 2013, 12:37:56 am »
Thanks.  I did try using both variables using different combinations but they did not do anything for me.  I had even switched from GENGRADD to SDDGRADD but they still had no effect.  Maybe they should and I am doing something wrong or have some setting that is off somewhere.  It seems that my particular SciTech drivers do not use these variables.

Thanks!
Scott

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 26
  • Posts: 529
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #3 on: April 20, 2013, 01:00:24 am »
Hi Scott

Maybe you want to update to SNAP - http://hobbes.nmsu.edu/download/pub/os2/system/drivers/video/snap-os2-3.1.8.zip (includes Serial Number) - to see if that helps.


Regards

Pete


Andreas Schnellbacher

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 14
  • Posts: 236
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #4 on: April 20, 2013, 10:46:42 am »
Just always add:

   OS2.INI -> PM_SystemFonts -> DefaultFont = 10.System Proportional
   (space before 'Proportional')

to avoid clipping in dialogs.

With Snap, you can use alternatively:

   SET SDDFONTSIZE=MEDIUM

There exists a patch for PMMERGE.DLL that allows to use

   OS2.INI -> PM_SystemFonts -> DefaultFont = 9.WarpSans
   (no space before 'Sans')

with a single drawback, so far (I use it since about 2 years):
Button fonts of the IBM help viewer look strange. Alex Taylor added
that Asian fonts don't look well with this patch applied:

http://hobbes.nmsu.edu/download/pub/os2/system/patches/PMFIX.zip

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #5 on: April 22, 2013, 05:07:14 pm »
Thanks Pete.  I installed the SNAP driver.  That does cause the SDD* variables to work and does give me more options to possibly correct my situation.  Though the results from using the variables seem somewhat limited as well have a similar effect to using the DefaultFont setting.  I need to experiment a little more.  I have found that the SNAP driver tends to hang my system at times.  Mostly, if not only, when switching screen sizes (to or from a full size command prompt for example).  I did not have this issue before.

Scott

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #6 on: April 22, 2013, 06:09:03 pm »
Andreas,

I had tried setting DefaultFont to "10.System Proportional" and the fonts still seemed to me too large.  They were not as bad as before but they still seemed larger than necessary.  It would be nice if there was something like a size 8 or 9 System Proportional font.

Using the MEDIUM variable size setting gets me what I have with DefaultFont set to "10. System Proportional" and using SMALL still has clipped widget and button text in various places.

I found the patch for PMMERGE.DLL but my version does not match the patchable version.  So I cannot use this at the moment.  Perhaps I still have more updating to do.  I am currently at FP 15 and DD 2.

I know what you mean about the Help buttons.  They, as some other graphic elements, seem to be hard coded in places.

Thanks,
Scott


Alex Taylor

  • Full Member
  • ***
  • Thank You
  • -Given: 10
  • -Receive: 14
  • Posts: 218
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #7 on: April 22, 2013, 08:01:02 pm »
Try setting DefaultFont to "8.Helv".  IIRC this is the default on DBCS versions of OS/2 and so most of the system dialogs should scale fairly well with it.

IIRC the IBM help viewer uses hard-coded fonts in some places, in which case there's nothing you can do about that except maybe use NewView instead (which I would generally recommend anyway, due to clipboard support, etc.).

BTW, if you see clipped dialog text with DefaultFont, it's a bug in that application, not a bug in OS/2.  All dialogs are supposed to be designed to fit the default dialog font (normally System Proportional), whether or not they actually use a different font for display.  This is not unfortunately very well documented for programmers.  However, the fact that the DefaultFont setting causes system-wide rescaling of dialogs is not only the correct behaviour, it is important that it work like this as some environments (including all DBCS versions of OS/2) depend on it.

If you don't have such an environment, then the patch that Andreas mentioned may well work for your purposes... but you do need to understand that this patch works by deliberately breaking part of the correct Presentation Manager behaviour.  It's a trade-off, and you should understand the ramifications.

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #8 on: April 22, 2013, 10:09:16 pm »
Thanks Alex.  I understand that 3rd party apps could have an issue and maybe even some OS/2 system apps.  I am seeing this issue even with OS/2's dialogs.  For example, if I select Properties on a folder the Icon tab will display a button with "reate another." instead of "Create another...".  Also the selection boxes will say "Templat" and "Lock positi".  I get this same result if I use any other font (Helv, WarpSans) other than System Proportional for DefaultFont.  I even get the same result if I use SDDFONTSIZE=SMALL (with/without DefaultFont set).

I suppose things could be worse, it just seems that something is not right.  Maybe this is just how it is supposed to be.  I really appreciate everyone's help with this.  This seems like such a rookie configuration yet at the moment a workable solution still eludes me.

Thanks for the tip with NewView.  This really solves my biggest pain since the help text was large everywhere.

Thanks!
Scott




Andreas Schnellbacher

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 14
  • Posts: 236
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #9 on: April 22, 2013, 10:27:29 pm »
I had tried setting DefaultFont to "10.System Proportional" and the fonts still seemed to me too large. 

OS/2 dialogs need exactly this size (or the default 12 pt one for resolutions greater 1024x768).
Otherwise you get clipping.

Using the MEDIUM variable size setting gets me what I have with DefaultFont set to "10. System Proportional" and using SMALL still has clipped widget and button text in various places.

Sure, I expected that.

After all, I seems to me like you're using a monitor too large for its resolution. I'm happy
with the recommended solutions and use 1920x1200 on a 24" TFT monitor.

The other option would be to upgrade to the newer eCS version of PMMERGE.DLL
to be able to patch it. I won't recommend that without exchanging other parts of the system. So, you should better switch to eCS, sooner or later.

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #10 on: April 22, 2013, 11:13:38 pm »
Thanks Andreas.  I will be buying eCS once version 2.2 becomes available.  I figured I would purchase a copy of OS/2 Warp 4 and use it until then.  I tried the eCS 1.2 and 2.2 demos and they, of course, did not have this issue.  Having used eCS and not experiencing this issue I was not sure if there was something with my installation of Warp 4 that I had configured wrong, had not patched fully, or if there might have been some sort of modification.

Thanks for the help!
Scott

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 632
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #11 on: April 25, 2013, 08:56:27 pm »
Scott, there is one thing you could try, setdfont (setdf101.zip) on hobbes.

I use it on all the computers here - well the one from which they were cloned and on a friends computer where the dialogue boxes and some program output displays were taking up a lot of the screen for no valid reason.  Once I set the default font to warp sans 9 everything was back to normal.  If memory serves it does need a rexxutil DLL and vrexx to work.

Andreas Schnellbacher

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 14
  • Posts: 236
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #12 on: April 26, 2013, 01:24:51 am »
Scott, there is one thing you could try, setdfont (setdf101.zip) on hobbes.

Once I set the default font to warp sans 9 everything was back to normal.

You would get clipping of dialog texts, as I wrote before.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 632
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #13 on: April 26, 2013, 08:13:59 pm »
Andreas, so far I have seen clipping of dialogue text on only one settings notebook page and I can't even remember which It was when I used it several years ago.

As I said it removes the large ugly dialogue boxes making them neat and tidy and more fitting with the basic OS/2 setup I have here.  If there was regular clipping I would have heard about it from those using the workstations - they love to complain about the smallest thing.

Scott Gibson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 13
    • View Profile
Re: OS/2 Warp 4 system font is too large - how to reduce font size?
« Reply #14 on: April 27, 2013, 06:32:25 pm »
Thanks Ivan.  I did give it a try.  On my system the clipping is actually worse than the results I get from using DefaultFont.  Using a DefaultFont of "10.System Proportional" and NewView helped a lot in making things better.  There are a few various interface elements that use larger than necessary fonts but at least they are somewhat subdued with DefaultFont.

Thanks,
Scott