Author Topic: Surprise with sound !! IN ECS2.2 B2  (Read 2683 times)

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Surprise with sound !! IN ECS2.2 B2
« on: October 07, 2016, 10:34:20 pm »
Today I happened to reinstall, the last update UniaudUpdate-1.09.06-1.09.26.zip
This update, and it had installed previously but with the following differences:
This time I unpack the zip it on drive C: (The drive C: or boot, is valid only for installing the media. But to unzip the zip?)
And install the debug version, not the runtime , and restart. And now the system is updated with Arca packs.

One or more of these things cause the sound to be heard, before nothing was heard.

Problems:
wav is ok
midi not is ok
mp3 is ok
In principle they sound just out by the helmets that plugs into a laptop.
With the pm123 program, running a mp3, the sound output from the headphones, and if I upload the volume to maximum, without disconnecting helmets, also goes by the laptop. But when the volume distortion is very large, and if it does not sound volume under.
With the pm123 program running, I have also seen that the system hangs.
I have generated the log file, if someone may be interested.
I have left to try more.

Saludos




roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #1 on: October 07, 2016, 11:52:28 pm »
I found this other program:
http://r6.ca/MMAudioPak/

but when I want to link to this page:
http://www.os2world.com/cdwriting/mmclasses/mmclassesmain.htm

this site show the home page www.os2world.com

???

Before install this program and after it, I can not resize the window in the program :
C:\MMOS2\DLL\UNIMIXPM.EXE only show the master play volumen.

saludos

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #2 on: October 08, 2016, 01:11:02 am »
With the pm123 program running, I have also seen that the system hangs.
The ver is 137 of pm123. And the hang is because I dont have same lib*, after install this packs is running well (but only in headphones)
libssp libstdc++6 libstdc++ libsupc++6 libsupc++
libc libgcc1 libgcc-fwd

I can play music!!!
saludos

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #3 on: October 08, 2016, 01:28:08 pm »
Only have a problem with pm123 1.37, when quit the program, apparently hang the system, but if I wait 2 or 5 minutes, the system close the program and return to normal work. For now, processes using a kill is faster closure pm123.

Saludos

Roderick Klein

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 179
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #4 on: October 08, 2016, 09:37:24 pm »
I found this other program:
http://r6.ca/MMAudioPak/

but when I want to link to this page:
http://www.os2world.com/cdwriting/mmclasses/mmclassesmain.htm

this site show the home page www.os2world.com

???

Before install this program and after it, I can not resize the window in the program :
C:\MMOS2\DLL\UNIMIXPM.EXE only show the master play volumen.

saludos

If you mean you want to download the CWMM classes from Chris Wohlgemuth they have been part of eCS 1.2R and higher. So there no need to install them, they are integrated in MMOS/2.

Roderick Klein
President OS/2 VOICE

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #5 on: October 08, 2016, 11:59:23 pm »
Thanks, Roderick
You are right, in fact I install the MMaudiopack.zip file, and not notice any difference. It is quite possible not know what to do with the mmclass, but sometimes look weird solutions to problems.

Saludos

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #6 on: October 09, 2016, 10:55:18 pm »
This pm123 is a very problematic aplication, I have seen that this application interferes with others, and may be dangerous. There is another application to run music? Many years ago I do not have a PC capable of running music. I remember using one called z !, but now can not find it. I found many links but not for download it.

Saludos

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 13
  • Posts: 263
    • View Profile

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 36
  • -Receive: 19
  • Posts: 416
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #8 on: October 10, 2016, 05:10:08 am »
This pm123 is a very problematic aplication, I have seen that this application interferes with others, and may be dangerous. There is another application to run music? Many years ago I do not have a PC capable of running music. I remember using one called z !, but now can not find it. I found many links but not for download it.

Saludos

I have never had a problems with pm123, also I believe there's two different version out there with later revision numbers 1.4xx.

May want to try the latest versions, before actually saying 'maybe dangerous', kind of careless thing to say ???  Seem more likely the problem is with your sound drivers, then PM123.

Here's some other stuff you can do with  MMAudio Pak by Russell O'Connor (including adding MP3 to eCS):

This is the lost art of programming the WPS :(
http://os2notes.net/os2cdcreator.html


Greggory

« Last Edit: October 10, 2016, 05:22:12 am by Greggory Shaw »

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 38
  • Posts: 938
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #9 on: October 10, 2016, 07:47:38 am »
Quote
May want to try the latest versions, before actually saying 'maybe dangerous', kind of careless thing to say

I agree. I use PM123 1.37, a lot. The only "problem" that I have with it is that my ISP cuts off the stream sometimes (not exactly a problem with PM123). Dangerous? Not in my experience. I will note that I had problems with the 1.4x version (it would play a stereo sound stream in mono), and went back to the 1.37 version (listening to an MP3 audio stream, in stereo, as I write  :) ).

MMAudio Pak, on the other hand, has caused problems for me, in the past. Still not dangerous though. It has been some time since I installed it myself, but I found that eCS 2.2b2 installed it for me. I would like to remove it, just to see if it is causing some of the WPS hangs that I am experiencing, but I haven't got around to doing it.

Quote
Seem more likely the problem is with your sound drivers

The only "supported" audio drivers are in UniaudUpdate-1.09.06-1.09.26.zip from the Arca Noae driver package. It has been my experience that they work fine, when they will load.

I do have two machines with sound cards where that version of UniAud will not load (device not found). There is another, later, version: ftp://ftp.netlabs.org/pub/uniaud/UniaudUpdate-1.09.06-2.02.01.zip  that loads on my Lenovo ThinkPad L530. It makes sound, but it sounds like it has maximum reverb.

The other machine is a desktop, so I simply plugged in an old SoundBlaster Live card. That one is interesting because I have 3 SB Live cards. One works with Sanders driver for SB Live, and not with UniAud. The other two work with UniAud, and not with Sander's driver. Interestingly, none of them will work with win 10 (no driver).

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #10 on: October 10, 2016, 03:50:08 pm »
I have never had a problems with pm123, also I believe there's two different version out there with later revision numbers 1.4xx.
My error!!, with version 1.37, now running 1.41 (from help file), is very well, all the list of problems that I show with 1.37, are solved with 1.41.

Saludos and thatnks for the info.

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #11 on: October 10, 2016, 04:40:30 pm »
I agree. I use PM123 1.37, a lot. The only "problem" that I have with it is that my ISP cuts off the stream sometimes (not exactly a problem with PM123). Dangerous? Not in my experience.
My other experience with 1.37
List of errors after install the libs:
With Sample Database from Watcom wsample.exe (only open the sample) the pm123 stop play similar a pause
When push in close program similar to hang the system, but if wait the system take the control.
If pm123 is in play mode, and open a Firefox 38.8.0, give me a TRAP 0003 in JFS.... (I have to test more this point in 1.41)


Quote
Seem more likely the problem is with your sound drivers.......

The only "supported" audio drivers are in UniaudUpdate-1.09.06-1.09.26.zip from the Arca Noae driver package. It has been my experience that they work fine, when they will load.
I install this drivers at begin, With the pm123-1.37 (without libs) program running, I have also seen that the system hangs, when push in mmclass\volume.exe in Mute on / off (now no have problems in 1.41) .
Quote
Interestingly, none of them will work with win 10 (no driver).
jaja I have a similar experience with a laptop that have windows vista preinstaled, i do not have drivers in xp for it.

saludos

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 331
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #12 on: October 10, 2016, 06:14:20 pm »
I almost forgot, a picture of how the bars are displayed, in 1.41. In 1.37 is ok,
This is what I understand it is a minor problem.
I made a photo, because pmview 378 can not capture the problem.
Saludos

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 36
  • -Receive: 19
  • Posts: 416
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #13 on: October 10, 2016, 06:53:58 pm »
I almost forgot, a picture of how the bars are displayed, in 1.41. In 1.37 is ok,
This is what I understand it is a minor problem.
I made a photo, because pmview 378 can not capture the problem.
Saludos

PM123 has been forked, try the other version too.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 38
  • Posts: 938
    • View Profile
Re: Surprise with sound !! IN ECS2.2 B2
« Reply #14 on: October 10, 2016, 09:13:44 pm »
Quote
List of errors after install the libs:
With Sample Database from Watcom wsample.exe (only open the sample) the pm123 stop play similar a pause
When push in close program similar to hang the system, but if wait the system take the control.
If pm123 is in play mode, and open a Firefox 38.8.0, give me a TRAP 0003 in JFS.... (I have to test more this point in 1.41)

What is Watcom wsample.exe, and why would you use it?

I see something like #2, when the input stream is cut off by my ISP. It is obviously a timeout of some sort.

What version of JFS are you using? JFS-1.09.06.exe from the Arca Noae driver package is the only one that is safe to use (although there is one user who argues with that). There was an older version that had a TRAP 0003 problem. That problem is more likely to be running out of shared memory space.

Quote
(without libs)

What do you mean by that? The programs won't work properly without the proper libs available.

Quote
I made a photo, because pmview 378 can not capture the problem.

That is misleading. PMView 378 cannot capture the screen because you have not registered it. There are other screen capture programs available at HOBBES, for free.

When you use your camera, turn the flash off.