Author Topic: New AN acpi-3.23.03.exe crashes my TP X250  (Read 1306 times)

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 26
    • View Profile
New AN acpi-3.23.03.exe crashes my TP X250
« on: October 12, 2016, 10:51:06 am »
I just tried to use the new Arca Noae ACPI driver (acpi-3.23.03.exe). With this package my Thinkpad X250 hangs on the boot logo. Back to acpi-3.23.02.exe it starts normal.
I make several tests. Every time same hang on boot logo.
Greetings from Potsdam, Germany
Mike



Moritz

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 16
    • View Profile
Re: New AN acpi-3.23.03.exe crashes my TP X250
« Reply #1 on: October 12, 2016, 11:07:31 am »
I have a similar issue with a ECS Guest in VBOX. System hangs when loading IBMKBD

David McKenna

  • Full Member
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 8
  • Posts: 167
    • View Profile
Re: New AN acpi-3.23.03.exe crashes my TP X250
« Reply #2 on: October 12, 2016, 12:44:09 pm »
 Are you using QSINIT to load your system? This new ACPI doesn't seem to work with it, you have to use the IBM loader....

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 26
    • View Profile
Re: New AN acpi-3.23.03.exe crashes my TP X250
« Reply #3 on: October 12, 2016, 03:21:59 pm »
Yes, I am using QSInit otherwise I have only less than 1MB RAM available. But I tried also booting using the original IBM loader. Same hang.
Greetings from Potsdam, Germany,
Mike

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 38
  • Posts: 937
    • View Profile
Re: New AN acpi-3.23.03.exe crashes my TP X250
« Reply #4 on: October 12, 2016, 05:44:58 pm »
I just tried it on my Lenovo ThinkPad T510. It hangs at the boot logo if I use the QSINIT loader. It seems to be okay (short test) with the IBM loader. I expect that QSINIT will need to be fixed, although preloading something may do the job. I will need to play with it later.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 38
  • Posts: 937
    • View Profile
Re: New AN acpi-3.23.03.exe crashes my TP X250
« Reply #5 on: October 12, 2016, 08:47:37 pm »
Quote
I just tried it on my Lenovo ThinkPad T510. It hangs at the boot logo if I use the QSINIT loader. It seems to be okay (short test) with the IBM loader.

My Lenovo ThinkPad L530 is the same. It works with the IBM loader, and not with the QSINIT loader.

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 26
    • View Profile
Re: New AN acpi-3.23.03.exe crashes my TP X250
« Reply #6 on: October 13, 2016, 05:18:29 pm »
David Azarewicz send me a test built of acpi 3.23.04. Now my TP X250 boots again, also with QSInit  ;D.
Thanks again for the very fast solution to David and the whole AN team.
Greetings from Potsdam, Germany,
Mike