Author Topic: XWP (xWorkplace) v1.0.11 beta3 Comments  (Read 5077 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1706
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
XWP (xWorkplace) v1.0.11 beta3 Comments
« on: November 23, 2016, 10:51:58 pm »
Hi

xWorkplace v1.0.11 beta 3 is working fine here.

I'm trying to make xview the default view when I open some folders. I know it can be done with "Open as..." and pressing "Shift" to select the new default.

But I was wondering if there is different way to do the same but from the object properties. Does anybody know if there is other way to do the same?

Regards


Martin Iturbide
OS2World NewsMaster
... just share the dream.

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 36
  • -Receive: 19
  • Posts: 416
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #1 on: November 24, 2016, 02:04:48 am »
With Object Desktop 2.0 installed the WPS got caught in a loop after the install the XPS.

After removing OD the install was good, testing now and will try to install OD later.


Looks good so far, thx Rich and all the developers !

Greggory

David McKenna

  • Full Member
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 8
  • Posts: 167
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #2 on: November 24, 2016, 06:09:31 am »
 Hi Martin,

  Yes... right click on the folder, then choose 'Properties' then choose the 'Menu' tab, click on 'Open As...' then click the 'Properties' button then in the 'Default Action' drop down menu choose '~XView'.

Regards

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1706
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #3 on: November 24, 2016, 02:21:20 pm »
Thank for your answers.

I'm going to write it down on the wiki to don't forget about.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1706
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #4 on: November 24, 2016, 02:55:06 pm »
Thanks

I wrote this very quickly to try to don't forget it.

http://www.os2world.com/wiki/index.php/Changing_the_Default_View_of_a_Folder

Let's hope that in a few years I don't forgot where I put it.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1706
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #5 on: November 24, 2016, 04:00:59 pm »
Hi.

I got a different issue.

It seems that the "Big Icon" functionality (I guess it is from Sunny Icons programs) that is included on eCS 2.2 beta is not working with the "xview" view. I can not turn it on and increase the icon size on the xview.

Maybe it will be getting fixed in ArcaOS, but for the moment, with the things that I have, I notice that limitation. 
If someone has the same issue please let me know.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Rich Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Posts: 31
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #6 on: November 25, 2016, 06:59:26 pm »
A few comments... but first an apology:

If you tried to installed XWP-Lite, it failed to create any XWP objects. Sorry 'bout that! The problem lies in 'install\instl001.cmd'. The REXX function 'RemoveUnsupportedFeatures' is missing its 'return' statement. Add it, rerun the script, then restart the Desktop.

As to Object Desktop: I have "the good parts" of v1.5 installed but not its folder enhancements. As many times as I've installed XWP on top of it, I've never had any problems. I can only hope that Greggory's problem was a one-time occurrence.

Finally, Sunny Icons... Martin, here are some answers to the questions you emailed me.

My _guess_ is that Sunny Icons just doesn't recognize the files window (on the right) as a WPS folder window, so it doesn't try to draw the icons itself. Xview doesn't get involved in how things are displayed in that window, so it isn't interfering with Sunny Icons.

OTOH, I could see where Sunny Icons might interfere with Xview. The screen shot of its menu shows a lot of options that Xview handles itself _and_ handles in a way that S.I. is unlikely to understand. Even if they work, they probably wouldn't get saved.

I'm sure that Sunny Icons and Xview can be made compatible, but most of the work will have to be done by eCoSoft or whomever maintains it these days.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1706
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #7 on: November 26, 2016, 12:34:51 am »
Thanks Rich for the answer. Let's hope that Sunny icons author can fix that to include the xview mode.

For the moment I will dream in technicolor that someday the Sunny Icons author can donate his "big icon" source code to the XWorkplace project :)

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 36
  • -Receive: 19
  • Posts: 416
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #8 on: November 26, 2016, 01:16:41 am »
As to Object Desktop: I have "the good parts" of v1.5 installed but not its folder enhancements. As many times as I've installed XWP on top of it, I've never had any problems. I can only hope that Greggory's problem was a one-time occurrence.

...

Hi Rich,

Folder enhancement seems to be the problem. I just installed XWP on a new install of eCS 2.2 with Object Desktop 2.0 without folder enhancements and XWP installed without problems.

Could you listed the list good parts of Object Desktop that you recommend and further comment on OD and XWP please !


Greggory

David McKenna

  • Full Member
  • ***
  • Thank You
  • -Given: 7
  • -Receive: 8
  • Posts: 167
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #9 on: November 26, 2016, 03:57:56 pm »
 Hi Martin,

  You might want to try the most recent alpha WPSWizard for large icons - it seems to work fine with XView. There is also a gigantic selection of icons to choose for it. A shame it was never fully completed, but it does work reliably...

Regards

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 36
  • -Receive: 19
  • Posts: 416
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #10 on: November 28, 2016, 08:58:41 am »
Think I found a bug with splitview, can someone else try this.

Open up a folder with splitview enabled.

Try to copy/move  anoterh folder, the folder with splitview does not show in the  dialog.


Greggory

Moritz

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 16
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #11 on: November 28, 2016, 10:14:37 am »
Yes i can confirm. Noticed the same behaviour.

Think I found a bug with splitview, can someone else try this.

Open up a folder with splitview enabled.

Try to copy/move  anoterh folder, the folder with splitview does not show in the  dialog.


Greggory

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1706
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #12 on: November 28, 2016, 04:26:52 pm »

You might want to try the most recent alpha WPSWizard for large icons - it seems to work fine with XView. There is also a gigantic selection of icons to choose for it. A shame it was never fully completed, but it does work reliably...

Yes, I will try WPS-Wizard again to see how it works with xWorkplace. I had some issues with WPS-Wizard in the past, I don't know exactly which feature of the program made my WPS unstable. But since this is on my experimental VM I will keep trying.

Drifting away from the topic, I also think that WPS-Wizard had a better idea how to integrate the bigger icons on the WPS compared to "Sunny Icons / PNG Desktop". On WPS-Wizard instead of creating a "Big Icon" property, it override the "Icon" functionality of the WPS, make it more organized on the element properties.

There are also some other simple visual things on "Sunny Icons / PNG Desktop" that can be improved. (Check screenshot)

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Rich Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Posts: 31
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #13 on: November 29, 2016, 04:16:51 am »
Think I found a bug with splitview, can someone else try this.
Open up a folder with splitview enabled.
Try to copy/move  anoterh folder, the folder with splitview does not show in the  dialog.

From the "OS/2 Developers" mailing list:

On Thu, 03 Nov 2016 17:20:25 +1100, Peter Moylan wrote:

>here's a bug in Split View.
>
>Open any folder in split view. Right click on a file and select "Copy".
>The list of folders that pops up does not include the one you're
>copying from.

Deep in the undocumented bowels of the WPS lies code with no
public interface that appears to limit this listing to views it knows
about (icon/tree/details). As such, I'd have to categorize this one
as "can't fix (except by dumb luck)".

Rich Walsh

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 6
  • Posts: 327
    • View Profile
Re: XWP (xWorkplace) v1.0.11 beta3 Comments
« Reply #14 on: November 29, 2016, 09:35:09 pm »
Defining folder in view 1/4 favotite folder, provides a link menu to that folder that fails

The problem is that the favorite-folder, if I select it from the right mouse, displays the contents of the folder, and if it is a program opens it, and if it is another folder shows its contents.
The program would not have to execute anything.

Skip much where it is selected, the menu, according to the corner of the screen, and the contents of the folder.

Saludos