Author Topic: Questions re git in YUM package manage and setting up ssh under ArcaOS  (Read 455 times)

Jean-Yves

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 1
  • Posts: 81
    • View Profile
    • shimeril.com
Hi,

A couple of questions:

1) for an ArcaOS installation in VirtualBox (64-bit OS X host), which git-all package should I use - there seem to be several with very similar version numbers.

2) I need to set up ssh so that I can create keys to communicate with my gitlab repos. However, unlike with Linux and OS X where ssh is baked in, I am not sure how to set this up under ArcaOS? I'd also be very grateful for any advice on what are the best client tools currently available. 

Many thanks.  :)


Thanks



Jean-Yves

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 1
  • Posts: 81
    • View Profile
    • shimeril.com
Actually I might nit need ssh. I thought I'd need it to generate the keys but I can do that on the host and move them over I believe.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1098
    • View Profile
Just install the latest git and it'll pull in everything else.
yum install git

Jean-Yves

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 1
  • Posts: 81
    • View Profile
    • shimeril.com
Thanks Dave, will do.

Jean-Yves

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 1
  • Posts: 81
    • View Profile
    • shimeril.com
Just out of interest, should I be concerned that although yum appears to have installed all 21 git packages it said it would, it finished with an error:

Rpmdb checksum is invalid: dCDPT(pkg checksums) ?

When I try to clone a repo from gitlab, I get:

error: cannot run ssh: No such file or directory
fatal: unable to fork


I am not sure whether the two are related or whether I do need an ssh implementation installed separately.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 243
  • -Receive: 46
  • Posts: 1639
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Hi

I wrote this quick and simple article of using git.exe under eComStation: http://www.edm2.com/index.php/Using_Git_under_eComStation
But to be honest I haven't used any ssh with it.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1098
    • View Profile
Just out of interest, should I be concerned that although yum appears to have installed all 21 git packages it said it would, it finished with an error:

Rpmdb checksum is invalid: dCDPT(pkg checksums) ?

No, it seems to be a permanent harmless error
Quote
When I try to clone a repo from gitlab, I get:

error: cannot run ssh: No such file or directory
fatal: unable to fork


I am not sure whether the two are related or whether I do need an ssh implementation installed separately.

Not sure about that error, might be simply out of low memory. Try rebooting, a good idea anyways as if a DLL is in use, it is unlocked and upgraded but the old one is still in memory.

Jean-Yves

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 1
  • Posts: 81
    • View Profile
    • shimeril.com
@martin - thanks. It's not git itself I have problems with, but actually your article reminded me that I had not set the globals for my user and email, so very useful indeed!  :)

@Dave - rebooting did not help, I got the same error.  However, I tried using HTTPS rather than SSH (I've always used SSH before so it had not occurred to me to use an alternative method). And bingo!

It means manually entering the password (well it can be cached in the globals I guess so not too bad), but all seems working. I have cloned, added, committed and pushed, and my changes have appeared on gitlab.

Thanks both for all for your suggestions.  The OS/2 community on these forums is really wonderfully helpful .