Author Topic: Broadcom Ethernet adapter issues Thinkpad T43 - Arca OS  (Read 272 times)

Kevin Nunn

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 2
  • Posts: 16
    • View Profile
Broadcom Ethernet adapter issues Thinkpad T43 - Arca OS
« on: May 26, 2017, 09:25:27 pm »
I am trying to setup my "backup" Thinkpad T43 (1875) with ArcaOS. I already installed it on my primary T43 (a newer model) and it is working fine.

The problem is with the Broadcom NetXtreme Gigabit ethernet adapter. It is not a real pressing problem, since this is a backup laptop and otherwise it sits collecting dust.

This laptop did have eCS 1.2 installed with ethernet working fine using a Broadcom B57 driver that I found specifically for Thinkpads. And after having issues with the Arca install, I reinstalled eCS 1.2 to make sure the adapter was still working and it does work fine.

Arca initial install does not find a network adapter at all. After the install was finished, I installed the driver I used with eCS. After that boot up would have a long pause after loading the driver, then would state that there was an "Invalid IRQ value - check IRQ in BIOS" (which i cannot find).

If I try to use the B57 driver included in Acra, it boots up fine, but with DHCP or assigned IP/Route/DNS, there is no connection. ping attempts result in "sendto: No route to host".

ifconfig lan0
LAN0: flags:3c2a<BROADCAST,LOOPBACK,NOTRAILERS,DEFMTU,MULTICAST,BRIDGE,SNAP>

Exact same setup in eCS works fine. I can't figure this one out.

Also on another T43, slightly newer, same network adapter works fine. So it could be an issue with the laptop, but why would it work fine under eCS, but not ArcaOS?





Bill Sorenson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 10
    • View Profile
Re: Broadcom Ethernet adapter issues Thinkpad T43 - Arca OS
« Reply #1 on: May 26, 2017, 10:03:50 pm »
I had an issue on an Optiplex 745 with ArcaOS not auto-detecting the broadcom adapter but working fine if I manually selected the device. I might suggest reinstalling ArcaOS from scratch and selecting the Broadcom 57 driver without installing the old ecs driver at all (there's a chance a file got overwritten with an incompatible version).


Kevin Nunn

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 2
  • Posts: 16
    • View Profile
Re: Broadcom Ethernet adapter issues Thinkpad T43 - Arca OS
« Reply #2 on: May 26, 2017, 10:28:47 pm »
I had an issue on an Optiplex 745 with ArcaOS not auto-detecting the broadcom adapter but working fine if I manually selected the device. I might suggest reinstalling ArcaOS from scratch and selecting the Broadcom 57 driver without installing the old ecs driver at all (there's a chance a file got overwritten with an incompatible version).

Thanks Bill! That did it. Fresh install, manually selecting Broadcom driver during install, and I now I have a network connection.

My life can continue on now :)

Thanks!!

Kev