Author Topic: Working ArcaOS 5.0 in Virtual Box 5.0.30  (Read 312 times)

David Hart

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 17
    • View Profile
Working ArcaOS 5.0 in Virtual Box 5.0.30
« on: May 29, 2017, 12:55:29 am »
I have been trying to install ArcaOS 5.0 and ran into issues with it detecting the following:

- Detected Sound driver (UNIAUD) did not work.
- Did not detect Intel Built in Network card (eCS 2.1/2.2 did detect)
- Plugged in network card that does work in eCS 2.2 and prior versions did not work.

Next I tried to install in Virtual Box and after a few tries I got sound and network working:

VirtualBox (Windows) 5.0.30 is what I have.  (I will try this on VBox for OS2 later).

General
- Operating system - Other OS/2

System
- Base Memory 2000 MB
Acceleration VT-x/AMD, Nested Paging

Audio
- Host Driver Windows DirectSound
- Controller ICH AC97 (This is what ArcaOS Needs)

Network
- Attached To: Bridged Adapter
- Name: Realteck PCIe GBE Family Controller
- Intel PRO/1000 MT Desktop (8254OEM) - (This is what ArcaOS needs)




Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1095
    • View Profile
Re: Working ArcaOS 5.0 in Virtual Box 5.0.30
« Reply #1 on: May 29, 2017, 02:05:35 am »
The OS/2 port of VirtualBox does not support Acceleration VT-x/AMD, which is required to install OS/2

David Hart

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 17
    • View Profile
Re: Working ArcaOS 5.0 in Virtual Box 5.0.30
« Reply #2 on: May 29, 2017, 09:03:01 pm »
ArcaOS does install on Virtual PC 5.1 by Connectix.

Networking does work but UNIAUD did not work and the installer installs UNIAUD even if Sound Blaster is selected.

Dave