Author Topic: format /fs:hpfs does not work  (Read 313 times)

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 232
    • View Profile
format /fs:hpfs does not work
« on: June 18, 2017, 01:26:12 pm »
I'm trying to format a new partition from a Warp CP2 CD using the command prompt. The disk has already been partitioned with two partitions (C: and D:) having been created. At the command from I run:-

e:\os2image\disk_3\format c: /fs:hpfs

and get the error msg

SYS1311: The system files are missing

Anyone know which 'system files' are being referred to?

I can format as FAT without any problem.



Joop

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 30
  • Posts: 405
    • View Profile
Re: format /fs:hpfs does not work
« Reply #1 on: June 18, 2017, 04:26:39 pm »
SYS1311: The system files are missing

Anyone know which 'system files' are being referred to?
What you want to do doesn't work that way. One of the system files you need is "HPFS.IFS". That "IFS" stands for Installable File System. As the name says, you need to install it or install the system from disk where these files reside for first run. I'm not sure if this is the only file you need in this process.

Lars

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 20
  • Posts: 140
    • View Profile
Re: format /fs:hpfs does not work
« Reply #2 on: June 18, 2017, 05:31:07 pm »
It,s rather UHPFS.DLL that is missing.

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 232
    • View Profile
Re: format /fs:hpfs does not work
« Reply #3 on: June 18, 2017, 05:35:20 pm »
SYS1311: The system files are missing

Anyone know which 'system files' are being referred to?
What you want to do doesn't work that way. One of the system files you need is "HPFS.IFS". That "IFS" stands for Installable File System. As the name says, you need to install it or install the system from disk where these files reside for first run. I'm not sure if this is the only file you need in this process.

I am in a cmd shell started during the installation process. When I press exit I return to the Installation program where I am asked to 'Accept the C volume'. If I press ENTER, system files are loaded , and them am told the volume can be formatted HPFS or FAT and I need to select a Long or a Quick format, then I select which File System. At this point I can select HPFS and the volume will be formatted HPFS. Notice I have not rebooted so the environment is still the same as it was when I tried to execute 'format c: /fs:hpfs', so if the system needs hpfs.ifs to have been loaded at bootup the it must already be loaded.

Laurenz Sommer

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 3
  • Posts: 29
    • View Profile
Re: format /fs:hpfs does not work
« Reply #4 on: June 18, 2017, 05:52:08 pm »
You have to change to e:\os2image\disk_3 before you run format, typing the full path to format.com like you did is not enough.

Andreas Kohl

  • Full Member
  • ***
  • Thank You
  • -Given: 4
  • -Receive: 6
  • Posts: 141
    • View Profile
    • warpserver.de
Re: format /fs:hpfs does not work
« Reply #5 on: June 18, 2017, 05:54:49 pm »
I'm trying to format a new partition from a Warp CP2 CD using the command prompt. The disk has already been partitioned with two partitions (C: and D:) having been created. At the command from I run:-

e:\os2image\disk_3\format c: /fs:hpfs

and get the error msg

SYS1311: The system files are missing

Anyone know which 'system files' are being referred to?

I can format as FAT without any problem.

Perhaps your environment is simply not correct. Some DLL files from \OS2IMAGE\DISK_2 are required for more advanced format functions: DOSCALL1, KBDCALLS, VIOCALLS, SESMGR, MSG, NLS. You can try to SET BEGINLIBPATH=e:\os2image\disk_2 before running FORMAT.COM.

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 232
    • View Profile
Re: format /fs:hpfs does not work
« Reply #6 on: June 18, 2017, 06:14:46 pm »
It,s rather UHPFS.DLL that is missing.

Many thanks for this Lars.

I needed to

e:
cd \cid\dll\os2
\os2image\disk_3 format c: /fs:hpfs

And now it works.


So I can install OS/2 to my newly HPFS formatted c: drive by:

e:\cid\exe\os2\semaint /s:c:\os2image /t:c:\maint /b:c: /l1:c:\install.log

Or rather I should be able to. It worked on a FAT drive, but now everything get copied but the process ends with:-

Executing C:\MAINT\SYSINSTX.COM to C:
CID0011: An error occurred while executing SYSINSTX.COM
CID0018: SEMAINT ended with errors. Return code = 0x1604

After further investigation, it looks like I needed uhpfs.dll in the libpath to run semaint when installing onto an HPFS partition.

So, a good lesson learned today :)...