Author Topic: Samba server on AOS  (Read 666 times)

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 649
    • View Profile
Samba server on AOS
« on: November 05, 2017, 02:00:50 pm »
Has anyone managed to get samba server working on ArcaOS?  If so can you please give me the correct incantation and number of chicken entrales I must sacrifice to do so.

OK, the last might be a joke but it does not change the requirement in any way.  The readme says nothing, the samba-howto-collection might but I think it would be better to have it as a pdf document and the Netlabs instructions seem rather irrelevant to what gets installed on ArcaOS at initial install time.

So far no matter what I do I cant get smbd.exe or nmbd.exe to run therefore samba server is not running.

I would normally assume that when software is installed it will be in a working state, maybe not at full potential but at least working. 

I have tried reinstalling ArcaOS several times just in case I had missed something - still no working samba server yet the ArcaMapper samba client works without problems which allows me to connect to the samba servers of my NAS boxes (setting up the SMB on the NAS boxes involved just ticking a box to activate it and another box to indicate user/s - if it is that simple what is wrong with our version?).
 



Richard Dunkle

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 16
    • View Profile
Re: Samba server on AOS
« Reply #1 on: November 05, 2017, 03:35:04 pm »

Andy Willis

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 9
  • Posts: 158
    • View Profile
Re: Samba server on AOS
« Reply #2 on: November 05, 2017, 07:32:14 pm »
Samba Server is in a working state, just not a configured state.  Before launching the Samba server, one has to run the "Simple Samba Configuration Center" in the Samba server folder (it is set to launch sscc /install which after running it will become sscc /config.
When the popup for Installation mode comes up, put a checkmark in
Erase current "smb.conf" and create a new one.
and then in
Erase current "Backend" and create a new one.
You can leave check "Install libraries using YUM" (though it should not be necessary).
Click Continue and you will be prompted to set the "root" account password.
Click Create Samba default default configuration.

Click OK on the following popups and then close.
Samba Users and Groups can be used to create the desired users.
Now you can launch Start Samba Server (smb.cmd start).

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 649
    • View Profile
Re: Samba server on AOS
« Reply #3 on: November 06, 2017, 12:16:03 pm »
Thanks both of you.

Andy, I followed your outline (it appeared simpler) and it appears to work.  I say appears because the server does not appear on any of my other computers which rather defeats the object of running it.

I do see that only smbd.exe is running, see attachment.  Since nmbd.exe is also listed am I correct in assuming it too should be running and if so what have I missed?

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 8
  • Posts: 136
    • View Profile
Re: Samba server on AOS
« Reply #4 on: November 06, 2017, 12:54:32 pm »
Nmbd writes a log file. The location of the logfiles is seen in smbd.conf. Either post the nmbd log here, or look at it yourself and try to figure out the reason. My bet is, that some netbios over tcp service is running already.
kind regards
Silvan
CTO bww bitwise works GmbH

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 649
    • View Profile
Re: Samba server on AOS
« Reply #5 on: November 06, 2017, 04:29:07 pm »
Hi Silvan.

There shouldn't be any netbios over tcp running - I didn't install it.

The log shows a problem with opening a socket on 192.168.0.255.  The problem might be that the dhcp server is on 192.168.0.254.

Richard Dunkle

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 16
    • View Profile
Re: Samba server on AOS
« Reply #6 on: November 06, 2017, 04:42:03 pm »
sure looks like peer networking conflict, what else would be using port 137 ?

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 8
  • Posts: 136
    • View Profile
Re: Samba server on AOS
« Reply #7 on: November 06, 2017, 04:46:53 pm »
Hi Silvan.

There shouldn't be any netbios over tcp running - I didn't install it.

The log shows a problem with opening a socket on 192.168.0.255.  The problem might be that the dhcp server is on 192.168.0.254.

most probably you hit http://trac.netlabs.org/samba/ticket/282. Please try to add the mentioned setting. It should even be already commented out in the smbd.conf
kind regards
Silvan
CTO bww bitwise works GmbH

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 649
    • View Profile
Re: Samba server on AOS
« Reply #8 on: November 06, 2017, 09:49:29 pm »
Thanks Silvan,

For some reason 'nmbd bind explicit broadcast was set to Yed in the nice new smb.conf, when I edited it to No, and restarted the server it now appears on other machines.

Now all I have to work out is how to share the various server partitions.

 

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 649
    • View Profile
Re: Samba server on AOS
« Reply #9 on: November 14, 2017, 04:12:49 pm »
As an addendum to this I can share all partitions on each drive letter EXCEPT the drive with the samba server on it - that one only displays the samba directory yet it is setup the same as all the others.

I am obviously missing something here but what it is I don't know.