Author Topic: Install TCP/IP after installation with OS/2 3.0 Connect?  (Read 7967 times)

pcm2a

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
    • View Profile
Install TCP/IP after installation with OS/2 3.0 Connect?
« on: August 10, 2013, 09:17:19 pm »
My OS/2 3.0 Connect installs to the same point every time and fails 9 out of 10 times right when it should install the TCP/networking "Connect" components.  For example here are the steps it goes through:

1. Blue screen install files
2. Graphical screen select stuff like printer, tcp/ip options
3. The "disk" install.  This is from a cdrom, but it is installing Disk 1-15 from the disk folder
4. Fail here
5. When it works it reboots to a while screen with some progress meters
6. TCP/IP and networking is installed.

After the failure I can boot into OS/2 and it looks exactly like OS/2 3.0 without connect.
- I can even do a install from the floppy disks on the cd rom without issue.

What can I run after the installation, from the CD, to install the TCP/IP components into OS/2?



pcm2a

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #1 on: August 10, 2013, 09:45:33 pm »
I thought of a much easier way to phrase this question.  If you have an existing install of os2 3.0 and want to upgrade to connect without erasing anything,  how would you do it?

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 244
  • -Receive: 46
  • Posts: 1642
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #2 on: August 11, 2013, 03:31:03 am »
Hi

Can you give a little more information about the OS/2 version you are using? On the command prompt run "ver /r" to see the revision of the OS/2 Warp 3 you are using.

Regards.

Martin Iturbide
OS2World NewsMaster
... just share the dream.

pcm2a

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #3 on: August 11, 2013, 05:00:05 am »
It's 8200.  Would the software on  the cd vary wildly between versions of 3.0 connect?

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 244
  • -Receive: 46
  • Posts: 1642
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #4 on: August 11, 2013, 06:01:26 pm »
Hi

Please, backup everything first, especially if this is a production enviroment.

On the "OS/2 System" folder there is another folder called "OS/2 Warp Connect Install/Remove".

Inside that folder you can try "Warp Connect Selective Install for Networking".

Regards.
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Fahrvenugen

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 44
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #5 on: August 11, 2013, 10:43:51 pm »
Hi,

On the Warp 3 Connect CD there is off the root a folder called something like:

\img\cid

or maybe it is \cid\img (or something like that... I'm going from memory here and I don't have a CD available right now)

In there you can find a number of folders, there will be one for \tcpapps
and another for \mptn or \mpts

something like that.

In each one of those there are installer EXE's which can allow you to run the individual installs.


pcm2a

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #6 on: August 12, 2013, 12:59:01 am »
Sweet!  These are fresh installs in old laptops just for fun, so nothing "production" related.  I'll try out those methods this week and report back.  On one laptop I did get it working by doing this:

1. Select the default "other" for cdrom
2. The MMTP stuff will start to be installed and then there will be a reboot
3. After the reboot the rest of TCP comes up but will never finish, because "other" was selected for the cdrom
4. Start up from os2 rescue cd, to command prompt
5. Edit config.sys and added "BASEDEV=IBMIDECD.FLT" to the end
6. Reboot and now the tcp finishes installing.

Interesting stuff.  I found that tip on some random old post from 1000 years ago.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1098
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #7 on: August 12, 2013, 01:35:17 am »
Really you should just install the 32 bit stack, a slightly outdated overview is here, you may have to use Google to find some of the stuff but much is still on IBM ftp sites. http://web.archive.org/web/20060926010237/http://www.warpupdates.mynetcologne.de/english/net_mpts.html and also for various other updates, http://web.archive.org/web/20060926004818/www.warpupdates.mynetcologne.de/english/site_contents.html

Alex Taylor

  • Full Member
  • ***
  • Thank You
  • -Given: 10
  • -Receive: 14
  • Posts: 218
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #8 on: August 12, 2013, 05:30:08 am »
I believe the Warp Connect CD has a script 'install' in the root directory which installs the networking stuff on an existing Warp system.

pcm2a

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 6
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #9 on: August 12, 2013, 05:35:04 am »
Interesting...  I have a couple of machines that have Win 3.11 WFW on and I run the tcp 32 bit on them instead of the 16 bit version.  Makes total sense that I would want to do the same on an OS/2 install.

The reason I put the 32 bit tcp on my Win 3.11 is the 16 bit versions wouldn't ftp files between a Win7 machine where the 32 bit would.  I didn't have that problem with OS/2.

Fahrvenugen

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 44
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #10 on: August 14, 2013, 10:37:25 pm »
Hi,

The 32 bit MPTS stack can still be downloaded right from IBM at:

ftp://service.boulder.ibm.com/ps/products/mpts/fixes/english-us/wr08610_conv/

You'll need to install the update at:

ftp://service.boulder.ibm.com/ps/products/mpts/fixes/english-us/wr08621/

and also grab newstack.zip from hobbes.

For the TCP/IP apps, once you've installed the TCP/IP apps on the CD, you'll need to install the fixpak at:

ftp://service.boulder.ibm.com/ps/products/tcpip/fixes/v3.1os2/un00959/

otherwise the apps don't work properly with the 32 bit stack in the MPTS above.

If I recall correctly, you also need to have first updated the base OS/2 Warp 3 install to a newer fixpak (FP 40 or so).  Otherwise there is stuff in the newer mpts which will trap.

FP 40 is at:

ftp://service.boulder.ibm.com/ps/products/os2/fixes/v3.0warp/english-us/xr_w040/

or

ftp://service.boulder.ibm.com/ps/products/os2/rsu/xr_w040/

Good luck!


Alex Taylor

  • Full Member
  • ***
  • Thank You
  • -Given: 10
  • -Receive: 14
  • Posts: 218
    • View Profile
Re: Install TCP/IP after installation with OS/2 3.0 Connect?
« Reply #11 on: August 22, 2013, 06:32:54 pm »
There are a few caveats involved in updating MPTS on Warp 4 without TCP/IP 4.1.  See: http://www.altsan.org/os2/fixpaks/mpts.html (especially the section at the bottom).