Author Topic: Strange and annoying problem with printing.  (Read 1904 times)

Einar Lygre

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 65
    • View Profile
Strange and annoying problem with printing.
« on: December 18, 2013, 11:00:14 pm »
I have two USB printers, Brother HL-2070N B&W laser printer and Lexmark X5150. The last one I can't use under eCS because there is no driver either i eCS or CUPS. The laser printer often "disappear", that means it does not respond when I try to print something and it does not show up in USBDock. The strange thing is that if I open the property book for the printer and then for the output port (USB) I find the message that the printer is OFFLINE (DETACHED). Booting to Vista without touching any cable or switch everything is OK and I can print in Vista. Sometimes (eCS) I just have to move the cable to another USB port, sometime I have to reinstall the printer and sometime it just start working again. The property book for the sheet to be printed has an empty box for the spool file name. Shouldn't there be a spool file?
Any advices?

Einar



Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 254
  • -Receive: 49
  • Posts: 1708
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Strange and annoying problem with printing.
« Reply #1 on: December 19, 2013, 12:19:40 am »
Hi Einar

Can you detail a little bit the USB drivers versions you are using?
Do you have that same USB disconnect behavior with other USB devices (mouse, keyboard)?
Are you using the "Brother HL-2070N B&W laser printer" with CUPS?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Einar Lygre

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 65
    • View Profile
Re: Strange and annoying problem with printing.
« Reply #2 on: December 19, 2013, 07:00:45 pm »
I have been using all the versions from Lars Erdmann and now also the new ones numbered 11.05. Related to the printer they behaves in the same way. But I have had problem with a wireless mouse where I have to unplug and then replug the unifying receiver after a boot. This problem is now fixed in a test driver I have tested, but the problem with the printer is not gone.
I do not use CUPS because there is no driver for my printer in CUPS either. I use the print driver HP LaserJet 6L.
I doubt the problem will be solved when using CUPS  because the message DETACHED is displayed in the property box of the output port immediately after reboot. The Lexmark printer shows up as ATTACHED (online), but as said, I can't use it.
The help file for the output port says "OFFLINE (DETACHED) means that the USB printer is powered off or not connected to the USB host. No actions should be performed with the printer while it is in the offline state."
I have tried to delete the printer and the printer port, and then install a new printer and port, but that is impossible because the installation program says there is no new printer. Maybe this is an USB problem that has lasted for a long time and I am the unlucky one that run into it relatively often.

Lars

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 21
  • Posts: 163
    • View Profile
Re: Strange and annoying problem with printing.
« Reply #3 on: December 28, 2013, 04:51:39 pm »
1) What happens if you unplug and plug back in the Printer ? Does that help ?
2) use Version 11.06 of the Drivers. It has just been released and is available via Betazone.