Author Topic: QT Question  (Read 1305 times)

R.M. Klippstein

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 205
    • View Profile
QT Question
« on: June 04, 2014, 05:30:04 am »
I have QT4 installed on 2.2 beta2. Now I need to compile  a package that needs QT3 (Headers) installed. Question is, Can I have both QT4 and QT3 installed at the same time?

thanks,  klipp



Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1098
    • View Profile
Re: QT Question
« Reply #1 on: June 04, 2014, 06:35:43 am »
You should be able to install the QT3 headers and libs in a different location and use environment variables or flags to differentiate. C_INCLUDE_PATH, CPLUS_INCLUDE_PATH and LIBRARY_PATH or CFLAGS=-Ipath/to/qt3/include, CPLUSFLAGS=-lpath/to/qt3/include, LDFLAGS=-Lpath/to/qt3/lib.
Even better if the developers gave this some thought and the defaults are /usr/include/qt4 and /usr/include/qt3 along with adding a suffix to the libraries to differentiate them. eg libqt4.lib and libqt3.lib
I don't have the QT developers kit installed.