Author Topic: HP 1600 and eCS 2.2 Beta?  (Read 2830 times)

BigGoofyGuy

  • Full Member
  • ***
  • Thank You
  • -Given: 28
  • -Receive: 3
  • Posts: 232
    • View Profile
HP 1600 and eCS 2.2 Beta?
« on: July 07, 2014, 05:46:05 pm »
I have a netbook with eCS 2.2 beta on it. I connected my HP 1600 color laser jet on it. It seems to see it but does not print anything. I want to print something that is really needed.


* * * * * * * *
BigGoofyGuy
 * * * * * * * *

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 38
  • Posts: 937
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #1 on: July 07, 2014, 07:19:05 pm »
eCUPS might work, but see: http://hplipopensource.com/hplip-web/models/color_laserjet/hp_color_laserjet_1600.html. It is a Linux page, but eCUPS is a Linux port, so the information should relate to your device.

For eCUPS see: http://trac.netlabs.org/ecups.

Paul Smedley

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 46
  • Posts: 355
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #2 on: July 07, 2014, 10:09:58 pm »
eCUPS might work, but see: http://hplipopensource.com/hplip-web/models/color_laserjet/hp_color_laserjet_1600.html. It is a Linux page, but eCUPS is a Linux port, so the information should relate to your device.

For eCUPS see: http://trac.netlabs.org/ecups.

It will NOT work with CUPS. From that page:
"Driver Plugin Information:
This printer REQUIRES a downloadable driver plug-in. Use hp-setup to install the printer, and to download and install the plug-in. In general, required driver plugins are required for printing support. Driver plug-ins are released under a proprietary (non-open) license and are not part of the HPLIP tarball release."

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 8
  • -Receive: 91
  • Posts: 1171
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #3 on: July 08, 2014, 01:36:22 am »
Wonder how hard it would be to make these binary blobs work on OS/2? I guess it depends if they only interact with cups or if they have a kernel module. XFree could load Linux video drivers and use them with the Elf loader

Alex Taylor

  • Full Member
  • ***
  • Thank You
  • -Given: 10
  • -Receive: 14
  • Posts: 218
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #4 on: July 09, 2014, 01:46:24 am »
According to this it should work with the foo2hp package: http://foo2hp.rkkda.com/

You could try with Paul's port of foo2qpdl (available on the eCups site) which includes foo2hp.

BigGoofyGuy

  • Full Member
  • ***
  • Thank You
  • -Given: 28
  • -Receive: 3
  • Posts: 232
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #5 on: September 02, 2014, 03:24:49 pm »
Thank you for the help. It is appreciated.  8)
* * * * * * * *
BigGoofyGuy
 * * * * * * * *

Alex Taylor

  • Full Member
  • ***
  • Thank You
  • -Given: 10
  • -Receive: 14
  • Posts: 218
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #6 on: September 03, 2014, 12:59:40 pm »
Thank you for the help. It is appreciated.  8)

Did you have any luck, then?

BigGoofyGuy

  • Full Member
  • ***
  • Thank You
  • -Given: 28
  • -Receive: 3
  • Posts: 232
    • View Profile
Re: HP 1600 and eCS 2.2 Beta?
« Reply #7 on: September 03, 2014, 03:19:09 pm »
Having to move, the printer was too big and bulky to take with me.  :'(
* * * * * * * *
BigGoofyGuy
 * * * * * * * *