Author Topic: Static and looping audio with UniAud  (Read 2195 times)

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 6
  • -Receive: 18
  • Posts: 309
    • View Profile
    • Blonde Guy
Static and looping audio with UniAud
« on: September 04, 2014, 04:52:58 am »
I'm installing eCS 2.2 beta II on a Lenovo ThinkCentre M32 thin client. This is pretty new, not everyone has it for sale yet. eCS mostly works, but the sound is staticy and loopy. Moving the mouse around fast influences the static and loopiness.

There was an old bug with static and loopiness, but that was for SND.DLL and supposed to be fixed by MMFIX.EXE.

Any idea how to troubleshoot?


Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Eugene Gorbunoff

  • Full Member
  • ***
  • Thank You
  • -Given: 3
  • -Receive: 3
  • Posts: 104
    • View Profile
Re: Static and looping audio with UniAud
« Reply #1 on: September 04, 2014, 09:40:27 am »
Uniaud doesn't work properly with computers manufactured after .. ~ 2010.

Solution:
* Use USB Audio adapter
* Install old C-Media card / Creative

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 6
  • -Receive: 18
  • Posts: 309
    • View Profile
    • Blonde Guy
Re: Static and looping audio with UniAud
« Reply #2 on: September 05, 2014, 03:54:41 am »
Thin clients don't have slots so no possibility of installing any other sound card.
UniAud recognized the hardware, and it nearly works.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

André Heldoorn

  • Full Member
  • ***
  • Thank You
  • -Given: 37
  • -Receive: 8
  • Posts: 246
    • View Profile
Re: Static and looping audio with UniAud
« Reply #3 on: March 24, 2017, 04:53:29 am »
Quote from: thinkwiki.org
the ALSA intel8x0 driver plays sound too fast. The following /etc/asound.conf restores normal operation:

Code: [Select]
  pcm.intel8x0-hw {
  type hw
  card 0
  }
 
  pcm.!default {
  type plug
  slave.pcm "intel8x0"
  }
 
  pcm.intel8x0 {
  type dmix
  ipc_key 1234
  slave {
  pcm "hw:0,0"
  period_time 0
  period_size 512
  buffer_size 4096
  rate 44100
  }
  }
 
  ctl.intel8x0-hw {
  type hw
  card 0
  }

Regarding UniAud and shooting troubles, is there a way to execute (the equivalent of) this code with OS/2?