Author Topic: OS/2 Warp 4 and Virtualbox  (Read 4305 times)

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
OS/2 Warp 4 and Virtualbox
« on: September 20, 2014, 11:41:44 am »
Hi all,
I found my old IBM OS/2 Warp 4.0 ITalian edition and just installed inside Virtualbox 4.1.12 on linux, applied fixpack XRIM015, installed guestadd for os/2, snap device driver 3.1.8, on reboot i got the DOSCALL1.DLL error in attach (but after, os/2 continue boot quite well), and the system does not shutdown anymore via warpcenter button, i need to send ctrl+alt+canc signal via virtualbox menu, vbox settings are:
guest os:
    OS/2 Warp 4,
ACPI:
    activated,
IO ACPI:
    not active,
VT-x/AMD-V:
    active,
nested paging:
    active,
audio controller:
    SoundBlaster16,
serial port:
    deactivated
Also, since i don't remember, what i need (and where are/find) to add install/fix network.
Thanks for your suggestions.



Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 245
  • -Receive: 46
  • Posts: 1646
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS/2 Warp 4 and Virtualbox
« Reply #1 on: September 20, 2014, 04:23:38 pm »
Hi Barbara.

Have you tried de-activating ACPI? I think that if you are not running the ACPI driver on Warp 4, the VM should run without.

I documented Warp 4.52 running as guest on VirtualBox some time ago here: http://www.os2world.com/wiki/index.php/VirtualBox_Guest. Maybe it can give you hint with the network.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: OS/2 Warp 4 and Virtualbox
« Reply #2 on: September 20, 2014, 05:08:39 pm »
Yes, i read this, and finally i found how to install mpts, but maybe something went wrong: loading network driver hangs machine, i need to reboot..rem out lines in config.sys let me boot, but trying to reconfigure mpts, the interface does not start anymore.
Clearly, there was some critical steps i forgot, like the features install, java and TCP/IP Configuration (java interface), could someone refresh me those steps?
Thanks.

Barbara

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 4
  • Posts: 144
    • View Profile
Re: OS/2 Warp 4 and Virtualbox
« Reply #3 on: September 20, 2014, 05:38:09 pm »
Ok, fortunately I uninstalled everything without having to reinstall os/2 itself, now I only have the fixpack 15, addons for vbox and snap, OS/2 ver is 4.5 and kernel is 14.062_W4 and warpcenter shutdown now works again (still DOSCALL1.DLL erron on boot).
« Last Edit: September 20, 2014, 05:46:25 pm by Barbara »