OS2 World Community Forum

OS/2, eCS & ArcaOS - Technical => Applications => Topic started by: Lars on February 22, 2015, 08:49:39 pm

Title: AOOo 4111GA does not install libc066
Post by: Lars on February 22, 2015, 08:49:39 pm
I tried the WPI method (rpm WPI on same directory as the base WPI): it does not work
I then tried to run yum with the command line given in the readme: I get told that Python cannot find urlgrabber and then that's it

libc066.dll is not installed and therefore none of the applications works.

Can someone tell me where to get libc066.dll ?
Title: Re: AOOo 4111GA does not install libc066
Post by: guzzi on February 22, 2015, 09:02:59 pm
http://rpm.netlabs.org/release/00/zip/libc-0_6_6-26_oc00.zip if you want to get your yum/rpm running again
ftp://ftp.netlabs.org/pub/gcc/libc-0_6_6-csd6.wpi as wpi when you donĀ°t use yum/rpm
Title: Re: AOOo 4111GA does not install libc066
Post by: Mark on February 23, 2015, 02:57:03 am
I may have had the same urlgrabber problem you are having.  I eventually had to copy the urlgrabber directory from the old Python release directory into the new Python release folder.  There isn't one in the new python folder so you will not overwrite anything.  But if it is indeed present in both python directories, the you have a different problem than I had.
Title: Re: AOOo 4111GA does not install libc066
Post by: guzzi on February 23, 2015, 10:16:23 am
There was also a defect, now fixed, where the urlgrabber dir was in upper case instead of lower case.
Title: Re: AOOo 4111GA does not install libc066
Post by: ivan on February 23, 2015, 11:14:17 am
Quote
There was also a defect, now fixed, where the urlgrabber dir was in upper case instead of lower case.

Ah, the joys of using software from a case sensitive operating system on one that is case insensitive.

Isn't there a way to make the ports case insensitive when on OS/2?
Title: Re: AOOo 4111GA does not install libc066
Post by: Alex Taylor on February 24, 2015, 04:40:32 am
Lars: That sounds like the bug where updating Python to 2.7 would break urlgrabber and thus yum.  The fix is to xcopy the \usr\lib\python2.6\site-packages\urlgrabber directory to \usr\lib\python2.7\site-packages\urlgrabber, then run 'yum update urlgrabber'.
Title: Re: AOOo 4111GA does not install libc066
Post by: Lars on February 28, 2015, 12:45:49 pm
Oh, thanks a lot. I don't have a clue about this yum/rpm stuff. I did as you suggested. At least that worked and downloaded and installed a bunch of things I don't know about.

I had already found the ftp://ftp.netlabs.org/pub/gcc/libc-0_6_6-csd6.wpi (or rather, the equivalent zip file) and installed that which cured the problem with AOOo 4111GA.

To be honest: I don't like the yum/rpm stuff as I cannot see what it is doing and how to fix problems with it. But I don't want to start a flame war ...