OS2 World Community Forum

OS/2, eCS & ArcaOS - Technical => Hardware => Topic started by: Martin Iturbide on September 27, 2017, 12:07:18 am

Title: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 27, 2017, 12:07:18 am
Hi

I was working on the OS2World wiki last weekend and organizing a little bit the "Laptops page (http://www.os2world.com/wiki/index.php/Laptop_Computers)".

It made me wonder if it will make some sense to try to put some focus on the "Hardware (http://www.os2world.com/wiki/index.php/Category:Hardware)" area of the wiki this year with reported ArcaOS working hardware on the wiki this year.

If so, it will make sense to me to start documenting some "Post 2010" laptops on the wiki, ( I mean laptops manufactured on the year 2010 or later). Which it does not mean that you are not free to document older laptops, but post 2010 year will be my focus.

If you want to help me this with this please post your experience with your post-2010 laptop on this thread (or send me by email) and post the following:

Detach anything from your laptop ports.
- Laptop model name and brand
- Laptop model number
- PCI.exe report ("[C:\sys\install\detect\pci.exe >pciout.txt")
- General Comments: Any special remark on how you installed ArcaOS, or any trick you used to make some specific device to work.

- Any ideas of what other hardware report will be interesting? is pci.exe enough to have more details of what is attached to the USB ports?

Let me know if you want to share on this initiative.

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Neil Waldhauer on September 27, 2017, 06:10:29 am
Most of these are pre-2010. Only The T540p is newer.

http://www.blondeguy.com/ComputersForSale.html (http://www.blondeguy.com/ComputersForSale.html)


I'd suggest that a template won't work for categorizing. Really, if the laptop is at all modern, you probably want to go for an essay format or a Youtube video like Sigurd Fastenrath.
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 27, 2017, 02:07:42 pm
Hi Neil.

Thanks for the pointer. I included the T540p on the Wiki (http://www.os2world.com/wiki/index.php/Lenovo_Thinkpad_T540p) with links to your review.  It can be great if you can send me or post the PCI report and the full model number to include more details.

Just a little typo on your page. On "http://www.blondeguy.com/ComputersForSale.html" it list the  Thinkpad T540p/strobopeep as "W540p"

I agree that making an essay format page or a YouTube video is great and I encourage user to do it too, but on the case of the wiki I want the details and HardwareId numbers so people that has similar hardwareIDs can search other machines that work or not with it.

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 27, 2017, 05:01:48 pm
Hi

Checking a little but more about this subject I found out that posting the "MACHINE.CFG" file is also interesting. On ArcaOS is located at C:\sys\install\rsp.

I don't know much about it, is there a way to generate a new report, is there a Britt Turnbull stand alone utility for it?

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Pete on September 27, 2017, 08:39:34 pm
Hi Martin

You can always use [BootDrive]:\sys\install\DETECT\pci.exe to generate a devices report for ArcaOS - on eCS systems that is [BootDrive]:\ecs\install\DETECTEI\PCI.EXE

Use this command
   pci /?
to get a list of parameters.


Regards

Pete
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 28, 2017, 05:47:41 pm
Thanks Pete

I found some interesting reports from the PCI /? switch.

I found that "dmidecode", that is also installed on ArcaOS (c:\sys\apps\anpm), is also interesting to extract hardware information. It provides mode details on the supported things on the BIOS. If someone want to share that report, notice that it may be good to "redact" the hardware serial numbers for privacy.

I took some samples of a old computer I have on the office:
http://www.os2world.com/wiki/index.php/D865GBF_Hardware_Report (http://www.os2world.com/wiki/index.php/D865GBF_Hardware_Report)

Anybody knows if there is a command line tool that can take a report of each USB device installed/plugged? Like the USB Device Monitor (http://www.os2world.com/wiki/index.php/USB_Device_Monitor), but that can query and report all at once?

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Pete on September 28, 2017, 07:01:04 pm
Hi Martin

Are there any parameters for dmidecode? I ask because using dmidecode gives this result:-

[M:\SYS\APPS\ANPM]dmidecode
# dmidecode 2.12
SMBIOS 2.7 present.
58 structures occupying 2541 bytes.
Table at 0xCEB94018.

Invalid entry length (0). DMI table is broken! Stop.


Regards

Pete


Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 28, 2017, 07:38:33 pm
Hi Pete

I just run "dmidecode.exe >report.txt" and got the report from that mainboard. It even seems we are using the same version of dmidecode, would it be something incompatible with the BIOS?

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Pete on September 29, 2017, 02:48:08 am
Hi Martin

My guess is that either the software is not up to the job with this mainboard or there is a problem with the DMI table which does not affect the use of the mainboard at all.

i had a look for the problem using Google and found a lot of results including this helpful advice

  Bugs
  More often than not, information contained in the DMI tables is inaccurate, incomplete or simply wrong. 

found at https://linux.die.net/man/8/dmidecode


Regards

Pete

Title: Re: Post 2010 Laptops running ArcaOS
Post by: Wim Brul on September 29, 2017, 10:40:28 am
Hi Martin,

Quote
Anybody knows if there is a command line tool that can take a report of each USB device installed/plugged?

Paul Smedley has ported LSUSB which will do the job. There is an LSUSB link on his libusb-1-0 (http://os2ports.smedley.id.au/index.php?page=libusb-1-0) page.

Code: [Select]
lsusb -v
Regards,

Wim.
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 29, 2017, 11:39:32 pm
Paul Smedley has ported LSUSB which will do the job. There is an LSUSB link on his libusb-1-0 (http://os2ports.smedley.id.au/index.php?page=libusb-1-0) page.

Code: [Select]
lsusb -v

Thanks Wim, I didn't know about lsusb. I'm playing with it right now.
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 29, 2017, 11:45:13 pm
  Bugs
  More often than not, information contained in the DMI tables is inaccurate, incomplete or simply wrong. 

Hi Pete.

Maybe that is what we can expect from "dmidecode.exe". I will try it on other systems next week to see if it fails.

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Mike Kölling on September 30, 2017, 01:02:08 pm
Most of these are pre-2010. Only The T540p is newer.

http://www.blondeguy.com/ComputersForSale.html (http://www.blondeguy.com/ComputersForSale.html)

My Thinkpad X250 is newer than 2010 and I can boot it from AOS5-DVD. No installation so far, because I have a running eCS2.1 with latest ArcaNoae drivers. Never touch a running system  :). Even sound is comming to live with the latest AN driver (A1- switch). But only after a warm boot if W7 was running before. Booting from cold - no sound, but at least no error messages of missing sound driver any longer in some applications.

Greetings from Potsdam, Germany,
Mike
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on September 30, 2017, 02:00:34 pm
Hi Mike

Can it be possible for you to share the pci.exe report of your ThinkPad X250 to also be included on the wiki page (http://www.os2world.com/wiki/index.php/Lenovo_ThinkPad_X250)?

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Pete on September 30, 2017, 05:27:38 pm
Hi Mike

I have an old Acer Travelmate laptop that does not produce sound with any uniaud driver unless I turn on and set volume using a cmd file in the Startup folder.

I suggest you use unimix to check the state of the soundcard and see if that might work for your laptop.


Regards

Pete
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Mike Kölling on October 01, 2017, 11:22:38 am
Hi, Thanks for the advice. Unfortunately neither Unimix nor pmUnimix are solving the problem. I have tried in the past as well with the latest AN drivers.
Mike
Title: Re: Post 2010 Laptops running ArcaOS
Post by: David McKenna on October 01, 2017, 07:10:25 pm
Hi Martin,

   I installed ArcaOS on a refurbished HP Probook 6570b I got back in May just for ArcaOS ($250US). It has a 3rd gen i5 processor, 8GB RAM, a 120GB SSD drive and came with Windows 10 installed. I set it up to have Win10 and ArcaOS boot using Airboot. The only issue installing was it did not detect my serial port, but easy to install manually. Everything that should work does (no WiFi, but installed card is one listed as supported by IWM if it is ever finished) except sound, which 'works' but is distorted and echos. PCI log attached.
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on October 02, 2017, 03:52:39 am
Thanks David.

I just posted that laptop on the wiki. http://www.os2world.com/wiki/index.php/HP_Probook_6570b (http://www.os2world.com/wiki/index.php/HP_Probook_6570b)

Regards
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Mike Kölling on October 02, 2017, 01:33:55 pm
Hi Mike

Can it be possible for you to share the pci.exe report of your ThinkPad X250 to also be included on the wiki page (http://www.os2world.com/wiki/index.php/Lenovo_ThinkPad_X250)?

Regards

Here you are.
Mike

P.S. Added new pci.exe report based at today's PCI.IDS. - 20171002 7:20PM German Summer Time
Title: Re: Post 2010 Laptops running ArcaOS
Post by: Martin Iturbide on October 18, 2017, 12:17:23 am
Hi

I just posted something quick about the "HP Pavilion g6-1d18dx (http://www.os2world.com/wiki/index.php/HP_Pavilion_g6)".

Regards