Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Barbara

Pages: [1]
1
General Discussion / Setting right a WinOS/2 printer
« on: May 28, 2016, 06:54:06 pm »
Hi all!
I urgently need to print some powerpoint 4.3 for WfW slides made long ago into landscape format.
The file is not recognized by AOO (wrong version) and the PS output from WinOS/2 PrintManager comes only in a portrait format!
Where can i set the right output?
I've no time now to search for an alternate solution or to manage a virtualbox installation, i need them for monday!
Meanwhile I'm trying to open it using other office suites for OS/2.
Thanks for any suggestions!

2
Setup & Installation / RPM/YUM update
« on: February 01, 2015, 12:11:45 pm »
Hi,
could someone help me?
got this error updating yum:

[C:\]yum update
Impostazione processo di aggiornamento
Errore: Il pacchetto con tupla ('libgcc446', 'i386', '0', '4.4.6.17', '1.oc00') non è stato trovato nel rpmdb

[C:\]

always working...until now, my active repos are both, release and experimental
Thanks in advantage

3
Setup & Installation / OS/2 Warp 4 and Virtualbox
« on: September 20, 2014, 11:41:44 am »
Hi all,
I found my old IBM OS/2 Warp 4.0 ITalian edition and just installed inside Virtualbox 4.1.12 on linux, applied fixpack XRIM015, installed guestadd for os/2, snap device driver 3.1.8, on reboot i got the DOSCALL1.DLL error in attach (but after, os/2 continue boot quite well), and the system does not shutdown anymore via warpcenter button, i need to send ctrl+alt+canc signal via virtualbox menu, vbox settings are:
guest os:
    OS/2 Warp 4,
ACPI:
    activated,
IO ACPI:
    not active,
VT-x/AMD-V:
    active,
nested paging:
    active,
audio controller:
    SoundBlaster16,
serial port:
    deactivated
Also, since i don't remember, what i need (and where are/find) to add install/fix network.
Thanks for your suggestions.

4
Networking / Network clarification question
« on: September 12, 2014, 06:23:14 pm »
Hi,
Could not be the right place this, sorry, but i need a clarification about network connections. Where i live we are three users to share the same Internet connection, a main router, and a wireless one, connected to main, used by two users, including myself. Is there a way to get the my connection completely open like for the main router? The main's router owner says the open connection is available only for his router and for a single connection, so if need to see some sites with restrictions/limitations, behind a firewall, as we, wireless users, are, i always have to ask a favor to the owner of the main router, could not be a problem, sure but he could be bored on long time.
Is this true or is it possible to configure a "double" opened connection?
Thanks for any suggestion.

5
Hi all,
The Italian community of OS/2 users would planning the conversion of most of the manuals in "inf/hlp" format for the development tools available on our platform into printable pdf format, ready for printing purposes by developers, to facilitate their wonderful efforts. We believe it is an excellent initiative, because the classic paper book is always useful and sometimes faster than internet to navigate and it should be always available for a developer.
If the initiative is welcome, we need a list of the main most used toolkit or otherwise most requested.
We will upload all on Hobbes.
Regards

6
Programming / Agena programming language
« on: August 23, 2014, 06:14:57 pm »
Hi, seem that the Agena programming language is not more developed for our community, i asked to the author for an update. I think that for study is a great software. Waiting for an answer.
Agena is now at 2.2.6 version, and we are at 1.1.3, does we need also the gdi and the agenaeditor?

7
Programming / Agena programming language
« on: August 23, 2014, 11:24:51 am »
Hi, all,
About Agena programming language, is there still a mantainer?
http://agena.sourceforge.net/
This is not more available:
http://downloads.sourceforge.net/agena/agena-1.3.3-os2.wpi

8
Storage / SSD on IBM T23
« on: June 17, 2014, 08:18:43 pm »
Hi all
I would like to upgrade the disk on my old ibm t23, a similar solution (IDE-PATA to microSATA adapter + 128GB SSD), in my case,  does it works on eCS?:

http://www.ebay.it/itm/IDE-44-Pin-to-1-8-Micro-SATA-Adapter-/291030890621?pt=US_Drive_Cables_dapters&hash=item43c2caf87d

http://www.ebay.it/sch/i.html?_trksid=p2047675.m570.l1313.TR0.TRC0.H0&_nkw=Ssd+Kingston+Sms200s3/120g&_sacat=0&_from=R40
More suggestions?
Thanks

9
General Discussion / Backgroud celebrating 25 years old of OS/2 Warp
« on: September 30, 2013, 01:06:23 pm »
Months ago someone asked me the background bitmap that could be seen in a post here. I found them again, I made them last winter in gimp ​​waiting eCSoft/2 came back online. After understand how to do an upload on Hobbes, I still wrong, sorry  ::) !
Ciao

10
Setup & Installation / eCenter Window list widget
« on: August 28, 2013, 03:24:26 pm »
Hi all, i lost all Window list configuration, so i can't switch between tasks simply clicking on its button into the eCenter, is there a way to reset the widget to default values?

11
Setup & Installation / Internet USB Key Huawei E353 and SafeFire PPP
« on: August 19, 2013, 07:58:14 pm »
Hi, since i never used Safefire, can someone help me try to operate/connect the modem in subject?
Those are my output and config.sys statements:

Config.sys

PSD=ACPI.PSD
DEVICE=C:\OS2\BOOT\PSCOM.SYS (1,3F8,4)
DEVICE=C:\os2\boot\usbcom.sys /V /N:COM2 /M:1 /I:32 /O:32

outputs are


 * Works with libusb 0.1.12 and probably other versions

Looking for default devices ...
 Found default devices (1)
Accessing device 001 on bus 000 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
 Cant't do driver detection and detaching on this platform.
 Could not send INQUIRY message (error -22)

Device description data (identification)
-------------------------
Manufacturer: HUAWEI
     Product: HUAWEI Mobile
  Serial No.: not provided
-------------------------
 Cant't do driver detection and detaching on this platform.
Setting up communication with interface 0 ...
Trying to send the message to endpoint 0x01 ...
 OK, message successfully sent
Device is gone, skipping further steps ...
-> Run lsusb to note any changes. Bye.


[C:\]


 * usb_modeswitch: tool for controlling "flip flop" mode USB devices
 * Version 1.0.2 (C) Josua Dietze 2009
 * Works with libusb 0.1.12 and probably other versions

Looking for target devices ...
 No devices in target mode or class found
Looking for default devices ...
 Found default devices (1)
Accessing device 003 on bus 000 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
 Cant't do driver detection and detaching on this platform.
 Could not get INQUIRY response (error -22)

Device description data (identification)
-------------------------
Manufacturer: HUAWEI
     Product: HUAWEI Mobile
  Serial No.: not provided
-------------------------
 Cant't do driver detection and detaching on this platform.
Setting up communication with interface 0 ...
Trying to send the message to endpoint 0x01 ...
 OK, message successfully sent
Device is gone, skipping further steps ...
-> Run lsusb to note any changes. Bye.


C:\mode com2
baud     = 345600                 parity   = NONE
databits = 8                      stopbits = 1
TO       = OFF                    XON      = OFF
IDSR     = OFF                    ODSR     = OFF
OCTS     = ON                     DTR      = OFF
RTS      = ON                     BUFFER   = N/A

C:\
We are on a Thinkpad X61s, running eCS 2.2 beta, following instructions from http://ru.ecomstation.ru/showarticle.php?id=256
Thanks in advantage.

12
Utilities / Innotek font engine
« on: April 06, 2013, 10:53:06 am »
There is still a need to use innotek font engine, or you can delete it? there are still programs that use this library? The libraries alternatives for mozilla suite and truetype.dll substitute for the wps can be considered as substitute?

13
Setup & Installation / Migration problems
« on: January 13, 2013, 12:12:04 pm »
Hi all,
Can someone explain me this and help:
I reinstalled eCS 2.1 with migration because my monitor visualized permanently characters and icons after closing some win32 applications like first pic (I've tried everything hope, unsuccessfully, reinstall inevitable).
After that, i have not more plugins in seamonkey and all the statements and all the software needed is right installed.
This is all my config.sys:

PSD=ACPI.PSD
REM [ Device Drivers ]
DEVICE=C:\OS2\BOOT\UNICODE.SYS
IFS=C:\ecs\boot\ntfs.ifs
IFS=C:\OS2\JFS.IFS /LW:5,20,4 /AUTOCHECK:*
IFS=C:\OS2\HPFS.IFS /CACHE:2048 /CRECL:4 /AUTOCHECK:*
IFS=C:\ECS\BOOT\FAT32.IFS /CACHE:2048 /H /Q /EAS
DEVICE=C:\IBMCOM\PROTOCOL\LANPDD.OS2
DEVICE=C:\IBMCOM\PROTOCOL\LANVDD.OS2
IFS=C:\OS2\BOOT\UDF.IFS /Q
IFS=C:\OS2\BOOT\CDFS.IFS /Q /W
DEVICE=C:\OS2\BOOT\OS2CDROM.DMD /Q
DEVICE=C:\OS2\MDOS\VCDROM.SYS
DEVICE=C:\IBMCOM\LANMSGDD.OS2 /I:C:\IBMCOM /S
DEVICE=C:\IBMCOM\PROTMAN.OS2 /I:C:\IBMCOM
REM DEVICE=C:\OS2\BOOT\TESTCFG.SYS
DEVICE=C:\OS2\BOOT\TESTCFG2.SYS
DEVICE=C:\OS2\BOOT\DOS.SYS
DEVICE=C:\OS2\BOOT\PMDD.SYS
DEVICE=C:\OS2\MDOS\VEMM.SYS
DEVICE=C:\OS2\MDOS\VXMS.SYS /UMB
DEVICE=C:\OS2\MDOS\VDPMI.SYS
DEVICE=C:\OS2\MDOS\VDPX.SYS
DEVICE=C:\OS2\MDOS\VWIN.SYS
DEVICE=C:\OS2\MDOS\VW32S.SYS
DEVICE=C:\OS2\MDOS\VPCMCIA.SYS
DEVICE=C:\OS2\BOOT\PCMSSDIF.SYS
DEVICE=C:\OS2\MDOS\VMOUSE.SYS
DEVICE=C:\OS2\BOOT\POINTDD.SYS
DEVICE=C:\OS2\BOOT\COM.SYS
DEVICE=C:\OS2\MDOS\VCOM.SYS
DEVICE=C:\OS2\BOOT\$ICPMOS2.SYS /G
DEVICE=C:\OS2\BOOT\USBPRT.SYS
DEVICE=C:\ECS\SYSTEM\AMouse\AMOUSE.SYS SMP
DEVICE=C:\ECS\SYSTEM\AMouse\USBMOUSE.SYS
DEVICE=C:\OS2\BOOT\USBKBD.SYS
REM DEVICE=C:\OS2\BOOT\USBCOM.SYS
DEVICE=C:\MPTN\PROTOCOL\SOCKETSK.SYS
DEVICE=C:\MPTN\PROTOCOL\AFOS2.SYS
DEVICE=C:\MPTN\PROTOCOL\AFINETK.SYS
DEVICE=C:\MPTN\BIN\VDOSTCP.VDD
DEVICE=C:\IBMCOM\PROTOCOL\TCPBEUI.OS2
DEVICE=C:\IBMLAN\NETPROG\RDRHELP.200
IFS=C:\IBMLAN\NETPROG\NETWKSTA.200 /I:C:\IBMLAN /N
DEVICE=C:\IBMCOM\PROTOCOL\NETBIOS.OS2
DEVICE=C:\IBMCOM\MACS\IBMPRISM.OS2
DEVICE=C:\IBMCOM\MACS\E100B.OS2
DEVICE=C:\IBMLAN\NETPROG\VNETAPI.OS2
DEVICE=C:\TCPIP\bin\vdostcp.sys
DEVICE=C:\MPTN\PROTOCOL\FWIP.SYS
IFS=C:\PROGRAMS\RSJCD\CDWFS.IFS /S
DEVICE=C:\MMOS2\ssmdd.sys /S:64 /P:64 /H:256 /Q:1024 /E:1024
DEVICE=C:\MMOS2\r0stub.sys
DEVICE=C:\MMOS2\MMPLAYER\midi.sys
DEVICE=C:\MMOS2\vcshdd.sys
DEVICE=C:\MMOS2\UNIAUD32.SYS /V
DEVICE=C:\MMOS2\UNIAUD16.SYS /V /C
IFS=C:\ECS\BOOT\EVFS.IFS
DEVICE=C:\ecs\boot\USBRESMG.SYS

REM [ Base Device Drivers ]
BASEDEV=APM.ADD
BASEDEV=IBMKBD.SYS
BASEDEV=TIMER0.SYS
BASEDEV=PRINT01.SYS
BASEDEV=CHKDSK.SYS
BASEDEV=PCMCIA.SYS /P
BASEDEV=IBM2SS14.SYS
BASEDEV=AUTODRV2.SYS
BASEDEV=USBUHCD.SYS
BASEDEV=USBUHCD.SYS
BASEDEV=USBUHCD.SYS
BASEDEV=USBD.SYS
BASEDEV=USBHID.SYS
BASEDEV=CADH.SYS
BASEDEV=DANIS506.ADD /!BIOS
BASEDEV=IBM1FLPY.ADD
REM  BASEDEV=IBM2FLPY.ADD
BASEDEV=USBMSD.ADD /REMOVABLES:8 /FLOPPIES:1
BASEDEV=USBCDROM.ADD
BASEDEV=DANIATAP.FLT
BASEDEV=OS2DASD.DMD
BASEDEV=OS2LVM.DMD

REM [ Paths ]
SET BEGINLIBPATH=C:\PROGRAMS\JDK6\bin;%BEGINLIBPATH%
LIBPATH=C:\usr\lib;.;C:\USR\LOCAL\LIB;C:\PROGRAMS\RSJCD;C:\IBMLAN\NETLIB;C:\MUGLIB\DLL;C:\ECS\DLL;C:\EMX\DLL;C:\OS2\DLL;C:\MPTN\DLL;C:\TCPIP\DLL;C:\IBMCOM\DLL;C:\IBMGSK50\LIB;C:\IBMGSK40\LIB;C:\IBMGSK\LIB;C:\OS2\MDOS;C:\;C:\OS2\APPS\DLL;C:\ECS\SYSTEM\AMOUSE;C:\MMOS2\DLL;C:\MMOS2\FREEDB;C:\PROGRAMS\4OS2;C:\MMOS2\MPLAYER;
SET PATH=C:\usr\sbin;C:\usr\bin;C:\USR\LOCAL\BIN;C:\MPTN\BIN;C:\TCPIP\BIN;C:\IBMCOM;C:\IBMLAN\NETPROG;C:\MUGLIB;C:\ECS\BIN;C:\EMX\BIN;C:\IBMGSK50\BIN;C:\IBMGSK40\BIN;C:\IBMGSK\BIN;C:\OS2;C:\OS2\SYSTEM;C:\OS2\MDOS\WINOS2;C:\OS2\INSTALL;C:\;C:\OS2\MDOS;C:\OS2\APPS;C:\ECS\KLIBC\BIN;C:\PROGRAMS\JDK6\BIN;C:\PROGRAMS\RSJCD;C:\MMOS2\FREEDB;C:\MMOS2;C:\MMOS2\MMPLAYER;C:\PROGRAMS\4OS2;C:\MMOS2\MPLAYER;C:\MMOS2\MPLAYER\CODECS;
SET DPATH=C:\MPTN;C:\IBMCOM;C:\IBMLAN\NETPROG;C:\IBMLAN;C:\MUGLIB;C:\ECS\LANG;C:\IBMCOM\MACS;C:\OS2;C:\OS2\SYSTEM;C:\OS2\MDOS\WINOS2;C:\OS2\INSTALL;C:\;C:\OS2\BITMAP;C:\OS2\MDOS;C:\OS2\APPS;C:\MMOS2;C:\MMOS2\INSTALL;C:\PROGRAMS\4OS2;
SET HELP=C:\MPTN;C:\MPTN\HELP;C:\ecs\help;C:\OS2\HELP;C:\ecs\system\ewps\help;C:\ECS\SYSTEM\AMouse;C:\IBMLAN\NETPROG;C:\TCPIP\HELP;C:\PROGRAMS\RSJCD;C:\MMOS2\HELP;C:\PROGRAMS\4OS2;
SET ULSPATH=C:\LANGUAGE
SET BOOKSHELF=C:\IBMLAN\NETPROG;C:\OS2\BOOK;C:\ecs\book;C:\EMX\BOOK;C:\TCPIP\HELP;C:\MMOS2;C:\PROGRAMS\4OS2;
SET EPMPATH=C:\OS2\APPS;
SET NLSPATH=C:\MPTN\MSG\NLS\%N;C:\TCPIP\msg\ENUS850\%N;
SET MOZ_PLUGIN_PATH=C:\PROGRAMS\MOZ_PLUG
SET LIBC_HOOK_DLLS=C:\OS2\DLL\klibccfg.dll@_kLIBCInitPath!pathrewrite
SET DMIPATH=C:\DMISL\BIN
REM SET CLASSPATH=C:\os2\javaapps\lvmgui.zip;C:\TCPIP\java;
SET ICEDTEA_WEB_JRE=C:\PROGRAMS\JDK6\jre
SET ICEDTEA_WEB_DATA=C:\PROGRAMS\JDK6\jre\lib
SET NWDBPATH=C:\IBMLAN\NETPROG
SET DSPPATH=C:\MMOS2\DSP;

SET MPLAYER_HOME=C:\HOME\DEFAULT\.mplayer
SET MPLAYER_CODECS_DIR=C:\MMOS2\MPLAYER\codecs
SET MPLAYER_PATH=C:\MMOS2\MPLAYER\mplayer.exe


SET PM_ASYNC_FOCUS_CHANGE=ON 9000
SET QUEUE_SIZE_THRESHOLD=20000


REM [ Device Information ]
DEVINFO=KBD,IT141,C:\OS2\KEYBOARD.DCP

REM [ Kernel Directives ]
AUTOFAIL=YES
BREAK=OFF
BUFFERS=90
CLOCKSCALE=4
CODEPAGE=850,437
COUNTRY=039,C:\OS2\SYSTEM\COUNTRY.SYS
DISKCACHE=1024,LW,32
DOS=LOW,NOUMB
EARLYMEMINIT=TRUE
FCBS=16,8
FILES=64
IOPL=YES
MAXWAIT=1
MEMMAN=SWAP,PROTECT
PRINTMONBUFSIZE=134,134,134
PRIORITY_DISK_IO=YES
PROTECTONLY=NO
PROTSHELL=C:\OS2\PMSHELL.EXE
RESERVEDRIVELETTER=R
RMSIZE=640
SHELL=C:\OS2\MDOS\COMMAND.COM C:\OS2\MDOS
SUPPRESSPOPUPS=C
SWAPPATH=C:\OS2\SYSTEM 2048 2048
THREADS=1024
VIRTUALADDRESSLIMIT=1536

REM [ Environment Variables ]
SET AUTOSTART=PROGRAMS,TASKLIST,FOLDERS
SET COMSPEC=C:\OS2\CMD.EXE
REM SET DELDIR=C:\DELETE,512;S:\DELETE,512;U:\DELETE,512;Z:\DELETE,512;
SET DEVICEFONTDISABLED=NO
SET DIRCMD=/V
SET DISPLAYTYPE=VGA
SET DLSINI=C:\IBMLAN\NETPROG\NETGUI.INI
SET ENH_STRETCH=NO
SET ETC=C:\MPTN\ETC
SET GLOSSARY=C:\OS2\HELP\GLOSS;
SET HOME=C:\HOME\DEFAULT
SET HOSTNAME=ECS
SET IKEYMAN40_HOME=C:\IBMGSK40
SET IKEYMAN50_HOME=C:\IBMGSK50
SET IKEYMAN_HOME=C:\IBMGSK
SET INIT_FILE_NAMES=netgui
SET INIT_FILE_RANGES=200
SET IPF_KEYS=SBCS
SET JAVA_HIGH_MEMORY=1
REM SET JAVA_HOME=C:\PROGRAMS\JAVA142
SET KEYS=ON
SET LANG=it_IT_EURO
SET LANINSTEP=S:\cid\server\IBMLS
SET LOGFILES=C:\var\log
SET MMBASE=C:\MMOS2;
SET MMSTREAM=/S:64 /P:64 /H:256 /Q:1024 /E:1024
SET MMYIELD=10
SET MOZILLA_HOME=C:\HOME\DEFAULT
SET NCDEBUG=4000
SET NOLARGENTEXEICON=1
SET NSPR_OS2_NO_HIRES_TIMER=1
SET OS2_SHELL=C:\OS2\CMD.EXE
SET OS=ecs
SET OSDIR=C:\ecs
SET PROGRAMS=C:\PROGRAMS
SET PROMPT=[$p]
SET RESTARTOBJECTS=STARTUPFOLDERSONLY,REBOOTONLY
SET RUNWORKPLACE=C:\OS2\PMSHELL.EXE
SET SANE_CONFIG_DIR=C:\PROGRAMS\TAME\conf
SET SCCANBENUKED=ON
SET SCKILLFEATUREENABLED=ON
SET SHELLHANDLESINC=20
SET SMB_EXE=C:\ECS\SYSTEM\Samba
SET SOMDDIR=C:\OS2\ETC\DSOM
SET SOMIR=C:\OS2\ETC\SOM.IR;C:\OS2\ETC\WPSH.IR;C:\OS2\ETC\WPDSERV.IR;C:\OS2\ETC\REXX.IR;
SET SYSTEM_INI=C:\OS2\OS2SYS.INI
SET TCPLANG=en_US
SET TZ=CET-1CES,3,-1,0,7200,10,-1,0,10800,3600
SET UNZIPOPT=-C
SET USER=ECS_USER
SET USER_INI=C:\OS2\OS2.INI
SET USE_HOSTS_FIRST=1
SET WPS_COMMUNICATION=YES

REM [ Executables ]
CALL=C:\ECS\BIN\CACHEF32.EXE /S /F
RUN=C:\OS2\SYSTEM\LVMALERT.EXE
RUN=C:\OS2\EXTENDFS.EXE *
CALL=C:\IBMCOM\PROTOCOL\NETBIND.EXE
RUN=C:\IBMCOM\LANMSGEX.EXE
REM CALL=C:\OS2\CMD.EXE /Q /C C:\MPTN\BIN\MPTSTART.CMD >NUL
RUN=C:\MPTN\BIN\CNTRL.EXE
CALL=C:\OS2\CMD.EXE /Q /C C:\MPTN\BIN\MPTSTART.CMD >NUL
RUN=C:\IBMCOM\PROTOCOL\NBTCP.EXE
RUN=C:\MPTN\BIN\VDOSCTL.EXE
RUN=C:\OS2\SMSTART.EXE
RUN=C:\IBMLAN\NETPROG\LSDAEMON.EXE
RUN=C:\IBMLAN\NETPROG\VNRMINIT.EXE
RUN=C:\PROGRAMS\RSJCD\CDWFSD.EXE -p "C:/var/temp" -c20000 -b2048 -t2 -i3 -s0
RUN=C:\MMOS2\mmfix.exe
RUN=C:\MMOS2\mididmon.exe
RUN=C:\MMOS2\mmhelpdd.exe
RUN=C:\MMOS2\qrymmcd.exe
RUN=C:\ECS\BIN\EVFSCTL.EXE

REM [ Remarks ]
REM -> TESTCFG2.SYS has been patched to support ACPI

REM [ Temporary Directories ]
SET TMP=C:\var\temp
SET TEMP=C:\var\temp
SET TMPDIR=C:\var\temp

RUN=C:\OS2\ACPIDAEMON.EXE
REM SET S3_FPSCALING=ON
DEVINFO=SCR,VGA,C:\OS2\BOOT\VIOTBL.DCP
SET VIDEO_DEVICES=VIO_SVGA
SET VIO_SVGA=DEVICE(BVHVGA,BVHSVGA)
DEVICE=C:\OS2\MDOS\VSVGA.SYS
SET GRADD_CHAINS=C1
DEVICE=C:\OS2\GRADD.SYS
DEVICE=C:\OS2\MDOS\VMANWIN.SYS
SET VCFG_NO_DDC=TRUE
SET GREEXT=SDDGREXT
SET C1=SDDGRADD
DEVICE=C:\OS2\SDDHELP.SYS /Q
SET UNIXROOT=C:

We are talking about a Thinkpad T23.
Thanks in advantage.

Pages: [1]