Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Jochen Schäfer

Pages: [1]
1
Programming / poll() and select()
« on: June 23, 2017, 09:58:10 pm »
I'm trying to port multitail, but it seems that select() as well as poll() doesn't seem to work.
I have attached my test programs, which both should work. Both  return with EINVAL.
So, am I missing something or is the OS/2 implementation buggy?
Can somebody point me to some already ported code, which uses poll or select?

2
Programming / Where is getaddrinfo?
« on: June 17, 2017, 11:11:09 am »
Hi.

Does some know whether we have a implementation of getaddrinfo?
It seems to me that it should belong to the C standard library, but I can't find any declaration in /usr/include.

3
Programming / Can't push to Github.
« on: June 13, 2017, 11:32:16 pm »
After installing ArcaOS, I installed Git via RPM.
Now I want to push to Github. git asks my username and password, which entered multiple times.
But it tells me that it can't access the HTTPS address and that the server returns 403 (Forbidden).
What do I have to configure, to make that work?

4
Applications / New DOSBOX build / new ports
« on: June 12, 2017, 11:30:37 am »
After getting ArcaOS set up and got the development envorinment set up, I can now proudly announce a new build of DOSBOX with the latest source code changes. You can fetch it at https://www.joschs-robotics.de/dosbox/.
I will also submit the installer to Hobbes.
Since I build against the RPM repos, you will only need the packaged DLLs, if you are not using RPM.

PS: I couldn't add the news to the Netlabs WIKI DOSBOX page, since I can't login at the moment. If someboy would be so kind, to add the announcement, I would be grateful.
 
EDIT: This build contains SDL_SOUND support again.

5
Programming / Problems with configure
« on: January 28, 2016, 08:38:09 am »
Hi there.

I have a problems with this configure from SDL, I'm working on.
I get the message
Code: [Select]
./configure.lineno: 23670: Syntax error: "fi" unexpected (expecting "then")I don't know why. If I remove the offending code, then the error moves to another part of the script.
So I think the error is somewhere. As I'm no expert in shell programming, I don't know where to look at.
Autoconf is 2.69, automake is 1.14.1-3.

6
Programming / Multimedia with GCC
« on: January 11, 2016, 10:17:36 am »
Hi.

I'm building SDL with GCC.
My problem is the typedef PACB (pointer to struct ACB).
I can find no definition in the OS/2 toolkit 4.5, although some multimedia API needs it.
The only definition, I could find, was in a Watcom C header.
My question: Am I overlooking something? Is there some packages (rpm or something else) I need to install?
Or have I to set up a C header file for the definition.

7
Programming / libc panic
« on: July 31, 2015, 07:34:33 am »
Hi.

I'm porting nginx. I was able to build a binary and nginx can serve me static HTML pages.
I can stop nginx via process signaling. That just works fine.
But if I want to restart nginx, I get the following:
Code: [Select]
nginx: [alert] shmget(384) failed (22: Invalid argument)

LIBC PANIC!!
safesem mutex requested failed, rc=0x6. pmtx=5fe10960:{.hmtx=0x800100fb .fShared
=0x1}
pid=0x0fbb ppid=0x0b43 tid=0x0001 slot=0x009c pri=0x0200 mc=0x0001 ps=0x0017
U:\WORK\NGINX\OBJS\NGINX.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Now, I have to reboot to get nginx running again.

I have the newest klibc installed and the binary is compiled with gcc 4.9.2.
Does anyone have suggestions, how to handle the problem?

Bye Jochen

PS: If someone wants to test the port, PM me.  I'll send you the binary.

Pages: [1]