Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Joop

Pages: [1] 2
1
Web applications / Directory safebrowsing in 38.8
« on: October 04, 2017, 02:19:11 am »
There is a directory in the profile of FF38.8 with the name safebrowsing. Is there a way that you can monitor its contents. The problem is that I have a forum which won't start in ff38.8 but do start in ff24. I can't figure out why and I suspect this directory which might contain information which is not right.

2
General Discussion / GMail no longer for OS2-eCS
« on: April 21, 2017, 10:34:52 pm »
I don't use the service that often, so I wanted to log in, had some trouble with those #$%& passwords. Now all is set, but as soon as I'm in I get the message that our FF is not supported any longer. Something is loading at the sidebar and the next thing is a sudden shutdown of FF.

3
Internet / Strange problem
« on: March 10, 2017, 11:23:57 pm »
I do visit regular a forum. But since yesterday I can't. Its like it doesn't exist. I have this behavior in FF38.8. When I close the program and start up FF24.8.1 then I can go to that forum. So I have a virus? Deleted the directory of FF38.8 with the databases, not the program directory, seems all is okay there, no changes in dates or time. I pickup my backup from about a month ago and restored the deleted directory. I had no problems then. But after starting up FF38.8 I still can't go the the forum. What's going here? For the record, did a fresh restart too.

4
Applications / Clam-AV virus scanner
« on: July 16, 2016, 07:38:59 pm »
I get strange messages from Google and can't use their search engine. It started today, don't know what's going on. So I want to start with my system if something is wrong. We have clam-av, but I'm unable to download the main cvd. This database is grown out of proportions, my estimate is about 1.3G and with only 1G mem you go to use your swapper.dat extensively. But its going slow and at some point OS/2 send me the message that clam-av doesn't respond and after that most wise thing to do is a restart.
Now is this database grown over the 1G or is something else wrong? Can still use all programs, so my guess is that the database is grown to big with the result that computer with 1G don't have a virus scanner anymore.

5
Applications / Firefox 38.8.0 for OS/2 Beta 7
« on: May 28, 2016, 08:34:09 pm »
Where to go for download?
And I don't want to start a war or so, but I do read unbelievable bullshit about installing needed libs. He really doesn't understand a thing about the power of OS/2.
All needed libs are in [drive:]\ecs\dll. Its in the config.sys, nothing changes there. Just copy the stuff in this lib. Only fontconfig path is different. How hard is it just to do it this way, I don't need a program which fucks up my system. If I want Linux that badly I go for such a system. So I want to install it my way, in this way no installation is standard, best way to keep it virus free. The trouble of Windows and Linux (Mac) is that everyone has the same layout when it comes to lib files, the best recipe for planting a virus in the system. So if you  want that, dream on..

6
Applications / Firefox 38.2.1
« on: March 04, 2016, 04:42:17 pm »
I downloaded firefox-38.2.1.en-US.os2.zip and did read the readme file. Downloaded the needed files. Found that with fonts that the needed dll is not in the distribution. I get the message xul can't load. Probably it can't find the correct dll. Are there more users with same problems or found solutions?

Regards,
Joop

7
Applications / strange behaviour with Thunderbird
« on: September 12, 2015, 06:28:49 pm »
Now I know that Thunderbird is not the latest with version 10.0.11, but up to installation of Firefox 31.8.0 it worked fine. After installation of Firefox 31.8.0, better said the needed libs, I experience strange behavior, even if Firefox 31.8.0 is not used. I still use Firefox 24.8.1. If I start Thunderbird after I have used FF it sometimes looks like a part is not loaded or so. Memory mostly shoots up to over 900Mb, but in some cases this stays below the 700Mb. In that case the screen is not build properly. Only where your mouse pointer hits the screen is revealed. So if you do this with your complete screen you end up with all kind of blocks and the frame of Thunderbird is missing. Fortunately I can go to the part of the menu to end this session. Restart of Thunderbird has no effect. The only way is a restart of OS/2. After that Thunderbird works as it should, but it has to be used before FF is started. This sounds to me that some needed lib for FF latest is not completely downwards compatible or some sort. So I have the question if other OS/2 users do have this experience. I'm on OS/2 1.2 Dutch, 1Gb memory and some rotating metal. I don't expect that some part of the memory on the graphics card or main memory is wimpy as all other programs do work normally.

8
Internet / icedtea hangs?
« on: September 04, 2015, 02:00:22 am »
I downloaded icedtea-web-1_3-beta.zip and followed the instructions. Downloaded glib2-2_25_15-4.zip and followed the instructions. Problem here is that 3 libs are with an older date. Don't know if mmap.dll, pthr01.dll and urpo.dll are that critical with different releases. I use the dll files with latest timestamps. I make use of run, so my env file contains this;
set MOZILLA_HOME=P:\FIREFOX_PROFIEL_240x
set MOZ_PLUGIN_PATH=I:\FIREFOX_PLUGINS
set ICEDTEA_WEB_JRE=I:\JAVA\JAVA160ga5
set ICEDTEA_WEB_DATA=I:\JAVA\JAVA160ga5\lib
set NSPR_OS2_NO_HIRES_TIMER=1
set MOZ_ACCELERATED=1
rem set MOZ_NO_REMOTE=1

Start up FF 24.8.1 and in the about:config confirmation that the plugin is loaded. Go to the Java test site and it hangs. But what's wrong? The test site, because it test on version 8? Another site with a page witch needs Java 6 also hangs, I get the clock icon or similar. And you can wait forever.

Any ideas?

Regards,
Joop



9
Applications / Firefox and thumbnails in profile directory.
« on: August 11, 2015, 12:37:26 am »
With FF version 24.8.1 and version 31.8.0 I have in the profiles directory a sub directory thumbnails. With these two versions I have thumbnails in this directory, but its taking space like hell (about 30k/picture). I don't want thumbnails, but can't find where to switch it off. In the about:config there are two lines about thumbnails. One has a setting with a long number, but that could be a date, the other has setting 3. Is there a way to stop producing automatic(?) thumbnails. There might be a change that some add-in does this, don't know. I looked everywhere. Does anyone of you have an answer on this subject?

10
Applications / What happend to XUL.DLL?
« on: August 01, 2015, 05:25:19 pm »
I'm still busy with some versions of JAlbum, can't stand it that it won't load FF when you aks for a preview (F12).
I have this setup and with this setup JAlbum (10.10.7) starts FF (6.02) and FF comes up with the preview. No problems, no popups, just works.
@echo off
SET CLASSPATH=
SET LIBPATHSTRICT=T
SET MOZILLA_HOME=P:\FIREFOX_PROFIEL_60x
SET MOZ_PLUGIN_PATH=I:\FIREFOX_PLUGINS
SET NSPR_OS2_NO_HIRES_TIMER=1
SET MOZ_ACCELERATED=0
SET BEGINLIBPATH=i:\JAVA\JAVA160\bin
set path=i:\JAVA\JAVA160\bin;i:\firefox_602
set appdata=T:\plaatjes\MyAlbums
I:
cd I:\DTP\JAlbum_10107
java -Xmx400M -jar JAlbum.jar 2>jalbum_10107_bugtracker.txt

I tried similar setup with a higher version of JAlbum (12.1.9) and with a higher version of FF (24.8.1).
@echo off
SET CLASSPATH=
SET LIBPATHSTRICT=T
SET MOZILLA_HOME=P:\FIREFOX_PROFIEL_240x
SET MOZ_PLUGIN_PATH=I:\FIREFOX_PLUGINS
SET NSPR_OS2_NO_HIRES_TIMER=1
SET MOZ_ACCELERATED=0
SET BEGINLIBPATH=i:\JAVA\JAVA160\bin
set path=i:\JAVA\JAVA160\bin;i:\firefox_2481;
set appdata=T:\plaatjes\MyAlbums
rem I:
rem cd I:\firefox_2481
rem firefox!EL.exe
I:
cd I:\DTP\JAlbum_1219
java -Xmx400M -jar JAlbum.jar 2>jalbum_1219_bugtracker.txt

But when I run this I get a popup with "Couldn't load xul.dll". When I rem the lines SET LIBPATHSTRICT=T up to SET MOZ_ACCELERATED=0 and remove the rem on the 3 lines lower then FF is called and runs, JAlbum is called and runs, preview is opening a new window in FF and shows the preview.
Has something changed that XUL.DLL only can be called from the active directory and won't respond to a path statement?

11
Programming / support opengl
« on: July 05, 2015, 04:35:31 pm »
I did test a Java CAD program for Legobricks. But it won't start due to not know our OS. I wrote to the developer and he answered that it's build on Java-to-OpenGL library called JOGL http://jogamp.org/ that includes some native code as a bridge to native OpenGL calls.
Now the question, does OS/2-eCS support OpenGL?

Regards

12
Applications / strange error with testing java program
« on: June 25, 2015, 03:40:23 am »
I'm testing the Java application jabRef. It starts fine. Did tweak settings to Dutch. Now you have to restart and then I get the next message;

LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=7d61bbbc lock=0x1
pid=0x0051 ppid=0x0050 tid=0x0001 slot=0x0096 pri=0x0200 mc=0x0000
I:\JAVA\JAVA160GA5\BIN\JAVA.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

I'm now on version 2.9.2, but I tried also 2.10 with same results. I could dump this message with giving more memory, no errors, change a thing, again same errors, error gets away with again more memory, start a database and save it, again same error.

Is this a problem with
my motherboard?
lib-c according message?
java 1.6.0-ga5
program not compatible with our JDK implementation.

As everything else runs fine and eCS is not complaining I think I can rule out my motherboard. Anyone an idea?

13
Programming / programming in Java with netbeans
« on: June 13, 2015, 01:59:44 pm »
I have some sources for Java programs which where developed in netbeans. I want to install netbeans, but what version (of course one for Java 6)? Are there different versions for OpenJDK and Sun's Java? There are lot of sources  available from programs which don't want to run in our implementation of OpenJDK.

Joop

14
Applications / Apache OpenOffice 4.1.1 RC3
« on: August 22, 2014, 12:36:02 am »
Downloaded the file, its going slow, it took about 12 minutes to complete.  The file name Apache_OpenOffice_4.1.1_os2gcci_install-arc_en-US-rc3-strip.zip suggest some kind of installation program. Didn't found one. There was a readme, but I couldn't discover any words about OS/2 or eComStation nor what you need in order to run the program. Its like something is missing, but I might be wrong.
So, said that, how do I start this monster?

Regards,
Joop 

15
Applications / Update homepage Java applications
« on: August 03, 2014, 10:59:17 pm »
I have updated my homepage about Java applications.  See the link.
The Dutch part will follow soon. After this I hope the add more programs, unfortunately there are lots of them which won't work for some reason. Most of them due to the difference between Sun Java and Open JDK. I got the source from one application and I'm going to try to compile it with our Open JDK SDK. So may be I'll come back for some help.

http://joopn.home.xs4all.nl/os2ecs/ecs6e.htm

Have fun and Ecs is only dead after the last user switched off  the light and no moment sooner,
Joop

Pages: [1] 2