Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Lars

Pages: [1] 2
1
Storage / oddities with OS2AHCI version 2.04
« on: December 16, 2017, 03:17:48 pm »
I recently installed version 2.04 which indeed fixes the problem with the system freezing on invoking smartahci.exe which happened with version 2.03.

But now I have this oddity: if I invoke smartahci.exe more than once in a row, the first invocation will work fine but the second invocation will again freeze the system.
I tried this commandline: smartahci.exe -i hd0

Before I open a problem report at AN: Does anyone experience the same problem ? Or is it just me ?

2
Storage / About FAT32 and AN
« on: June 10, 2017, 11:10:01 am »
Looks like quite a few people are having probs with FAT32 as it comes with AN:

the new version that is being worked on still needs some fixes. What I fixed with SVN revision 250 was some prob with extended attributes in conjunction with the /largefiles switch which would lead to a complete system hang when opening a FAT32 drive object. Currently we are working on a problem when double clicking on a file with a program association​ (say a zip file associated with the arcview.exe utility).
We know where the resulting system hang occurs but we don't yet know why ...

For the time being the solution is to revert back to version 0.9.13 which you will find at Hobbes.

To find out about what SVN revision is delivered with AN:
open a commandine, change to directory \os2\boot and do a "bldlevel FAT32.IFS" (without the quotes).
The returned info contains a 3-digit value (apart from other info) which is the SVN revision.

If it is older then 250 you can try newer version here (as I said:not yet ready for prime time):
trac.netlabs.org/FAT32




3
Hallo,

I have uploaded to Hobbes version 5.0 of VFDISK.SYS. It contains a fix so that the FAT12/FAT16 support that comes with the new FAT32.IFS can peacefully coexist with VFDISK.SYS.

VFDISK.SYS is a device driver to emulate floppy media.

Lars

4
Multimedia / recent developments for USB audio
« on: April 08, 2017, 10:22:54 am »
Hallo,

Wim Brul and me have made some significant progress in enhancing support for USB based audio:
1) we have fixed quite a few bugs in USBAUDIO.SYS so that finally it will work reliably
2) I have implemented on-the-fly sample rate conversion in an IOProc (USBWAV.DLL) for these conversions:
   target:
   16-bit signed PCM, stereo, 44100 Hz
   source:
   8-bit unsigned PCM, mono, 11025 Hz
   8-bit unsigned PCM, stereo, 11025 Hz
   8-bit unsigned PCM, mono, 22050 Hz
   8-bit unsigned PCM, stereo, 22050 Hz
   8-bit unsigned PCM, mono, 44100 Hz
   8-bit unsigned PCM, stereo, 44100 Hz
   16-bit signed PCM, mono, 11025 Hz
   16-bit signed PCM, stereo, 11025 Hz
   16-bit signed PCM, mono, 22050 Hz
   16-bit signed PCM, stereo, 22050 Hz
   16-bit signed PCM, mono, 44100 Hz
"on-the-fly" means you no longer have to manually convert audio files to the 16-bit signed PCM, stereo, 44100 Hz target format.
The IOProc will instead do that on the fly when you open an audio file (double click a WAV file under the Workplace Shell for example).
3) additionally I have added Codecs for A-Law and Mu-Law
4) for audio compressed files, I have added support to the IOProc to use any audio codecs that are installed to decompress audio from the compressed format to 16-bit PCM (if a suitable codec can be found)
5) Wim has picked up the functionality in the IOProc as listed in 2) and added the same to USBAUDIO.SYS. This is for those applications that use DART directly and bypass the MMIO file support. An example of direct DART use would be the "libkai" library.

This will greatly improve the usability of USB audio under OS/2. What's left to be done is to also support "48 kHz sampling rate only"  USB devices. However that will require additional effort.

Lars

5
Hi,

Apache Office 4.1 needs libicu in Version 4.2 (it is looking for DLL icuuc42.dll).
However Firefox needs libicu in Version 56.1 (it is looking for DLL icudt.dll I seem to remember).
The problem is: if I install the newer version, the older version is removed. I had to manually zip all files from the old version package, install the new one and then unzip the saved DLLs.

What is the correct way to deal with this ? Do I need to copy over that old stuff into the Apache Office application directory ?
I admit that I am lost.

Lars

6
Applications / Problem with ANPM
« on: March 05, 2017, 01:38:50 pm »
I tried to update various packages and got this:

[u'ERROR with transaction check vs depsolve:', 'nss3.dll is needed by rpm-libs-4.13.0-9.oc00.pentium4', u'Please report this error at http://yum.baseurl.org/report']

Anyone know how to resolve this problem ? I cannot find nss3.dll in any of the likely packages. I can only find nss3k.dll.
I have the same problem with nssutil3.dll vs. nssuti3k.dll.

And another one: installing "netlabs-exp" leads to this error message:
Cannot access repository dir /@unixroot/var/cache/yum/netlabs-exp

It installed these settings for the repo:
URI : http://rpm.netlabs.org/experimental/00/i386/

7
Hardware / USB drivers 10.215 are in the works
« on: February 02, 2017, 09:22:16 pm »
I had to do numerous fixes to USBMSD.ADD regarding geometry computation in order to make it more compatible to Windows and DFSee. I also had to add recomputation of geometry in case the media is ejected and exchanged but the device stays attached (example: SD card reader).
This required substantial changes. Unfortunately 10.214 is suffering from some major problems and I suggest to roll back to say 10.210 and wait for the next version :-)

Lars

8
Hardware / USB drivers 10.213 released
« on: December 22, 2016, 07:11:20 pm »
Please skip versions 10.211 and 10.212. All changes in "readusb.txt", as usual.
Find on Hobbes.

9
Hardware / USB drivers 10.206 released
« on: June 22, 2016, 10:35:02 am »
Sorry but since it's kind of urgent: I had to do yet another critical fix to USBMSD.ADD in order to prevent data loss and/or an endless cycle in trying to write/read data under specific circumstances.
Get the latest 10.206 from Hobbes as usual. Contained file "readusb.txt" lists the changes (as usual).

10
Hardware / USB drivers 10.205 released
« on: June 14, 2016, 09:26:31 pm »
Hallo,

I hope to have fixed the problems with USBMSD.ADD that existed up to and including 10.204.
Just try out and report back.
Available, as always, on Hobbes (hobbes.nmsu.edu), currently in "incoming" directory.

11
Hallo,
a word of warning:
there was a serious bug in USBMSD.ADD which might lead to data corruption on USB media (clipped files, corrupted files etc.).
It only happens under very specific conditions but unfortunately it will not show up immediately (no trap or the like).

I am not sure if that error also exists in IBM original 10.162 as I am building upon the DDK code which was pretty much outdated compared to the 10.162 binary. I have now reworked the relevant code but it needs more testing ...

I will prepare 10.205 if time comes.


Lars

12
Applications / AOOo 4111GA does not install libc066
« on: February 22, 2015, 08:49:39 pm »
I tried the WPI method (rpm WPI on same directory as the base WPI): it does not work
I then tried to run yum with the command line given in the readme: I get told that Python cannot find urlgrabber and then that's it

libc066.dll is not installed and therefore none of the applications works.

Can someone tell me where to get libc066.dll ?

13
I just took the chance to rework the HW Manager replacement WPS class (HWMAN) and uploaded to Hobbes.
Who cares about HW manager ? Probably nobody. So what's the real deal ?
It comes with full source code that is extensively commented. It's meant for everybody who is interested in starting WPS programming.
That said, I tried to comment the stuff that is not really documented anywhere ...

Martin (if you are reading), I think it is a good idea if you update GITHUB with this new update ...

Lars

14
Programming / Where do I find hd4disk.add, acpi4.sys ?
« on: January 15, 2014, 12:24:30 am »
I have read about these drivers but they are not contained in the OS/4 package ? Is there any place I can find them ?

Lars

15
OS/4 kernel does not support the TRACE and TRACEBUF statements. It displays that these statements are not valid and continues to boot (the same holds true for VIRTUALADDRESSLIMIT but I guess that was intentional).
This is even true with the OS/4 debug as well as retail kernels.
This is a serious limitation because for example it's the only way for David's / my USB drivers to log operational info on a user's end machine. Without any tracing, it's impossible to determine why a driver won't work on a user's machine (except for flat HW traps which can be located by other means).
Again, this renders the OS/4 kernel incompatible with the existing OS/2 kernels.

Lars

Pages: [1] 2