Author Topic: Strange problem  (Read 972 times)

Joop

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 30
  • Posts: 401
    • View Profile
Strange problem
« on: March 10, 2017, 11:23:57 pm »
I do visit regular a forum. But since yesterday I can't. Its like it doesn't exist. I have this behavior in FF38.8. When I close the program and start up FF24.8.1 then I can go to that forum. So I have a virus? Deleted the directory of FF38.8 with the databases, not the program directory, seems all is okay there, no changes in dates or time. I pickup my backup from about a month ago and restored the deleted directory. I had no problems then. But after starting up FF38.8 I still can't go the the forum. What's going here? For the record, did a fresh restart too.



Andreas Kohl

  • Full Member
  • ***
  • Thank You
  • -Given: 4
  • -Receive: 6
  • Posts: 138
    • View Profile
    • warpserver.de
Re: Strange problem
« Reply #1 on: March 10, 2017, 11:43:30 pm »
You can try to disable the tracking to Google, Facebook and Twitter. This involves a lot of JS code and can cause trouble with the latest beta of the firefix fork for OS/2. You can check it in your Javascript console or by "about:memory".

André Heldoorn

  • Full Member
  • ***
  • Thank You
  • -Given: 37
  • -Receive: 7
  • Posts: 183
    • View Profile
Re: Strange problem
« Reply #2 on: March 11, 2017, 12:18:55 pm »
And/or use NoScript, to exclude those commercial scripts by default: https://secure.informaction.com/download/releases/noscript-5.0.1.xpi
« Last Edit: March 11, 2017, 12:27:57 pm by André Heldoorn »

Joop

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 30
  • Posts: 401
    • View Profile
Re: Strange problem
« Reply #3 on: March 17, 2017, 06:16:21 pm »
Can someone tell me what the files in the profile directory mean and do? And where can I connect the password database to the security page? For some reason I lost it. Get real sick of 38.8, its slow, don't use memory right, needs a lot of time shutting down, what is the program writing? And the worst part, I can't read a thing in all those files, formerly you could go through a file and kick out the line which was not okay.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1063
    • View Profile
Re: Strange problem
« Reply #4 on: March 18, 2017, 03:35:36 am »
Here is a description of SeaMonkey's profile files, Firefox is mostly the same except no mail etc http://seamonkey.ilias.ca/profilefaq/
Yea, it's somewhat slow and does use a lot of memory. Probably finalizing the sqlite databases during shutdown. Search Hobbes for sqlite browser (or is that sqlite3 browser) to read the databases

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 614
    • View Profile
Re: Strange problem
« Reply #5 on: March 18, 2017, 10:26:34 am »
Another thing to check is the 'thumbnails' directory, it gets created if you want it or not and nothing ever appears to be deleted from it.  I ended up with several Gb in there until I found how to stop them being saved (it might have been Dave that gave the answer). Since then nothing sets saved in there and firefox runs a little faster.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 7
  • -Receive: 87
  • Posts: 1063
    • View Profile
Re: Strange problem
« Reply #6 on: March 18, 2017, 06:36:31 pm »
Another good resource is the extension "Config Descriptions" which will give a description of many (but some are missing) preferences when you go to about:config, handy for finding some prefs such how to turn off thumbnails.

Joop

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 30
  • Posts: 401
    • View Profile
Re: Strange problem
« Reply #7 on: March 18, 2017, 06:56:09 pm »
Some file on Mozilla about Mac gives lots of info about the files. Found that one thanks to Dave. But still have the password file problem. Memory seems to be a bug. I have *.wal files, these are write ahead log files.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 24
  • Posts: 614
    • View Profile
Re: Strange problem
« Reply #8 on: March 18, 2017, 07:12:00 pm »
Regarding passwords, we always backup the passwords once a month using the 'Password Exporter' addon.  We also use the 'Saved Password Editor' addon to check and edit passwords.

Both of those addons require manual use but are well worth the effort.

Joop

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 30
  • Posts: 401
    • View Profile
Re: Strange problem
« Reply #9 on: March 24, 2017, 05:41:15 pm »
And where can I connect the password database to the security page? For some reason I lost it.
Didn't found a solution in the database of Mozilla. Only the things you can find in the menu. Even when the three files are in the user directory the program can't still find it. So I decide for an other solution. I have it now in UPM with Java.
Get real sick of 38.8, its slow, don't use memory right, needs a lot of time shutting down, what is the program writing?
I unchecked the option of history, I checked private. Now its going the normal speed I used to when closing down. But the memory bug is to stay, every time you close down and start up you loose some, I can see it in the widget memory where the figure used memory is going slowly up.