Author Topic: Quassel OS/2 fails to connect to core  (Read 668 times)

Devon

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 25
    • View Profile
Quassel OS/2 fails to connect to core
« on: October 15, 2017, 10:32:25 pm »
Hey guys,

I didn't realize that quassel was ported to OS/2, but I'm glad that it is (since I do use it already on my other systems):
http://os2ports.smedley.id.au/index.php?page=quassel-irc

However, whenever I try to connect quasselclient to my quassel core with the ported OS/2 client, it always fails to authenticate (but I've confirmed it works perfectly fine on my 0.12.4 windows clients).

Is it because the port is 0.10.0 which would require an older version of the quassel server? Or some other kind of bug?

(I'm running the latest version of ArcaOS)



TeLLie

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 47
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #1 on: October 16, 2017, 04:04:05 pm »
Hi Devon,

I ported some month ago the latest Quassel.
If you like you can try it...

Devon

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 25
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #2 on: October 16, 2017, 11:22:23 pm »
Hi Devon,

I ported some month ago the latest Quassel.
If you like you can try it...

That would be awesome if you have it, I'd love to give it a shot.

TeLLie

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 47
    • View Profile

Devon

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 25
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #4 on: October 17, 2017, 09:59:24 am »
Well it looks like the same issue occurs: 'The remote host closed the connection'

But now I know more about the issue, even when I don't specify a password--it doesn't even get to the point where the core prompts for it.

I'll see about setting up another server core to do tests, I'm presently running the core on a Raspberry Pi running Raspbian (since it runs 24/7, doing it that way just saves power). But I'm wondering if maybe it doesn't like the fact the Pi is not x86.

Devon

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 25
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #5 on: October 17, 2017, 10:35:41 pm »
Well I may have an answer to the problem, I don't think ArcaOS (or OS/2 vanilla) have SSH by default:
http://www.ucc.gu.uwa.edu.au/~dunc/ssh/snafu-mirror/getting_started.html

That's probably what's missing, I'll check that out when I get home and report back. If that fails, I'll set up a quassel server core on OS/2 server and see if it can communicate okay or if the problem persists.

TeLLie

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 47
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #6 on: October 18, 2017, 07:05:48 am »
Hi

I don't use the core myself, but i know some peeps use the core successfully with OS/2
What are the errors you get when try to connect to core ??

TeLLie

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 47
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #7 on: October 18, 2017, 04:14:18 pm »
Hi

Did you install the newer  Networks DLL that fixes the ssl ...

ftp://ftp.netlabs.org/pub/qtapps/QtNet4_Fix_SSL.zip

Please try again when you change with newer DLL

Devon

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 25
    • View Profile
Re: Quassel OS/2 fails to connect to core
« Reply #8 on: October 19, 2017, 05:39:43 am »
Hi

Did you install the newer  Networks DLL that fixes the ssl ...

ftp://ftp.netlabs.org/pub/qtapps/QtNet4_Fix_SSL.zip

Please try again when you change with newer DLL

That fixed it :p

Thanks