S3 Video card installations

From OS2World.com Wiki
Jump to: navigation, search

By Derek Clarkson

A quick note for those new to this:

The chipset is one or more microchips on your video card which are responsible for taking instructions from your CPU and turning them into the images you see on your screen.

Essentially they are mini computer on a card whose job is to draw pictures. This frees your main CPU to continue on with other jobs. Along with the type of memory you have on the card, the make and type of video chipset is one of the controlling factors in how fast your computer can draw things.

Another is the software drivers for it. Without suitable drivers, the computer is limited to VGA and you main CPU does all the works to draw on your screen. This is due to the fact that VGA is the only actual standard that all cards comform to.

Every video card on the market impliments SVGA in a different way, hence the need for specific drivers for them. Using the appropriate drivers, your main CPU issues instructions such as 'Draw a box' to the video card which then does the work, saving huge amounts of time as well as allowing the card to perform functions which enhance the display or speed.

Article

I sat looking at the screen, I could hear the system opening folders and starting programs, but all I could see was vertical green and blue lines. The video card putting out somthing that my monitor just could not understand. I guess it's time for a reinstall.

If you've ever had cause to play around with your video drivers and try out different ones then this sort of situation is not an uncommon one. Mostly it seems to apply to people who have various 'no-name' brand cards using S3 chipsets and the like. The most likely candidates being the S3C801, S3C805, S3 Vision 864, 868, 964 and 968 chipsets. I have also heard that there are also a couple of other S3 chips which can masquerade as 801/805s and have caused trouble through not being truely compatible.

So here I am. I've got a Diamond Stealth64 with 2M of VRAM memory. It's about a year or so old and uses the S3 864 chipset. I've also got a friend who has a Number 9 9FX Motion 771 with 2M of VRAM memory which uses the S3 Vision 968, which I also installed for him. And I have tried and tested IBM's latest generic S3 864/968 drivers from the IBM BBS. The interesting thing about all these cards and the numerous drivers I have on tap is that they all use a similar install procedure, but have different quirks when installing or running.

Of course the big thing to note here is the strange world of computers. i.e. Take the same piece of software, put it in two different machines, and it will behave completely different. You know, standards and stuff ... Not!

So what I am out to do here is to pass on some of my experinces and hopefully some tips to those of you who have or are going to bug these types of cards.

Lets have a look at the install process you will be going through to install one of these cards :-

1.- Make sure that your system is currently running in standard 640x480x16 VGA mode. If not, the best way to set it back to VGA is to do either one of two things.

First you can go to selective install and re-install the VGA driver. Or, you can reboot, press ALT+F1 when the white dot and "OS/2" appear in the top left hand corner of the screen, and then from the Recovery Choices menu, select Go to a Command prompt. Then at the prompt, type 'setvga'. This will reload VGA drivers from a backup install directory.

2.- Slot the first display driver disk and at a command prompt, transfer a new version of the DSPINSTL.EXE program to you OS/2/INSTALL directory. Typically this is done through a REXX .CMD file. For example the Stealth64 uses a program called "S3INST" to do this. The command I type at the command prompt looks like this:

   [A:]S3INST A: C:

DSPINSTL.EXE is the program that OS/2 uses to install video drivers. Presumeably the S3 range need a slightly different version of it. After the program has prompted you for any disks you need, shutdown and reboot to get this program setup in your system folder.

3.- Once the system is back up again, run the DSPINSTL program which now has an icon in the System Setup folder. This is the first place where things may go haywire.

DSPINSTL works by reading any files in your install directory which have the extension of '.DSC'. These are text based files which tell DSPINSTL what drivers are available and how to set them up. Unfortuneately a couple of the new DSPINSTL programs I have come across encounter problems with some of the parameters in the older .DSC files that came with OS/2. Typically if you encounter this problem you will see a message come up saying something about an incorrect number of parameters ina DSC file, but not telling you which one.

If this happens I recommend that you copy all of the DSC files to a backup directory and then only copy back the ones you need for your video card. With my Stealth the only one I need is the PSS3.DSC file which contains the 32bit Stealth64 driver install instructions. You will have to look through these files to find out which one matches your card.

4.- Once DSPINSTL is running you will see a screen asking you which display you want to set the driver for. It should have your drivers already set, but set them again as it is just indicating what it thinks should be loaded not what is, and it won't actually load them until you indicate to do it.

5.- So click on Primary Display and press OK which brings up a list of drivers including the new ones you are loading. Select the driver you have been told to use by your cards README file and press OK. Hin: if it's not there then start again ..you've stuffed up somewhere!

6.- DSPINSTL now asks you whether you want to configure the card using monitor defaults or a display adaptor utility program. Confused ? I was at first. Basically in order to get the refresh rates setup so everything runs ok and you don't get any interlaced (flickery) screens, you need to do two things. First you must set the video card to the desired speeds for the display resolutions you want to run, then OS/2 must read these and set them up as defaults.

Typically with a S3 card, the readme will tell you to use the Configure Using Adaptor Utility, and then specify the utility to run. Pressing this leads to another window where you can select the utility and specify parameters for it.

With my Stealth I select a to use the utility program, insert the first disk and type in 'S64MODE.EXE MONITOR' as a command line. This blacks the screen for a while as the card sets itself up.

With my friend's Number 9 a different utility is used which displays a DOS screen you can specify the refresh rates you want to use. This part will probably differ for each individual card on the market according to who made it.

7.- Once the cards utility has been run to set it up, OS/2 them runs another DOS program called SVGA.EXE. This utility is provided with OS/2, but may have also been updated by the video cards initial install proccess. It's job is to read from the video card, all the settings that OS/2 needs to know to be able to handle different SVGA resolutions and to be able to switch between them. When it runs it creates in your OS/2 directory, a file called SVGADATA.PMI. This file is essential to the smooth running of SVGA under OS/2.

9.- After this you will be prompted for the first disk of the SVGA drivers and DSPINSTL will load the drivers into your system, following up with the second disk if it is required. Then you wil be prompted to reboot your machine again so that the drivers can be activated.

At this stage your computer will come up in 640x480x256, a basic but workable SVGA resolution. Most people prefer a higher one such as 800x600x256, 1024x768x64k or for the really twisted with phalix sized monitors, 1600x1200x64k (Hi Marius!).

To do this you need to access the System icon in your System Setup folder. Once SVGA drivers have been installed the first two pages of this notebook are dedicated to the settings of your video card and monitor. Again it can very accord to the drivers that you install. For example, my Steath64 drivers only give me the first page with a list of screen resolutions and colours on it. However some generic S3 864 drivers I tried gave me, resultion and colour, display speed, and a second page where I could specify the make of monitor I am using and view the setup for it. There was even an entry for my Viewsonic 17G with On Screen Controls.

If you've ever tried to install something like video cards or CD-ROMs, one fo the first things that becomes appearent is there is three parts to getting it working:

  1. Getting the card installed.
  2. Finding out what drivers are available.
  3. Getting the correct drivers in and running.

Unfortunately, even after getting things working it does not necessarily end there.

Most of the S3 installs (mainly VRAM) that I have looked at, say that to get back to VGA you have to use the Setvga method I described above. Question: Why would you want to get back to VGA ? Answer: You might want to install an alternate set of drivers or remove the current ones before installing a different video card. Plus any number of other reasons.

In my case last week, I wanted to try a new set of IBM S3 864/968 drivers I had downloaded. Theoretically they should work with my Stealth and I was hoping for a speed boost. Both the old Stealth64 drivers that came with the card and the newer IBM ones said I had to reset the system to VGA before installing.

So I reset the system using Setvga and followed the install procedure for the IBM's. I had to vary it a little. For example my Stealth64 drivers used a DSPINSTL.EXE that didn't like some of the .DSC files in my OS/2/INSTALL directory, where as the IBM drivers where quite happy. I also had to use the display utility from the Stealth64 drivers because the IBM drivers (being generic) did not come with one. Eventually I had them installed and everyrthing was working again. These drivers seemed to be a little quicker than that Stealth64's (Shows a year of development me thinks!) and gave me more options in my System settings notebook. However for some unknown reason I could not get a mouse pointer up in a full screen Win-OS2 session.

Whilst not essential as I run most of the remaining Windows programs I have on the desktop, there are still a couple which I run full screen for speed reasons and therefore it's rather hard if there is no mouse. Actually that's not true, there was a mouse, I just couldn't see it, I could still do things with it though. So I decided to go back to my original drivers as they worked perfectly. This is where things went strange.

So I loaded up the Stealth64 drivers again after doing a Setvga. Everything seemed to work as normal and I did the last reboot to restart the system in SVGA. (Dramatic music please) But something was wrong.

Even though the drivers where in, the monitor had vertical green and blue lines and no display. Wierd science I tell you. I could hear OS/2 starting and loading everything so it was just a display problem. *JUST* !!!

I did another Setvga, but for some reason it would not work. Hmmm, things were a getting tricky. No OS/2 and no VGA. I played with several things, and looked inside the SETVGA.CMD file to see what was happening. Eventually I worked out there there are several ways to run SETVGA and what I needed to do was to load VGA from the install disks rather than from the system.

On my system the install is from a CD-ROM, so I restarted the system and then pressed ALT+F1 at the appropriate time to get to the Recevery Choices screen. Once there I pressed C to get to a command prompt and then typed the following command line:

[c:]setvga c: i:\os2image

This told setvga that my OS/2 drive was C: and it was to install VGA from the i:\os2image drive and directory which is on my CD-ROM. Worked like a charm, in next to no time I was back at a VGA OS/2 desktop.

I then tried to reinstall the Stealth64 drivers again on the off chance that I had done something wrong. Nope, same again. It looked as though the IBM drivers had done something to the system that the Diamond version didn't like. Most probably a INI setting but where and what I didn't know. At this stage I had a system that would not accept the drivers I wanted to install and I did'nt want to run the other ones. So I reformatted the drive and reloaded OS/2.

If your still reading this by now, then your probably wondering why on earth anyone would want this much hassel. The one thing you can say about the S3 drivers is that once you get them working they are wicked. OS/2 running in SVGA modes with customised icons and backgrounds is a truely spectacular operating system. Especially when some of the work place shell enhancement packages have also been added in.

But the real point here is that when installing drivers you have to take a little care. Especially with things like video drivers. CD-ROM driver an such are not so bad. Hey! if your CD-ROM doesn't work, you can still do other things. Not so with video.

But I guess the important things to note are that the install of the S3 drivers can be a little tricky, so be prepared to spend some time doing it and also be prepared to reinstall if you have to. Although I have hopefully given you some guidelines here that will help you avoid this. If your lucky enough and have a spare drive in your system then I would defineately recommend setting up another copy of OS/2 on it and testing drivers there first before installing in your main partition.