Brother HL-L6200DW Business Laser Printer

From OS2World.com Wiki
Revision as of 13:03, 23 September 2017 by Martini (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

[[Image:|thumb]]

General Specs

  • Model Number: HLL6200DW
  • Connection Method: Network / CUPS

General Comments

Reported to be working on ArcaOS 5.0 by David.

[quote] I connected the printer using a cat5e network cable to an 8 port switch connected to a router. The ArcaOS computer and the printer both connect to the 8 port switch.

I had to download the Linux (DEB) driver from the Brother website and decompress it to find the ppd file. On the printer itself I set an IP address outside of the assigned DHCP range on my router.

I then used the "Install CUPS printer" option in the Printers folder. Using the CUPS add printer option I pointed it to the PPD file when prompted. The setup then identified the Brother printer and completed the driver installation seemingly correctly with no errors. However, just as with my last printer (also a Brother laser printer) absolutely nothing would print. Despite the CUPS setup having identified the printer each time I tried to print I received an error stating that the printer could not be found.

Just as with my last printer, the only way I could get the printer to actually print was to change the output to an SLPR port. In this instance, I added an SLPR port, changed the "LPD Server" to the address of the printer, left the "LPD printer" as the default * and left the "High performance" and "LPRPORTD Compatible" options unchecked.

Doing the above allowed me to immediately print to the printer. I was able to print emails successfully and PDF files immediately. However, when I tried to print anything from OpenOffice V4.1.3 nothing would print, there was no error message and nothing in the queue. Anything I tried to print seemingly just vanished. I did find the solution though I have no idea why it works. What solved the problem of being unable to print was to open the printer driver options, go to the "Queue Options" tab and check the box next to "Print while spooling". Doing this immediately allowed me to print using OpenOffice 4.1.3 I still find setting a printer using CUPS to be confusing and have never managed to get it to work without having to change the output port to SLPR. I am now printing successfully from ArcaOS5.0 to the Brother L6200DW over a network connection. I have not tried to connect the printer via USB or wifi as I have no plan to use either of these methods. [/quote]