OS2 World.Com Forum

Subject  :  Can't run chkdsk /f
Author  :  ~Von
Date  :  05 Aug, 2004 on 07:50
I'm trying mount my OS/2 W4 HPFS file system from Mandrake 10 and I am having trouble. A bit of googling recommends running chkdsk /f from OS/2 to fix the problem. When I run chkdsk (w/o /f) from an OS/2 window, it tells me it finds errors but I need the /f to fix them. When I run chkdsk /f i get this error:

The current hard disk drive is: c:
The current file system for the disk is HPFS
The HPFS file system program has been started.
SYS0108: The disk is in use or locked by another process

Any ideas on how to get chkdsk /f to run? THe only thing that I can think that could be causing the problem is that I am using bootmagic to boot to the OS/2 install. Here is what the disk looks like:
Partition 1 is fat16 with DOS installed and boot magic
Partition 2 is fat32 with Win95 installed
Partition 3 is HPFS with OS/2
Partition 4 is fat32 with WinME

I'll try disabling partition magic to see if that does anything. Any other suggestions would be appreciated.


Subject  :  Re:Can't run chkdsk /f
Author  :  ~Von
Date  :  05 Aug, 2004 on 08:24
I tried disabling bootmagic and I am still not able to run chkdsk /f...

Subject  :  Re: Of course can't run chkdsk /f ...
Author  :  icebear
Date  :  05 Aug, 2004 on 09:28
... if any instance/s or process/es are active on the partition !!!

Are you booting from C: and then trying chkdsk on C:

One needs to boot from floppy or CD to get your chkdsk /f running properly !

Subject  :  Re:Can't run chkdsk /f
Author  :  Kim
Date  :  05 Aug, 2004 on 10:27
as mentioned already, see to that you boot from os2 diskettes, such as the installations diskettes when running chkdsk. If it still won't run chkdsk try using /f:2 instead.


Subject  :  Re:Can't run chkdsk /f
Author  :  Radek hajek@vuv.cz
Date  :  05 Aug, 2004 on 11:54
You cannot run chkdsk /f on the system partition. It'll be a problem. If you have emergency diskettes, then you can try to start OS/2 from the diskettes and run chkdsk c: /f from the promt. I haven't tried it so that I don't know whether you will succeed.

Powered by UltraBoard 2000 <www.ub2k.com>