OS2 World.Com Forum

Subject  :  New MB
Author  :  Trident
Date  :  27 Mar, 2007 on 15:50
I just migrated my eCS1.2 to a new machine and HD
SATA driver a Abit K7-v mb.
I did this by boot from the eCS cd then doing a hotserve copy
of both C and E partitions, C: being eCS and E: is all the programs.
here are some of the problems I now have, and any answers or
suggetions are welcome.
1. Scrolling in either firefox2.0 or Seamonkey 1.1 is slow, very slow
and is not smooth..yes have (smooth scrolling checked)
2. window draging is drag, then the screen seems to rewrite the window.
3. the mb has built in audio, AC97, which is what the eCS cd detects
when doing an install, but I get no sound from my speakers or
head set
4. I don't seem to have usb support, Hardware manager shows
2 different usb controllers, one is EHCI for usb 2.0
the other is (2) UHCI controllers using IRQ 11.
but usb device monitor says no usb connected...yes they are on
and pluged into the usb port.
ok guys lets hear from you on this

Subject  :  Re:New MB
Author  :  zman zirkle@wizard.net
Date  :  27 Mar, 2007 on 19:10
might be easier to debug (learn the ins and outs of the new hardware) with a fresh install. i've never had much luck cloning a system unless the base hardware was the same.

Subject  :  Re:New MB
Author  :  Fahrvenugen
Date  :  27 Mar, 2007 on 20:59

The scrolling and the window drag issue sounds like a video driver problem. You might want to bring your system back to plain old VGA display and then try re-installing SNAP.

For sound, try either reinstalling the UniAudio drivers, or try some of the different versions out there. One sound card that I have on one of my computers only works with the older (Innotek release, I think) version of UniAudio, but another computer I have works fine with the later drivers.

As for USB, try removing all the USB drivers from the config.sys, download the latest drivers for USB, and run the install for them.

Good luck.

Subject  :  Re:New MB
Author  :  Trident
Date  :  27 Mar, 2007 on 22:58
Fahrv, thanks for the info..
solved the scroll and drag problem with a reinstall of snap
still working on the sound and usb support..
well let you know what takes place

Subject  :  Re:New MB
Author  :  Pete losepete@ntlworld.com
Date  :  28 Mar, 2007 on 03:29
Hi Dave

Looking at your post I read it as:-

you have a new hard drive and a new mainboard.

you xcopy'd the existing system from old hard drive to new drive.

Regarding sound: AC'97 is not an audio chipset; it is a specification for an audio chipset. Therefore while both mainboards involved may have AC'97 sound and both may be supported by uniaud they are probably 2 totally unrelated chipsets.

So, you have uniaud installed for mainboard 1 but you are now using mainboard 2.

The only answer I have ever found for this is to reinstall the uniaud driver - I suggest the 114RC2 version may be worth a download from ftp://ftp.netlabs.org/pub/uniaud/uniaud114rc2.zip

You may also need to use a mixer to check that output and input switches are on and volume is set once booted. I use the PMUnimix mixer from http://hobbes.nmsu.edu/pub/os2/apps/mmedia/util/mixers/umixpm2p1.zip

You may find that this mixer peaks your cpu so you need to Right Mouse Button click on the mixer when you 1st start it and select Less aggressive from the menu.

For help with USB I am going to refer you to a little USB Configuration Tool that comes with a help file and a USB Removables FAQ. I suggest a read of those docs before attempting any changes. USBcfg is available here

Hardware Manager shows that your controllers are Enabled. What else do you expect?

If you are looking to discover what you have plugged into those controllers then you need to use either USB Resource Manager or USB Dock. They obviously do not show anything if there are no devices plugged in - note that devices plug into ports which are connected to controllers

As you have eCS1.2 you probably already have USB Resource Manager installed - check the Programs -> Utilities folder.

USB Dock is only available to eCS Software Subscription customers through the ecomstation betazone and is basically a replacement for USB Resource Manager.

Hope the above is of help


Subject  :  Re:New MB
Author  :  Trident
Date  :  28 Mar, 2007 on 16:58
Thanks Pete on the uniaud driver..could not find the one you specified
but am installing one of the earlier version.
Thanks for the hint on the usb tool, I am using USB manager
i've tried setting the usb in the bios...along with a the audio..
will keep you guys updated..thanks again

Powered by UltraBoard 2000 <www.ub2k.com>