OS2 World.Com Forum

Subject  :  Pioneer DVD-Rom (SCSI)
Author  :  Kim
Date  :  23 Aug, 2001 on 17:11
It looks like that when using the latest Pioneer SCSI DVD-Rom together with normal CDs (650mb not DVD)together with OS2 your not able to do following:

* Play Audio CDs
* Copy CDs/tracks with RSJ Writer

Any that have same problem or uses DVD-Rom (IDE) without any problem under OS2 and able to do above?


Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  pipes
Date  :  28 Aug, 2001 on 17:56
I have yet to get a DVD drive.. nice setup with the SCSI though

Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  BigWarpGuy
Date  :  05 Sep, 2001 on 20:07

Perhaps it is a driver thing? Here is a driver source for OS/2.

OS/2 Warp-ed to the very end.

Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  warpcafe warpcafe@yahoo.de
Date  :  27 Nov, 2002 on 10:10
Hi Kim,

I can't tell if this will help you solving the problem, but just yesterday I hooked up my SCSI DVD 303 from Pioneer that I bought on eBay and came across an interesting fact:

I thought that it was just a matter of pulling out my old TEAC 532S CD-Rom and putting in the Pinoeer, because SCSI - huh, you know it's just about ID an that's it, so it should work.

But nope Sir: At bootup I had a trap E in the OS2Kernel.
I quickly found out that OS2ASPI was the cause (that was added for cdrecord/2 ).

I then remebered, that some months ago I had trouble getting OS2CDROM.DMD to work and was forced to use JJSCDROM.DMD instead which worked great and - btw - allowed me digital extraction from my Teac. By error (!) I thought that I couldn't use OS2CDROM.DMD because of my SCSI controller (Dawicontrol 2967UW with SYM53C875 on it).
The fact is, that OS2CDROM.DMD couldn't actually handle the TEAC drive.

Now I decided to switch back to OS2CDROM instead of JJSCDROM and...: Everything worked beatifully - at least my machine doesn't trap anymore.

To sum up:
- try if there's any difference with using JJSCDROM instead of OS2CDROM. It might depend on your controller as well.
- Check if there is more than 1 ASPI router in your config.sys (e.g. if you're having RSJ and CDRecord/2 installed): Like VASPI and ASPIROUT...

Anyway: As I didn't check for Audio-CD's since I hooked up the DVD-rom yesterday evening, I'll now take a look immediately when getting back home today...


Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  RolandR
Date  :  27 Nov, 2002 on 15:29
Open the multimedia setup, click on the CD-tab and go onto the third page (by clicking twice on the small "+" in the upper right corner of the window).
You will see several checkboxes. Uncheck the "search" box (checked by default). This will enable you to play audio-CDs with the MMOS2-CD-player.

Audio-Cd track grabbing is possible by using jjscdrom.dmd. You have to use the flag /F for your DVD-ROM device with jjscdrom.dmd in config.sys.

Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  warpcafe warpcafe@yahoo.de
Date  :  27 Nov, 2002 on 21:48

I can at least confirm the same problems here.
While the OS/2 CDPlayer simply says "unit not ready (rc=5010)" (translated form german), PM123 says "DosDevIOCtl failed with return code 0xff08 reading sector xxxx-yyyy" when trying to play a track.
Building the track list at least seems to work.

I'll try to play with config.sys and let you know of any success...

Keep your head up!

Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  warpcafe warpcafe@yahoo.de
Date  :  28 Nov, 2002 on 15:28

I didn't start messing around with config.sys yet, but I was just busy sneaking around for information. Did you know that there is a hell of threads in the newsgroups all about SCSI Pinoeer DVD-ROMs not being able to play sound? Wow! Seems like we're not the only ones
In particular, I think it's Alex Taylor who did the most of posting - thanks to his information, I can at least suggest a workaround:
"There seems to be some limitation in MMOS/2 that prevents the OS/2 CD
Player applet from recognizing the drive as audio-capable. I have to
use Chris Wohlgemuth's WarpCD player instead (which doesn't use MMOS2

As far as I found out, all the problems are dealing with SCSI models.
Seems like due to the OS2CDROM.DMD and/or MMOS/2 limitations the drive can't handle certain commands.
When using JJSCDROM.DMD these problem might be solved, but in my case at least I won't be able to use an aspi driver to do cdrecord/2 because this will give me an TRAP E.

Possible solutions (as far as solutions exist when you don't know the actual problem...):
- Try other combinations of SCSI adapter driver, aspi and cdrom drivers
- Check at hobbes for PIONEER.ZIP
- use Chris Wohlgemuth's WarpCD player (circumvents MMOS2)

Because of the "error reading sector" message, I was wondering if there is any change in behaviour when using the pin #6 jumper to change the default sector size from 2048 down to 512... if this has any effect? Who knows?
Seems like we need *professional* help from aspi / device driver folks that tell us *why* this happens and *how* to get arounf the problems.
Even if there is no solution, I would like to know what the actual cause is!


Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  Kim
Date  :  28 Nov, 2002 on 15:42

As far as I found out, all the problems are dealing with SCSI models.

Would above mean that there are less problem when using IDE based DVD-ROM units? I always been a bigger fan of using SCSI, but ok if IDE offers less trouble, why not.

Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  warpcafe warpcafe@yahoo.de
Date  :  28 Nov, 2002 on 23:01
As far as I've seen in the newsgroups, nobody complained about IDE models.
But - heck! - we pay the price to have "better" systems with SCSI and finally we only get f***ed up by sluggish drivers?! No, sir!

But okay, let's get back to the test lab - I first concentrated on OS2CDROM.DMD and alternate solutions JJSCDROM.DMD (20021027) and the pioneer.zip patch for OS2CDROM.DMD, each one in conjunction with aspirout and OS2ASPI.DMD.
What I found out is:
Does NOT play Audio by MMOS2
Does NOT play Audio by DAE (digital) with PM123

- OS2CDROM.DMD patched with pioneer.exe
Does NOT play Audio by MMOS2
Does (!) play Audio by DAE (digital) with PM123

- JJSCDROM.DMD (20021027)
Does NOT play Audio by MMOS2
Does (!) play Audio by DAE (digital) with PM123

Okay - the TRAP problem apparently was caused by "older" version of JJ's driver. This is fixed. Both pioneer patch and JJ enable DAE, thus digital audio cd play works.
I just checked Chris Wohlgemuth's WarpCD and it works but I can't tell if it uses DAE to play or if it just simply "works"

Well, there IS a problem regarding MMOS/2 and SCSI DVD drives from Pioneer.
Maybe I'll have to write a short article in the VOICE newsletter to attract attention of the people that know what might cause the trouble.
Perhaps that's an issue for the screambox too...?


Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  Kim
Date  :  28 Nov, 2002 on 23:11
Odd, since Pioneer players usually in the past at least has been working rather problem free. Hmm.. but from what you have tested out so far it more or gives the advice to people planning to get Pioneer IDE drives instead of SCSI.

I've noticed that this topic have had rather hight interest among people since in top of the topic you'll see how many that have read this posting and it's not showing the number of pageview, it actually showing how many unique visitors that have read this posting based on their IP#. so yes, people are following this since I guess that rather many OS2 users has in the past bought Pioneer hardware, but they might not in the future.

What would be the best recommendation when it comes to get a proper working DVD-drive for OS2 then?


Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  warpcafe warpcafe@yahoo.de
Date  :  29 Nov, 2002 on 08:37
I dont't think it's a Pioneer-related problem, it's rather SCSI-related (thinking of the trouble with my Teac CDR32S drive).To make sure: It's not Pioneer who's to blame in my opinion.
If we take DANIs drivers for example: As far as I understand, they (besides other things) provide an interface for ASPI commands, making an IDE CD-whatsoever drive act as if it was a SCSI drive, enabling the user to use it along with e.g. CD-recording programs. And this works. So this proves the cause of the problem being the 'core' SCSI / ASPI implementation within OS/2 in my mind.
But this is just guessing. I can only observe from what I experienced on my system(s). I think I'll drop a post into the os2hardware group at yahoo and look what those "know-it-alls" will suggest me to do. Maybe anyone can clarify on the cause.


Subject  :  Re:Pioneer DVD-Rom (SCSI)
Author  :  sehh
Date  :  10 Dec, 2002 on 13:55
I also own a Pioneer DVD-ROM (305S).

This drive has two problems:

1) Locked firmware. The firmware locks speeds down to 6x or 4x
when you try to rip a DVD or CD. Any attempt to do RAW reads
results in drop of speed.

2) Ripping a music CD as a whole track will cause a cracking sound
at about the middle of the ripping procedure.

Both problems have already been identified by many review sites,
and thus this drive is been suggested to people who are not
interested in ripping.

The drive also has some incompatibilites with playing music CDs,
but that problem seems to exist under OS/2 only. So its
probably "our problem" only.

Powered by UltraBoard 2000 <www.ub2k.com>