OS2 World.Com Forum

Subject  :  Problems with Java
Author  :  Fudeba daniel@caetano.eng.br
Date  :  23 May, 2006 on 00:06

I am having some trouble using Java in one particular site, which happens to be my bank site... And I'm being obligated to boot Windows to do home banking (brrrrr!)
Well, the problem is: in Firefox/Mozilla/IBM Web, using Java 1.4.2, the browser simply hangs when I try to operate the controls (I can type the account and even type the password, but once I click on "entrar" (login) the browser hangs).

I used to access it from Netscape 4.61 running Java 1.1.8, and it worked ok... but sometime ago it just stopped to work (I have no idea!). I have another OS/2 machine at my side (my k6-2 500MHz server), which is able to operate that site using the very same Netscape 4.61 and Java 1.1.8 (it's just too slow and takes about 7 minutes or more just to logon... urgh). I tried to copy every dll from server to my client... but no way: nothing made Netscape access my bank home site. And yes, I tried to reinstall Netscape, no solution either.

I am very sad because this problem is bugging me for some time now. I had bought a new harddrive and began a fresh install... and it started to work again. But after I installed several software I need to work at home, it stopped to work and I just was not able to detect "what" instalation destroyed my ability to run that site on Netscape 4.61.

The site is: https://www2.bancobrasil.com.br/aapf/aai/login.pbk

And the error reported by Netscape 4.61 with Java 1.1.8 is:

IBM Corporation -- Java 1.1.8
Type '?' for options.
# Applet exception: class br/com/bb/aapf/bbteclado/CampoTeclado got a security violation: method verification error
java.lang.VerifyError: br/com/bb/aapf/bbteclado/CampoTeclado
at java.lang.ClassLoader.resolveClass(ClassLoader.java:273)
at netscape.applet.AppletClassLoader.loadClass1(AppletClassLoader.java:755)
at netscape.applet.AppletClassLoader.loadClass(AppletClassLoader.java:69
at netscape.applet.AppletClassLoader.loadClass(AppletClassLoader.java:675)
at netscape.applet.DerivedAppletFrame$LoadAppletEvent.dispatch(DerivedAppletFrame.java:449)
at java.awt.NetscapeEventDispatchThread$EventPump.dispatchEvents(Compiled Code)
at java.awt.NetscapeEventDispatchThread.run(NetscapeEventDispatchThread.java:121)
at netscape.applet.DerivedAppletFrame$AppletEvtDispatchThread.run(DerivedAppletFrame.java:924)

Any ideas? Suggestions are VERY welcome.

PS: the only "strange" thing I stalled which is related to Java and *is not* intalled on server is HDManager, the "replacement" for IBM's LVM GUI. I thought about uninstalling it, but it seems the package do not has an uninstall option.

Thanks in advance.

Subject  :  Re:Problems with Java
Author  :  Fudeba daniel@caetano.eng.br
Date  :  23 May, 2006 on 00:39

In fact, I had an "insight" and took a look at my CLASSPATH and found out that the install of HDManager, which replaces LVMGUI.ZIP had *not* removed this entry from CLASSPATH.
Because LVMGUI.ZIP from HDManager is a Java 1.2 file, Java 1.1.8 was becaming crazy and crashing the applet.

Well, here's the advice: if you ever install HDManager, remember to manually *remove* the LVMGUI.ZIP from CLASSPATH.


Powered by UltraBoard 2000 <www.ub2k.com>