OS2 World.Com Forum

Subject  :  Firefox 2.0 - Cannot install any extensions
Author  :  brittonx brittonx@gmail.com
Date  :  06 Nov, 2006 on 06:10
I have not been able to get Firefox to install any extensions. I get an error saying the file could not be installed. Looking at the error log, I see the following:

Error: [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIRDFService.GetDataSourceBlocking]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: file:///C:/FIREFOX/components/nsExtensionManager.js :: getInstallManifest :: line 892" data: no]
Source File: file:///C:/FIREFOX/components/nsExtensionManager.js
Line: 892

Any Ideas?

Subject  :  Re:Firefox 2.0 - Cannot install any extensions
Author  :  El Vato
Date  :  07 Nov, 2006 on 16:28

brittonx (06 Nov, 2006 06:10):
Any Ideas?

Although I normally use the whole Mozilla suite, I installed firefox 2.0 in my Merlin fixpak 15 and WSEB server machines. No problem installing the extensions: http://www.chingonazo.com/firefoxExtWebDev.JPG

I have uploaded an self executable file with a single extension -- the Web Developer -- in case you may want to try and/or compare the file tree structure to yours
(the extension shown in the JPG above is the one installed).

Once you download the file simply open a command prompt and change to the directory where you want firefox unzipped; follow that by typing at the command prompt:

firefox-2.0.exe -d

Do not forget the switch (-d); otherwise the directories will not be created. I am using the licensed version of Pkzip for OS/2 to compress.

Alternatively, if you want the non self-executable version with the included extension, simply point your browser to:

Notwithstanding, judging from your error message, your unzipping utility may have issues and/or your file may have been corrupted in transition.

Disclaimer: the files referenced above worked fine in my OS/2 environment and I was able to install the extension I referenced. Notwithstanding, by downloading either (or both them) you agree that you do so at your own risk.

I will be emailing you the user/password combination to the files of reference.

Good luck!

Subject  :  Re:Firefox 2.0 - Cannot install any extensions
Author  :  davidfor
Date  :  09 Nov, 2006 on 23:52
I have had no problems installing extensions in Firefox 2.0. That suggests it is either the extension, something wrong with your profile or something wrong with you Firefox installation. If it is happening for more than one extension, it is probably one of the latter two.

I would recommend following the suggestions on http://kb.mozillazine.org/Standard_diagnostic_-_Firefox . This is a pretty good guide for debugging this sort of Firefox issue. There is no mention of OS/2 on the page, so use the Windows instructions with reference to http://www.os2bbs.com/os2news/Warpzilla.html to sort out the OS/2 paths.

Good luck and don't forget to come back and tell us how it goes.


Subject  :  Re:Firefox 2.0 - Cannot install any extensions
Author  :  brittonx brittonx@gmail.com
Date  :  10 Dec, 2006 on 08:39
Well, I finally solved my problem.

I had tried numerous things. I was having this problem on any OS/2 install I have done over the last year.

The final solution was to add the following to CONFIG.SYS:
(I made sure there was a D:\TEMP in existence)

There was already a TMP variable, just not TEMP. Now I have both and extensions install with ease.

Powered by UltraBoard 2000 <www.ub2k.com>