Copyright 2021 - OS2World - Contact us

News

Bitwise Updates: rpm, python-rpm-macros, popt, createrepo_c, qt5, pthread, os2-base, poppler-data, ca-certificates, highmem

Bitwise works published a new set of updated for rpm, python-rpm-macros, popt, createrepo_c, qt5, pthread, os2-base, poppler-data, ca-certificates, highmem.

Remember to sponsor them via their webshop or Patreon page. 

 

 

 

Rpm work:
We released version 4.13.0-20 of rpm (The RPM package management system), version 3.9-2 of python-rpm-macros (The common Python RPM macros), version 1.18-2 of popt (C library for parsing command line parameters), version 0.17.3-2 of createrepo_c (Creates a common metadata repository), version 5.15.2-1 of Qt5 (Qt5 meta package), version 0.2.6-1 of pthread (A posix pthread emulation for OS/2 and OS/2 based systems), version 0.0.1-3 of os2-base (OS/2 - eComStation 2.0 - ArcaOS 5.0 base), version 0.4.11-1 of poppler-data (Encoding files for use with poppler), version 2021.2.50-1 of ca-certificates (The Mozilla CA root certificate bundle), version 1.0.3-1 of highmem (HighMem, a LX format 32bit DLL 'loading above 512MB' marking utility)
It is uploaded as rpm to the netlabs rel or exp repository. To install, use either yum or ANPM. If anyone prefers a zip file, those are available at the netlabs rel repo or at the netlabs exp repo.

Non rpm work:
We released a test browser to some testers.
To be able to finish this all we urgently need more sponsors!!!.

Behind the scenes
There are more projects being worked on. If you are interested in it all, please look at our GitHub repo's.
Again to be able to finish this all we urgently need more sponsors!!!.

What's new in rpm:

  • force proper sse2 alignment in optflags on x86 platforms
  • cherry pick some lua changes from upstream, fixes lua path handling

What's new in python-rpm-macros:

  • use the right location for the python.lua scriptp
  • use new %%{_rpmluadir} macro instead of %%{_rpmconfigdir}/lua

What's new in popt:

  • update to version 1.18
  • add a forwarder to the old popt.dll
  • obsolete and provide -libs and -data/li>
  • use epoch 1, as old spec had it

What's new in createrepo_c:

  • add -Zbin-files, as the rpm dll need it. which is a rpm dll flaw!!!

What's new in Qt5:

  • Release version 5.15.2 for OS/2
  • Add qtmultimedia, qtwebchannel, qtwebsockets to dependencies

What's new in pthread

  • Add pthread_condattr_setclock() and needed functions for that
  • Fix ticket 16 with pull request 17
  • Fix wrong return codes in pthread_rwlock_try*lock()

What's new in os2-base

  • Set pentium4 as defalut platform

What's new in poppler-data

  • updated to version 0.4.11
  • adjusted the spec according to fedora

What's new in ca-certificates

  • update to latest fedora spec
  • update ca-cert to latest Mozilla cert

What's new in highmem

  • Always skip marking of libc runtime dlls

What's new in Chromium:


Sponsoring
To be able to finish our goals we need your support. Please sponsor as much as possible via our webshop or via our Patreon page.

OS/2-eCS-ArcaOS General News

OS/2-eCS-ArcaOS Software News

Latest Forum Posts

WarpStock and OS/2-eCS-ArcaOS Event News

Site News

f t g m