Author Topic: Firefox 38 problem  (Read 6183 times)

karotlopj

  • Guest
Firefox 38 problem
« on: April 26, 2016, 04:09:48 pm »
After a lot of trial and error trying to get the latest Firefox (v38) running, I discovered the '-console' command line parameter which revealed:-

Quote
Video driver is SNAP
Unable to enable DIVE

Killed by sigsegv

What should I do?

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 38 problem
« Reply #1 on: April 26, 2016, 04:38:11 pm »
Is that the entire output of redirecting firefox? Firefox 2>&1 | tee firefox.log
Here I get,
Code: [Select]
DIVE is disabled - Panorama's shadow-buffer is enabled
Assertion failed: fcCacheChains[i] == NULL, file fccache.c, line 533

Killed by SIGABRT
pid=0x007d ppid=0x0021 tid=0x0001 slot=0x0102 pri=0x0200 mc=0x0001 ps=0x0017

Note that the sigabrt comes from fontconfig.
Snap should automatically enable DIVE if it passes an sanity check, including using 32 bit colour.

Daniel Carroll

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: Firefox 38 problem
« Reply #2 on: April 27, 2016, 01:17:45 am »
Now that's interesting... so I typed in
Firefox 2>&1 | tee firefox.log
While running Firefox 31.8.0 in 16 million colors and 1920 x 1080 at 60 Hz, ATI Radeon X850 series using SNAP.
And got..

VMI_CMD_SETPTR - rc= 0  ulStatus= 1
Video driver is SNAP - mouse ptr will not be hidden
_init_dive:  _load_dive() succeeded
_init_dive:  hDive= 1  scrn= 0x2a50000  format= BGR4
Changing DIVE from enabled to disabled - 'layers.acceleration.disabled' is TRUE


Isn't BGR4 a four bits per pixel mode?

Daniel Carroll

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: Firefox 38 problem
« Reply #3 on: April 27, 2016, 01:37:12 am »
Ok, it's a 4 bytes per pixel mode. I still don't have a clue why it disables Dive. But that's normal enough.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 38 problem
« Reply #4 on: April 27, 2016, 04:53:29 am »
You have it disabled for some reason,
Quote
Changing DIVE from enabled to disabled - 'layers.acceleration.disabled' is TRUE

Go into about:config, search for layers.acceleration.disabled, right click on it and choose toggle.

Daniel Carroll

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: Firefox 38 problem
« Reply #5 on: April 27, 2016, 08:23:33 am »
That was it. I have no idea what set it to off or why, but thanks.

karotlopj

  • Guest
Re: Firefox 38 problem
« Reply #6 on: April 27, 2016, 11:37:32 am »
You have it disabled for some reason,
Quote
Changing DIVE from enabled to disabled - 'layers.acceleration.disabled' is TRUE

Go into about:config, search for layers.acceleration.disabled, right click on it and choose toggle.

I'm trying to follow this and don't understand what is going on...

Do I have a DIVE setting somewhere? It's not something I have installed.

arr531

  • Guest
Re: Firefox 38 problem
« Reply #7 on: April 27, 2016, 12:53:10 pm »
I believe he is referring to the configuration page within Firefox - about:config.

karotlopj

  • Guest
Re: Firefox 38 problem
« Reply #8 on: April 27, 2016, 02:25:46 pm »
If Firefox doesn't load up, how do I change this, if it is causing the problem?

Is there a cfg file I can edit?

arr531

  • Guest
Re: Firefox 38 problem
« Reply #9 on: April 27, 2016, 03:09:46 pm »
Can you try running it in safe mode? I believe the switch is -safe-mode although that might not be the correct syntax. I have not tried starting it from the command line so I am not familiar with the switches.

Okay, I just checked the command line help and it is --safe-mode.
« Last Edit: April 27, 2016, 03:36:08 pm by adam »

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 38 problem
« Reply #10 on: April 27, 2016, 04:35:42 pm »
If Firefox doesn't load up, how do I change this, if it is causing the problem?

It shouldn't stop Firefox from running.
Quote
Is there a cfg file I can edit?

prefs.js in your profile

karotlopj

  • Guest
Re: Firefox 38 problem
« Reply #11 on: May 06, 2016, 01:56:31 pm »
Quote
VMI_CMD_SETPTR - rc= 0  ulStatus= 1
Video driver is SNAP - mouse ptr will not be hidden
_init_dive:  _load_dive() failed
Unable to enable DIVE - it will not be used for this session

Am I unable to load the latest Firefox because DIVE  cannot be enabled?

I can run v31.8.0 without any problems.

Pete2

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 3
  • Posts: 24
  • Karma: +4/-0
    • View Profile
Re: Firefox 38 problem
« Reply #12 on: May 06, 2016, 04:14:24 pm »
Hello John. Nice to hear from you again. Have you checked that you have all the required dependencies? PMdll ( http://hobbes.nmsu.edu/download/pub/os2/util/system/pmdll-2.12.zip) is a good tool for this.

karotlopj

  • Guest
Re: Firefox 38 problem
« Reply #13 on: May 06, 2016, 04:33:15 pm »
Hello John. Nice to hear from you again. Have you checked that you have all the required dependencies? PMdll ( http://hobbes.nmsu.edu/download/pub/os2/util/system/pmdll-2.12.zip) is a good tool for this.

I have run chkdll32 on firefox.exe  and xul.dll and all the required dll's are available. There are no error msgs displayed. Firefox simply will not load. I'm obviously missing something fundamental since no one else seems to have this problem.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 38 problem
« Reply #14 on: May 06, 2016, 05:25:19 pm »
If it is running long enough to do the DIVE test, it may be a bad fontconfig install or an old DLL, probably gcc*dll, stdcpp*dll or possibly a libc06*.dll that is not a forwarder.