Author Topic: Backslash changes to long dash  (Read 2264 times)

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 233
    • View Profile
Backslash changes to long dash
« on: May 11, 2016, 12:00:21 pm »
For some reason my backslash key has turned into a long dash '─' not the normal dash '-'.

Anyone know what could have done this and how to rectify the situation.

Now I can only insert a backslash by pasting it in from the clipboard - not very convenient...

This what I have in config.sys:

BASEDEV=IBMKBD.SYS
COUNTRY=044,C:\OS2\SYSTEM\COUNTRY.SYS
CODEPAGE=437,850
DEVINFO=KBD,UK166,C:\OS2\KEYBOARD.DCP
SET LANG=en_GB
SET TZ=gmt0bst
SET ULSPATH=C:\LANGUAGE
DEVICE=C:\OS2\BOOT\UNICODE.SYS

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 34
  • Posts: 977
    • View Profile
Re: Backslash changes to long dash
« Reply #1 on: May 11, 2016, 12:41:33 pm »
Is there a possibility that the keyboard table for your keyboard (C:\LANGUAGE\KEYBOARD\UK166.KBL) is damaged or missing?

The other thing is that the physical keyboard may have a problem and is sending the wrong keycode.

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 8
  • Posts: 451
    • View Profile
Re: Backslash changes to long dash
« Reply #2 on: May 11, 2016, 01:56:09 pm »
You can change your keyboard in a command com
keyb SP               for spanish
keyb UK               US               etc.. see the help for locate your country keyboard.

Saludos

Sergey Posokhov

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 6
  • Posts: 118
    • View Profile
    • OS/2 API Research
Re: Backslash changes to long dash
« Reply #3 on: May 11, 2016, 02:02:10 pm »
In case if my program does it, just disable the feature.
I can disable it by default in further versions, if you want.

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 233
    • View Profile
Re: Backslash changes to long dash
« Reply #4 on: May 11, 2016, 08:51:56 pm »
In case if my program does it, just disable the feature.
I can disable it by default in further versions, if you want.

Hi Sergey,

It probably is Nice Enhancer causing the problem...

I've only just installed it, and it is a nice program although I haven't fully investigated it yet.

I can't identify which notebook setting to change - there are so many of them.

I'm using v570 but haven't found the settings page shown in the image you have displayed.




guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 16
  • Posts: 302
    • View Profile
Re: Backslash changes to long dash
« Reply #5 on: May 11, 2016, 10:20:39 pm »
Hello Sergey,

Could it be that Nice uses the primary codepage to determine the language it installs in? I have 866 as primary and Nice installs in Russian.  Is there a way to force installation in English?

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 35
  • Posts: 813
    • View Profile
Re: Backslash changes to long dash
« Reply #6 on: May 12, 2016, 05:41:49 am »
Hi John

Is the codepage right for a UK keyboard?


Regards

Pete

John Poltorak

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 0
  • Posts: 233
    • View Profile
Re: Backslash changes to long dash
« Reply #7 on: May 12, 2016, 07:59:25 am »
In case if my program does it, just disable the feature.
I can disable it by default in further versions, if you want.

Hi Sergey,

When I did a Shutdown of the Nice Enhancer daemon, I got my blackslash back.

Sergey Posokhov

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 6
  • Posts: 118
    • View Profile
    • OS/2 API Research
Re: Backslash changes to long dash
« Reply #8 on: May 13, 2016, 12:21:22 am »
The program is just a plug-in for Presentation Manager that uses a little Shared Memory area to track its state and multi-threaded daemon to do the whole work. Source code was in bad condition so it has been re-arranged and partially rewritten in 2006.

To install it in English, just type: "Install.exe english" in FC/2.

To disable backslash substitution, open a settings in "Keyboard >> FireFox keys" and disable "Use '|\' key to type dash and quotes".

I would like to turn it OFF by default in the next version.