OS/2, eCS & ArcaOS - Technical > Games

Running MGL Doom on Warp 4

(1/3) > >>

I am trying to run MGL Doom on Warp 4 and I am getting the error "Double Buffereing not available!".  The readme doc states that SDD beta38 or later is required.  I am using SNAP 3.1.8 for my graphics driver.  This is a later driver and I am able to get further along than with sddse704.exe.  I have not tried sdd7_b38.zip which is not as new as what I am currently using and I believe that it will require a license.  Perhaps SNAP 3.1.8 does not have the required functionality?  I do have SDDHELP.SYS running.  Anyone know what is necessary in order to have MGL Doom run on Warp 4 in this case?

I can get MGL Doom to run on a demo eComStation CD (I currently do not have a full version yet).


Scott, I can't answer your question directly because I don't have MGL Doom but from this question and your problems with dialogue boxes it sounds as if you have a very messed up system.

A few questions to get things started. 
What was the fixpak that you last installed?  As far as I can remember 5 was the last official but I have the unofficial 6 on all the workstations here.  There is also the device driver fixpak 3, I seem to remember.
Have you run cleanini, xfix (from xworkplace) or checkini (from wptools) in clean mode and so cleaned out the dross in your ini files?
Last, is there anything else that isn't quite working as it should?  If there is then we need to fix your system before you do much more  ;)

Dave Yeo:
The last free Warp v4 fixpak was 15 and the last was 17. The last free device driver fixpak was 2 but 1 should be installed first due to a bug IIRC. The 3rd device driver fixpak was non-free/
The kernel should also be updated to 104w level after applying fixpak 15 which brings the system to Warp v4.5
IIRC Scitech requires at least fixpak 5

I applied Fixpack 15 (XR_M015) then applied DD 2 (XR_D002).  After this is when I applied  sddse704.exe and then SNAP 3.1.8 which I am currently using.  I then also applied Fixpack 17 (XR_M017).  There were networking fixes that I applied too.  My ver reports as 4.50.  BLDLEVEL on my kernel shows revision 14.97.  I have not made any specific kernel updates other than what might have been applied via a fixpack.  My OS/2 Base Operating system shows version 4.00.0 with a syslevel of XR0M017.

Everything seems to be running fine.  I have network access, sound (Timidity for MIDI), the SciTech GL 3D test examples run very well.  All other applications are running fine (DeScribe, Lotus SmartSuite, IBM Works, X Workplace) as well as Windows, DOS, and the included games.  I have no crashes (except maybe when switching out of a full command prompt screen after using the SciTech tests - which I rarely do).

It is entirely possible I have something messed up.  I tried to apply things in the order that seemed most people did.  The only thing I can think is that when I am installing a fixpack/updates and a newer file is found than the one to be written to disk I cancel the overwrite in order to retain the latest version.  Is that the wrong approach for OS/2 updates?  I have not ran any of the utilities that you have suggested and will check them out.


Thanks for the correction David re fixpaks - my excuse, it was late at night after a very frustrating long day and I was going on memory ;)

Scott, I have generally allowed the overwrite but just note the file name so I can restore it from backup if necessary as I think all that is checked is the date of the file rather than any internal information.  For example, several of the files in the SNAP video get given dates when they were installed rather than the date they were created so when you go to upgrade they appear to be newer than the update files when in fact they are not.

As I said there could also be a lot of garbage in your ini files that could be removed with advantage - it also reduces the size if the ini files, another advantage.  I do a run of cleanini /c /restart on all the workstations here every Friday evening which removes redundant references to such things as deleted or moved files and so on.


[0] Message Index

[#] Next page

Go to full version