Author Topic: Success using Brother L6200DW printer with ArcaOS.  (Read 5495 times)


  • Guest
Success using Brother L6200DW printer with ArcaOS.
« on: September 21, 2017, 10:52:30 pm »
In case anyone is looking to use a Brother L6200DW ( ) black and white laser printer I can now say with certainty that it works under ArcaOS 5.0

I connected the printer using a cat5e network cable to an 8 port switch connected to a router.  The ArcaOS computer and the printer both connect to the 8 port switch.

I had to download the Linux (DEB) driver from the Brother website and decompress it to find the ppd file. 
On the printer itself I set an IP address outside of the assigned DHCP range on my router.
I then used the "Install CUPS printer" option in the Printers folder.
Using the CUPS add printer option I pointed it to the PPD file when prompted.  The setup then identified the Brother printer and completed the driver installation seemingly correctly with no errors.  However, just as with my last printer (also a Brother laser printer) absolutely nothing would print.  Despite the CUPS setup having identified the printer each time I tried to print I received an error stating that the printer could not be found.
Just as with my last printer, the only way I could get the printer to actually print was to change the output to an SLPR port.  In this instance, I added an SLPR port, changed the "LPD Server" to the address of the printer, left the "LPD printer" as the default * and left the "High performance" and "LPRPORTD Compatible" options unchecked.
Doing the above allowed me to immediately print to the printer.  I was able to print emails successfully and PDF files immediately.  However, when I tried to print anything from OpenOffice V4.1.3 nothing would print, there was no error message and nothing in the queue.  Anything I tried to print seemingly just vanished.  I did find the solution though I have no idea why it works.  What solved the problem of being unable to print was to open the printer driver options, go to the "Queue Options" tab and check the box next to "Print while spooling".  Doing this immediately allowed me to print using OpenOffice 4.1.3
I still find setting a printer using CUPS to be confusing and have never managed to get it to work without having to change the output port to SLPR.
I am now printing successfully from ArcaOS5.0 to the Brother L6200DW over a network connection.  I have not tried to connect the printer via USB or wifi as I have no plan to use either of these methods.
I hope that this information may prove useful to some folk.
« Last Edit: September 21, 2017, 11:02:36 pm by David »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4778
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Success using Brother L6200DW printer with ArcaOS.
« Reply #1 on: September 23, 2017, 03:09:11 pm »
Thank you for reporting hardware David.

If it is ok with your I had also posted it on the OS2World Wiki. With your same OS2World UserID and Password you can also update the page.

Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Posts: 1328
  • Karma: +26/-0
    • View Profile
Re: Success using Brother L6200DW printer with ArcaOS.
« Reply #2 on: September 24, 2017, 01:30:39 am »
Hi David,

Great post, thanks for getting it out there.

I picked up a Brother HL5470DW nearly 2 yrs ago, it is no longer being sold by Brother. I was able to get it running with the Postscript drivers, however, there are some combinations of print job settings that actually cause the PSCRIPT driver to trap. Subsequently, I am using a sub-set of options, but was always wondering how much further ahead I would get with the CUPS driver.

The model you picked up literally seems to be a new version of my HL5470DW, or at the very least simplar printer engine, etc, etc...granted, yours is more of a workgroup printer.

So I'm curious, have you been able to put it through it's "paces" using the CUPS configuration? What I mean by that is:

1) are the various printer quality settings (300,600, HQ1200, 1200, etc) working as expected? This applies to both text and images.
2) are you able to use the built-in scanner?
3) are the other normal options such as Duplex printing, scaling, booklet printer all working?

Thanks again,