OS/2, eCS & ArcaOS - Technical > Hardware

SATA AHCI weirdness

(1/3) > >>

Hi, long time lurker, first time poster. I was wondering if anyone might be able to help me out.

Let's start at the beginning. I have been trying to install Warp 4 on my primary desktop computer, I can give more detailed hardware info if you need it. It doesn't have a floppy drive so I installed a really basic version of OS/2 in Virtual PC and then wrote the virtual hard drive image to the physical disk. I added the latest versions of DaniATAPI.flt, and DaniS506.add to the system as well as OS2AHCI.add (not the latest version) before I transferred the image
OS/2 boots up to a point OS2AHCI correctly recognizes the Intel ich7 chipset but then DaniATAPI won't load and it gives the "OS/2 cannot operate your hard disk" error.
I did this with and without Fixpack 15 applied before the transfer and got the same results, the one time I did get it to work was from a FAT partition instead of HPFS, but it corrupted the desktop as soon as it was shut down.

I have done all I know to do, I don't really have the money to spend on a copy of eCS right now, though the Live CD does work great. I stared this just for something to do, but now I am determined to get it to work. I realize that it could be a problem with the image transfer, and if that is it, I guess I'm done, unless it is possible to make a custom boot CD.

Any help anyone can give would be greatly appreciated!

Andy Willis:
Depending on how old your copy of os2ahci is, it may be prior to some issues that were resolved relatively recently.  You may be able to remove the os2ahci driver and let danis506 run the drive (you may or may not need to turn the SATA legacy mode on in the BIOS if available).

os2ahci is version 0.1.4 (the one from hobbes). I have tried setting the BIOS to both SATA and IDE mode, with and without os2ahci loaded, I even tried SCSI mode once, to no avail. Danis506 does not seem to recognize the drive no matter what I do, but daniatapi.flt will not load at all. all my hardware *should* be compatible, and like I said, it worked one time from a fat16 partition. I may try that again and see what it does.

Hi Floyd

I think more detailed hardware info may help others to come up with possible solutions.

I'm tending to suspect that you may have a mainboard that requires ACPI support.



Here is some more hardware info:
Motherboard- Intel BOXDH77KC LGA 1155 It does support ACPI.
CPU- Intel i3-2120 3.30Ghz
8gb of RAM
Intel 7 Series/C216 chipset family SATA AHCI controller

I'm just using the on-board video and sound for now, I doubt that would stop it from booting.


[0] Message Index

[#] Next page

Go to full version