Author Topic: Firefox problem, was Re: IRC speakup with BWW this Saturday (3 of March)!  (Read 1475 times)

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 8
  • -Receive: 102
  • Posts: 1401
    • View Profile
I made a STARTUP.CMD file and put it into my ArcaOS 5.02 root directory.

@ echo off
x:
md temp
exit

I'd suggest
x:
if not exist x:\temp mkdir \temp
exit
As at least here, after a warm reboot, all files are still present on the ramdisk and IIRC, trying to create an existing directory causes an error.
Quote
which creates a temp directory on drive X which is my RAM drive.

I then changed my config.sys to point to where my new temporary directory is located.

SET TMP=x:\\temp
Is this typo also in your config.sys?
Quote
SET TEMP=x:\temp
SET TMPDIR=x:\temp

Now the problem.

My Firefox 45.9.0 download directory in Options points to

f:\home\temp

When I download a file, it always fails.  When I click the retry, it shows it finishes the download.

However,the downloaded file is not found in the f:\home\temp directory.

I now find it in my X:\temp directory.

Before, Firefox would have no problem downloading and the downloads would always be found in the home\temp directory.

Have I done something wrong or is this a problem with Firefox?

Sometimes it seems hard to get changes to the download directory to stick. Try pointing it elsewhere and then try putting it back.
BTW, Firefox also has problems downloading to the root of a drive.

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 7
  • Posts: 164
    • View Profile
Hi Dave

Thank you for the suggestions.

I changed my Startup.cmd as you suggested.  Works great.

That was a typo in my config.sys that I corrected.

Made the two changes and Firefox download works as it should. 

Thanks for your help.

David