OS/2, eCS & ArcaOS - Technical > Networking

Test build wpa_supplicant v2.7

(1/3) > >>

Andi B.:
I've made a test build of the newest wpa_supplicant code and uploaded it to https://bitbucket.org/Andi_B/os-2-wpa_supplicant/downloads/.

It can be used together with current xwlan builds. From the readme.os2 -

--- Code: ---###############################################################################
BetaTester installation intructions
- replace installed wpa_supplicant.exe with the included one
When using xwlan widget wpa_supplicant is usually found in
\util\xworkplace\plugins\xcenter\xwlan\.
When using the standalone wlanstat then in .\xwlan\.
- check if the new version is used by xwlan/wlanstat
right-click - properties - tab 'WPA supplicant' check version and path
- connect to wpa protected networks and post your findings at correspondending
thread at os2world.com
- you can also test wpa_supplicant with a .conf file. F.i. set up a profile
with no security, switch on wireless and start wpa_supplicant manually
(f.i. wpa_supplicant.exe -i lan1 -cwpa_supplicant.conf)
###############################################################################
--- End code ---

If someone want to test feel free to post your findings here. If you're using the xcenter widget (in contrary to the standalone wlanstat.exe), be sure your ALT-F1 boot works or you've a working maintenance partition. I once saw a hang on my T60 at bootup of the xwlan widget with teh new wpa_supplicant.

Have fun.

Dave Yeo:
Hi Andi, thanks for the update.
The readme.os2 needs updating to refer to where ArcaOS stores its wpa_supplicant.exe, namely x:\sys\apps\xwps\plugins\xcenter\xwlan
After rebooting (is this needed? Perhaps add to readme.os2) right clicking shows I'm now using wpa_supplicant v2.2 (eCS-v1) which I have to assume is correct.
Double clicking the widget connected to my internet hub fine, seemed to connect quicker. Firefox loaded pages fine.
This on a T42

Andi B.:

--- Quote from: Dave Yeo on March 13, 2018, 06:55:43 pm ---Hi Andi, thanks for the update.
The readme.os2 needs updating to refer to where ArcaOS stores its wpa_supplicant.exe, namely x:\sys\apps\xwps\plugins\xcenter\xwlan

--- End quote ---
Thanks for the input.


--- Quote ---After rebooting (is this needed? Perhaps add to readme.os2)

--- End quote ---
No. New wpa_supplicant is used whenever a new connection (profile) is established.


--- Quote --- right clicking shows I'm now using wpa_supplicant v2.2 (eCS-v1) which I have to assume is correct.

--- End quote ---
Unfortunately this is wrong. Your version is what I supplied with xwlan3.12. The new one should identify itself with 'v2.7 (OS/2-v2beta)....'

Seems you didn't not copy it into the correct directory. Check 'right-click - properties - tab 'WPA supplicant' version and path'. Be aware wlanstat uses a different directory than the xwlan widget.

Dave Yeo:
I must of mis-clicked when copying the exe. Now it says "wpa-supplicant v2.7-devel (OS2-v2beta)-hostap_2_6-1746-gba5 and perhaps 4, it is clipped at this point as itis wider then the settings window.
Seems to work fine.

Holger Schuett:
Hi Andi,
I start wpa_supplicant by using a .conf file. and do not use xwlan. For some reason this only worked (until know) with a very old version of wpa_supplicant dated from 2008.
I tried the one you uploaded (thank you for all the work!). At first it did not work, this was the message shown:
Successfully initialized wpa_supplicant
lan0: No network configuration found for the current AP
I amended my .conf with ap_scan=2, this helped, works now

Holger

Navigation

[0] Message Index

[#] Next page

Go to full version