OS/2, eCS & ArcaOS - Technical > Networking

Test build wpa_supplicant v2.7 - v2.10-devel

<< < (2/5) > >>

Andi B.:

--- Quote from: Holger Schuett on March 18, 2018, 09:14:35 am ---...
I amended my .conf with ap_scan=2, this helped, works now

Holger

--- End quote ---
Good to hear. The .conf file is full of documentation. Honestly I've to say I do not understand what all the options are good for. I only enabled the build to allow .conf file cause someone asked it long ago in a ticket IIRC. I never used it by myself and so can do only very limited testing. This is one reason why I asked here for testers.

Feel free to open an issue at https://bitbucket.org/Andi_B/os-2-wpa_supplicant/issues?status=new&status=open if you find any problem with the supplicant or here http://trac.netlabs.org/xwlan/newticket. I guess you need to login there for doing that. No promise that anyone is fixed especially things I can not test. But sometimes even tickets opened years ago get fixed eventually :)

Holger Schuett:

--- Quote ---I only enabled the build to allow .conf file cause someone asked it long ago in a ticket IIRC.
--- End quote ---
If you mean this one it was me too:
https://www.os2world.com/forum/index.php/topic,1444.0/topicseen.html
So thank you for keeping this in mind!
I will continue to do further testing with your new build and try to read andunderstand the documentation.

Holger

Holger Schuett:
Hi Andi,

I did a little more testing with your new build compared to the old one I use.

For the records: The old wpa_supplicant is shown as version 0.5.7.
This one works well when using a .conf file and works well with xwlan too. The connection to my wlan is established extremely fast.
Message :
Trying to associate with SSID 'WLAN-KHH8TK'
Associated with 08:7a:4c:01:98:2e
WPA: Key negotiation completed with 08:7a:4c:01:98:2e [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to 08:7a:4c:01:98:2e completed (auth) [id=0 id_str=]

The new  build works well too in xwlan and using a .conf file but connection is sometimes established slower.
Message:
lan0: No network configuration found for the current AP
lan0: CTRL-EVENT-DISCONNECTED bssid=18:00:71:08:31:1e reason=3 locally_generated=1
  ndis_get_oid res=36
lan0: No network configuration found for the current AP
lan0: CTRL-EVENT-DISCONNECTED bssid=18:00:71:08:31:1e reason=3 locally_generated=1
lan0: Trying to associate with SSID 'WLAN-KHH8TK'
  ndis_get_oid res=36
lan0: Associated with 08:7a:4c:01:98:2e
  ndis_get_oid res=36
lan0: WPA: Key negotiation completed with 08:7a:4c:01:98:2e [PTK=CCMP GTK=CCMP]
lan0: CTRL-EVENT-CONNECTED - Connection to 08:7a:4c:01:98:2e completed [id=0 id_str=]

Both messages are what I see when using xwlan and choosing wpa_supplicant visible.
And sometimes when using the new build connection is interrupted and it may take several tries to reestablish the connection.

Using the .conf file the messages are the same as above, depending on which wpa_supplicant I use.
Using your new build with a .conf file I played around with the ap_scan= line documented in the wpa_supplicant.conf included in the new build.
The best seems to be to set ap_scan=2, but I admit, I have no idea why?

Holger

Andi B.:
I've uploaded a new test build with current code of development branch. Included is wpa_gui.exe too. See https://bitbucket.org/Andi_B/os-2-wpa_supplicant/downloads/20180313_wpa_supplicant_v2.7beta.zip
Here's the top of the readme -

###############################################################################
Installation intructions for Beta & RC testers

Using with XWLAN/WLANSTAT
-------------------------
- Replace installed wpa_supplicant.exe with the included one. When using xwlan
  widget wpa_supplicant is usually found in
  \util\xworkplace\plugins\xcenter\xwlan\.
   When using the standalone wlanstat then it is in .\xwlan\.
- Check if the new version is used by xwlan/wlanstat
   (right-click - properties - tab 'WPA supplicant' check version and path)
- Connect to wpa protected networks and post your findings at correspondending
   thread at os2world.com

- You can also test wpa_supplicant with a .conf file. F.i. set up a profile
   with no security, switch on wireless and start wpa_supplicant manually
   (f.i. wpa_supplicant.exe -i lan1 -cwpa_supplicant.conf - see wp.cmd)

Using with wpa_gui.exe
----------------------
wpa_gui is a QT frontend for wpa_supplicant. You can use it instead of
xwlan/wlanstat for managing your wireless networks. It works for me and I can
connect to my local wireless networks here.
- Start wpa_supplicant with a .conf file f.i. wp.cmd
- Use wpa_gui for scanning and configuration

As usual your wireless card has to be supported by genmac to use wireless
networks with OS/2.

There is also included wpa_cli.exe. But this is not tested very well.
###############################################################################

@Holger - I've seen these delays in establishing the connection since ages. I guess this is the way it works since a long time on OS/2. But I do not have any *nix system to test against. Though it may be a timing problem together with genmac too. I don't think it does make much sense to test against v0.5.7 as I don't even know if we have the sources for the OS/2 version somewhere.

Andi B.:
I've uploaded a new testbuild. It includes latest changes from official development tree. I've updated some old OS/2 source files to current level where possible too. Some new options in wpa_supplicant.conf are enabled (the ones which does not stop compiling).

If you have pmprintf.dll on your system then the debug messages are routed there too. The output maybe better readable in the PM window than in the VIO.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version