Author Topic: OpenOffice 4.1.7 gives error on startup  (Read 885 times)

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 10
  • -Receive: 43
  • Posts: 558
    • View Profile
    • Blonde Guy
OpenOffice 4.1.7 gives error on startup
« on: May 04, 2020, 04:07:20 am »
With WarpIN now working, I've got OpenOffice installed. Yum has installed all prerequisites. Yet, I'm seeing the attached error message.

The DLL mentioned, G:\OpenOffice417\program\deploy.dll exists on disk, 576k, date 1/27/20.
« Last Edit: May 04, 2020, 03:36:48 pm by Neil Waldhauer »
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 283
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #1 on: May 04, 2020, 05:33:20 am »
With WarpIN now working, I've got OpenOffice installed. Yum has installed all prerequisites. Yet, I'm seeing the attached error message.

Do you have the DLL ?

...\ApacheOpenOffice.4\program
27/01/20 16:25        586 735      0 a---  deploy.dll


roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 17
  • -Receive: 12
  • Posts: 513
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #2 on: May 04, 2020, 10:02:08 am »
Try to install the previous version of libicu
saludos

Moritz

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 3
  • Posts: 33
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #3 on: May 04, 2020, 01:58:39 pm »
i had the same issue and it turned out i had to install "libxslt" (using ANPM)

Andi B.

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 22
  • Posts: 494
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #4 on: May 04, 2020, 02:37:23 pm »
libvpx ! ?

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 68
  • Posts: 602
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #5 on: May 04, 2020, 06:56:21 pm »
What I do is always go to https://ecsoft2.org/firefox and copy the

yum install bww-resources-rpm cairo dash-sh fontconfig freetype hunspell libc libc-devel libcx libgcc1 libicu libjpeg-turbo libkai libpng libstdc++6 libvpx nspr nss nss-util os2-base os2-mpts pango pixman pthread zlib nspr

to the YUM quick install.  This contains everything needed.
« Last Edit: May 04, 2020, 06:58:22 pm by David Graser »

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 39
  • Posts: 1150
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #6 on: May 04, 2020, 08:05:11 pm »
Hi David,

They do say on that site
Quote
If you use Apache Openoffice as well, be aware, that you need to install the icu-legacy package to have AOO still working (yum install icu-legacy).
which might be the answer people are looking for.

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 68
  • Posts: 602
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #7 on: May 04, 2020, 08:52:18 pm »
Hi Ivan

Not enough sleep. Brain is befuddled.   I have been working 7 days a week/12 hour days.  I should have said

https://ecsoft2.org/openoffice

yum install libc libgcc1 libgcc-fwd openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6 libstdc++ uclip


ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 39
  • Posts: 1150
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #8 on: May 04, 2020, 09:32:04 pm »
Hi David, 

I hope they are paying you for that time but you really have to worry when you start on 18 hour days - they are the killer.

It appears there is some conflict with DLLs which is why I have all the necessary DLLs in the openoffice directory and use libpath strict on starting it.

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 68
  • Posts: 602
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #9 on: May 04, 2020, 09:52:31 pm »
Hi Ivan

If one has ArcaOS, I don't believe there is a dll problem so long as YUM is used to install.  That has been my experience. 

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 173
  • Posts: 2467
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #10 on: May 04, 2020, 09:56:21 pm »
The icu-legacy is the likely solution as when icu was upgraded, the new DLLs broke stuff using the old DLLs, so icu-legacy installs the old DLLs.
Note there will be more legacy packages required for the Mozilla apps once some stuff works its way into netlabs-rel, libvpx-legacy-4 is one IIRC.

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 10
  • -Receive: 43
  • Posts: 558
    • View Profile
    • Blonde Guy
Re: OpenOffice 4.1.7 gives error on startup
« Reply #11 on: May 04, 2020, 11:55:12 pm »
It turns out to be a prerequisites problem after all. the missing libraries were ft2lib and expat.

Thanks everyone!
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Matt Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 2
  • Posts: 43
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #12 on: June 28, 2020, 07:01:28 pm »
I had AOO 4.1.7 working, but after recent ANPM dll updates it quit working and I get the message Neil mentioned at the beginning of this thread.  I tried all the suggestions and it's still not working.  Anyone have any recent suggestions?
I'm really stuck without my AOO to work with.
Matt W.

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 68
  • Posts: 602
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #13 on: June 28, 2020, 07:47:02 pm »
I had AOO 4.1.7 working, but after recent ANPM dll updates it quit working and I get the message Neil mentioned at the beginning of this thread.  I tried all the suggestions and it's still not working.  Anyone have any recent suggestions?
I'm really stuck without my AOO to work with.
Matt W.
Matt

Under YUM  > Manage > YUM Tools > Quick Install

Copy and insert the following line:

yum install libc libgcc1 libgcc-fwd openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6 libstdc++ uclip

and then select OK.

This will tell you if you are missing anything and will ask you if you want it installed.

I just did all the YUM updates and OO works fine.


Matt Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 2
  • Posts: 43
    • View Profile
Re: OpenOffice 4.1.7 gives error on startup
« Reply #14 on: June 29, 2020, 12:54:24 am »
Thanks. AOO now works again.   Only thing it installed this time vs several previous attempts was " libxslt " and I don't know how that didn't get put in before when I tried.  Appreciate the feedback.  I also donated a bit more to BitWise for the AOO project.
Matt