Author Topic: AOS Removable media monitor - how to install  (Read 229 times)

Doug Clark

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 99
    • View Profile
AOS Removable media monitor - how to install
« on: September 25, 2018, 06:39:21 pm »
I am trying to figure out how to add the AOS removable media monitor widget to xCenter. For some reason when I installed AOS 5.01 on my laptop the monitor wasn't installed.

Andreas Schnellbacher

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 16
  • Posts: 334
    • View Profile
Re: AOS Removable media monitor - how to install
« Reply #1 on: September 25, 2018, 08:22:42 pm »
There may exist other ways to install it, but this works:

If you have it working on any system, just copy the files RemMedia.dll and RemM_en.msg to xworkplace\plugins\xcenter. If these files already exist, it should have worked.

Close XCenter and re-open it. Then move the pointer over an xcenter edge to get XCenter's and not a widget's context menu with mouse button 2. Click on its menu item 'Create new widget' and select 'AN Removable Media Monitor'. After that, you can move the newly created widget (a black symbol with a triangle and a bar below) were you want it.

Doug Clark

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 99
    • View Profile
Re: AOS Removable media monitor - how to install
« Reply #2 on: September 26, 2018, 12:49:26 am »
Thanks Andreas

I put those two files, plus RemMedia.xqs in the directory.

AN Removable Media shows up on the Add Widget submenu, but is greyed out so I can't select it.

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 11
  • Posts: 229
    • View Profile
Re: AOS Removable media monitor - how to install
« Reply #3 on: September 26, 2018, 02:00:22 am »
Hi Doug

When greyed out, it usually indicates that the USB widget has already been selected and should be found on XCenter.  However, if it is not showing up in the Xcenter, I don't understand why?

The widget appears as a black arrow pointed up. 

One anomaly I have found with the latest USB drivers is that when I boot up, my USB drive is not found.  However, removing the drive and re-installing the USB drive into the USB port and  it is recognized every time.   Any USB 3 port does not work at this time.


Doug Clark

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 99
    • View Profile
Re: AOS Removable media monitor - how to install
« Reply #4 on: September 26, 2018, 02:32:38 am »
Thanks Dave.

It appears, once again, to be operator error on my part.

I misread Andreas post as "add new widget" instead of  what he actually wrote, which was "create new widget".

Once I clicked on the right part  of xCenter I saw the create new widget menu option - which worked just fine.

And thanks again Andreas, for your help.

I have the Removable Media thing on another AOS machine (and now on the laptop) and I like it. Very nice.