OS/2, eCS & ArcaOS - Technical > Setup & Installation

eCS 2.2 clone for X200t and X230t - Questions and observations

(1/4) > >>

Sigurd Fastenrath:

I am working on tailored eCS 2.2 clones for the

- Lenovo X200t Tablet
- Lenovo X230t Tablet

at the moment.

I do have some questions and observations, that may have been noticed by others before but I would like to ask/state them here once again. Help is appreciated!

1. Observation: WLAN and GENMAC installation failed to work -> Reason: the eCs 2.2 beta config.sys is sorted, the 'helperw.exe' file needed for the GENMAC is placed in the middle of config.sys, once I moved it to the beginning of config.sys it started to work

2. Question: I do want to change the "ecs.ru" sheme for desktop icons as I prefer the "usual" one - changing it via "Appearance, Icon Theme" failed, there are still the icons. How to change them?

3. Observation: while on the X200t 'DOS Window' and 'WIN-OS2 Window' both need time to start for the first time, on the X230t both do not start at all (both Laptops installed with Panorama). Will give SNAP a try on X230t, on X200t it is working, but I still leave 'Panorama' as this is the prefered one by the developers; and I do expect SNAP not to work with the X230t

4. Observation: Adjusting the Panellight works on X200t via FN keys, on X230t not

5. Observation: Sound on the X200t works, on the X230t it does not (producing some kind of noise) -> I may have to ask Paul for help ;-)

6. Observation: USB 2.0 on X200t works great, on X230t as well (the USB 3.0 of the X230t are not supported, as expected - but one have at least ONE USB 2.0 there)

7. Question: once I shut down or reboot eCS 2.2 on the X200t I get a beep, on the X230t not. Someone with the same experience?

8. Observation: It is really nice to have the Keyboard Backlight with the x230t, the X200t does not offer this functionality

!! IMPORTANT NOTICE: ecomstation.ru is not allowed to use or link the attached picture, those are copyright by Sigurd Fastenrath only!!

Hi Sigurd

Nice to see that you are getting eCS working on fairly current tablets  :-)

I'll try to respond to your points:-

1] My experience is that eCS 2.2 Beta installation mangles genmac installation. I never tried to discover the cause I simply installed genmac again when I found it was not working. I did report the problem to eCS and understand that they found the cause and it should work fine for the GA.

2] Not sure what "ecs.ru" desktop icon scheme is... but I did not install any of the "Sunny icons" so had "eComStation Classic" as my desktop icon scheme.
Of interest is that I just changed the icon theme to "Manilla Envelopes" and rebooted. On reboot I see that the Desktop icons have not been changed at all but the folders displayed when I open a drive are "Manilla Envelopes". Obviously another glitch in this Beta; Guess I should report it.

3] I never install DOS/Win16 support as I only really use DOS for games. DOSBox does that much better - and with Sound.

4] Cannot comment

5] Add a pause line to config.sys immediately after the uniaud drivers to check that uniaud has identified hardware correctly. I use this:-
The boot stops to display a message like "driver not found, press a key to continue booting" which means you get as much time as you want to note down details.
If the hardware is identified correctly then you need to check the output of unimix to make sure that all options are set correctly. Use this line to generate a file with the current mixer settings:-
unimix -list > sound.txt
Unimix should be in the [BootDrive]:\MMOS2 directory.

6] It seems that eCS is always "playing catchup" - we have nearly got a fully working USB1/USB2 stack for most systems but USB3 is already here. I wonder if Lars is going to be looking into USB3 sometime in the near future...

7] I have had the "shutdown beep" on a Desktop system. This was finally fixed by an updated version of ACPI that worked fine on that Desktop. I think there has been an ACPI update since 2.2 Beta was released so you may want to investigate.

8] Guess it helps you to see what keys you are pressing when using the hardware in a dark room  :-)

Have Fun  ;-)


Sigurd Fastenrath:
Hi Pete,

thanks for answering, I am still not able to use the quote functionality as it ought to, so I just write my answers following the numbers.

Yeah, I want to have the eCs 2.2 clones ready for the meeting in Cologne end of November this year :-) so I still have some time left ;-)

1. I installed GENMAC 2.2 once again manually after the initial installation,  but it did not work for me again. Then I found the hint in Lantran.log. I guess the manual installation did found helperw.exe in config.sys but did not "realize" that it was at the wrong position.

2. Yes, these are the so called Sunny icons. But I want to have the option to use them with the clone but all the attempts to change to other icon sets failed. At may have to deinstall Sunny icons at least.

3. Yes, DOSBOX is better in this case, it was just for information

4. -

5. Yes, I did try this as well, sound with the X230t did only start to work at all (even with no result) once I used a tailored startup.cmd with the unimix parameters. I did exam unimix -list and all the possible parameters, but ....

6. at least 2.0 seems to get better and better

7. I already updated the ACPi to 3.22.02, AHCI 1.30, latest USB. ;-) Sorry, did not mention it.

8. or lying in bed. :-) I did not know how usable this feature is till I used the X200t again after using the X230t :-)



Doug Bissett:
Hi Sigurd. Interesting project...

1. It would be interesting to see if GENMAC 2.1 (from the eCS 2.1 install CD) would do it right (probably not, since it seems to be a config.sys sort problem). It would also be interesting to know what happens if you use my Logical ConfigSys Sort program (LCSS) on those machines. It is at HOBBES: http://hobbes.nmsu.edu/download/pub/os2/util/config/LCSS-0-4-4.wpi You may need an updated DAT file from: http://www3.telus.net/public/bissett1/LCSS.dat.

2. I have decided that the Sunny Icons feature causes too many problems, so I simply don't install it (I will try again, with the GA version). There is a selection in the desktop properties to turn that off (Display-> turn off Default, and select Normal). It doesn't seem to prevent other annoyances that I have seen with that feature.

3. I have quit installing DOS and WinOS2 support. It seems to be pretty useless these days. I agree that DOSBOX does a reasonable job, for the few times that I find a need.

4. I have same problem on my T510, and my L530, and I do miss it, on the few occasions when I would like to use it.

5. Sound works well, on my T510 (if you don't count the terrible speakers), using UNIAUD from UniaudUpdate1.09.06-2.02.01.zip. I get sound from the L530, using the same driver, but it is not right. Earlier versions of UNIAUD won't even load. So far, I haven't bothered trying to get it fixed, since there are other problems on that machine.

6. USB works well on the T510, using Lars' versions. The T510 has two EHCI adapters, and no others. USB also works well, on the L530. The L530 has a USB 3.0 adapter (which doesn't work, of course - even in windows, until you turn it on), as well as two EHCI adapters. Lars' driver works, and I can use all of the USB ports, including the USB 3.0 port, with USB 1.0, 1.1, and 2.0, devices.

7. That may have something to do with sound support (just a guess).

8. I haven't seen that feature...

I will add an observation, and question:
9. My L530 has a UEFI BIOS, set to "legacy" mode. It runs eCS 2.x okay, but there is a 4K memory hole at the 512 meg mark (cause unknown). That prevents eCS from "seeing" more than 512 meg of memory. From what I have been able to determine, some devices also cause memory holes, but the rest of them are above the 3 GB mark, so they wouldn't cause a real problem. Does your X230T have the same thing? FWIW, the L530 does run well, with only 512 Meg of memory.

Sigurd Fastenrath:
Hi Doug,

thanks, sorry for my short replies!

1. I will try your suggestions later today and report

2. Thanks, will try this later as well as I do have the X230t not at hand now

3. -

4. -

5. I am already in contact with Paul and may make progress today

6. Thats a very good point! I in fact did not try to use the 3.0 Ports because I thought those are not "backward compatible" on OS/2 :-). For Windows: with 7 or 8 I do not have to switch them on manually, they are allways "on". Maybe something in your Windows "Power scheme" is changed?

7. -

8. If you watch may latest video with the X230t I tried to show that it is working right at the beginning, but it is not to be recognized very good as I just made a quickshot and it was during daylight. It is really something I do appriciate!

9. Yes, the same with the X230t and this memory hole. I guess this is so since the Sandy/IVY Bridge generation. I was able to get rid of it using OS4LOADER instead of the eCS OS2LOADER on the Samsung Slate with Sandy Bridge. There I had the full 4GB of RAM (minus some for the onboard graphic). But on the X230t OS4LOADER fails to boot (even the latest edition - so far), maybe because I have 8GB of RAM there. The same with the other LOADER - QSLOADER, that is around. In addition it seems to me that those both loaders make a better job at all than the one from eCS. AFAIR I pointed Mensys to this QSLOADER and they might want to merge some things from it to overcome the memory whole as i.e. the QS Loader is written from scratch - the file is about double as big as the "usual" OS2LOADER. So maybe with the next eCS 2.2 beta there are some news (do not know as I do not get much information from there -> close to zero.) Even though I will reduce RAM to 4GB and give OS4LOADER a try with eCS 2.2 again later on.




[0] Message Index

[#] Next page

Go to full version