Author Topic: AvxCat  (Read 5002 times)

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 20
  • Posts: 821
  • Karma: +4/-0
    • View Profile
Re: AvxCat
« Reply #15 on: October 10, 2018, 03:58:48 am »
Remy,
Thank you...I fell a little behind in my up-keep of your app and ffmpeg itself. Just downloaded your latest release, will hopefully get a chance to put it through it's paces this weekend.

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: AvxCat
« Reply #16 on: July 03, 2020, 04:29:17 pm »
i have a problem with AVxCAT :
trying to convert mp3-files to wav format always leads to an error "12" with no files appearing in the destination folder. trying to convert a while folder leads to only getting an empty folder.
tried also to convert into other formats with the same result.
i have all the newest modules installed...

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 364
  • Karma: +0/-0
    • View Profile
Re: AvxCat
« Reply #17 on: July 03, 2020, 11:34:36 pm »
i have a problem with AVxCAT :
trying to convert mp3-files to wav format always leads to an error "12" with no files appearing in the destination folder. trying to convert a while folder leads to only getting an empty folder.
tried also to convert into other formats with the same result.
i have all the newest modules installed...

Whats your rxu.dll build ?
* having the problem on all conversion could be the result of a not created pipe or not enough available shared memory (this could be the case if you set ffmpeg module as load high without loading them permanently into high storage. each ffmpeg run will then load dlls high and at free, a hole if left into storage "OS/2 issu". To prevent this I've got too, I wrote a small load perm high ffmpeg dlls "ffmpegHigh", use GUI ( http://remydodin.levillage.org/fr/realisations.php?item=6000&id=realisations ) or do not flag ffmpeg dlls to be loaded into highmem.
If this is the case, I would suggest you to try a system reboot to get back all storage and then, use my loadhigh gui for ffmpeg dlls.     
 
next: which AVxCAT do you use ?
- open extra logs and send me the results. Use the link provided on my site http://remydodin.levillage.org
- Send me the generated temporary file under your temp path too.

Best regards
Remy


Updt: current AVxCAT development (v2 !)
- Lot of work done on audio part with new functions  (ex: added icecast link entries "http only" -  recording or play calling pm123)
looking for testers of new audio functions as well older function following code update.   

- Video not fully updated with new functions 
- Planned to add webcam recording as new input source  (usefull to create specific presentation or video conference archives....etc...)   
« Last Edit: July 03, 2020, 11:41:55 pm by Remy »

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: AvxCat
« Reply #18 on: July 06, 2020, 08:59:34 pm »
thanks very much for your quick reply. i will send you the requested files.
i use version 1.5.1.4 and the rxu.dll from 12.08.2017.
I replaced it with the version from 2.05.96 but that didn't help (i'll send you the logfile also. it's FCA66103.tmp, ffmpeh-file had same content as with the newer rxu-dll-version).

also tried a version from 13.05.1996, but that lead to an error 43 when i started AVxCat. i also couldn't start print2ps.cmd for ePDF any more - strange, cause the dll-version is from that program - anyway epf stopped working since a few days for some unknown reason though i did't change anything (only thing i did was triying out some java-programs). Just telling this, cause there might be some connection with my problem with AVxCat.
I also used ffmoeghigh as suggested. unfortunatelly it didn't help. used it on ffmpegca-ecs.dll, ffmpqggca.dll and rxu.dll.

you write that there will be a new version of the program. when will it be available?
i really like your program. before i updated to AN5.05 it worked fine with AN5.01

Couldn't find the link for uploading the log-files. Will send you here...

« Last Edit: July 06, 2020, 09:25:03 pm by andreas »

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 364
  • Karma: +0/-0
    • View Profile
Re: AvxCat
« Reply #19 on: July 06, 2020, 10:41:27 pm »
thanks very much for your quick reply. i will send you the requested files.
i use version 1.5.1.4 and the rxu.dll from 12.08.2017.
I replaced it with the version from 2.05.96 but that didn't help (i'll send you the logfile also. it's FCA66103.tmp, ffmpeh-file had same content as with the newer rxu-dll-version).

also tried a version from 13.05.1996, but that lead to an error 43 when i started AVxCat. i also couldn't start print2ps.cmd for ePDF any more - strange, cause the dll-version is from that program - anyway epf stopped working since a few days for some unknown reason though i did't change anything (only thing i did was triying out some java-programs). Just telling this, cause there might be some connection with my problem with AVxCat.
I also used ffmoeghigh as suggested. unfortunatelly it didn't help. used it on ffmpegca-ecs.dll, ffmpqggca.dll and rxu.dll.

you write that there will be a new version of the program. when will it be available?
i really like your program. before i updated to AN5.05 it worked fine with AN5.01

Couldn't find the link for uploading the log-files. Will send you here...

the html mailto: function doesn't work until a default mail client is defined but my email address appears in the link.

The log file has no entry about the process.
Can you please enable extra log and then run the conversion  (wav to wav in your case) and save this extra log file after conversion.
From the tmp file, all seems ok.

Please read the private message I sent you under os2world
(V2 needs curls program)

Regards

Note: to from a command line what happens,
Edit FCA66103.TMP
add at first line  /* rexx */
add after  more_map=""  copy_metadata=""
remove   ||' 2>\pipe\avxcat66063'
Add return as last line and save the file as filename.cmd
From a cmd os2 prompt window, run filename.cmd and check all messages
If it works, then the problem may be with the named pipe.


Check you have default email program defined, see the following screen copy. If yes, mailto: under firefox should open the specified mail program.
« Last Edit: July 08, 2020, 11:30:14 am by Remy »

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: AvxCat
« Reply #20 on: October 16, 2020, 04:42:36 pm »
wrote you already a mail. but mane also others might have the same problem. so i repeat it here:
problem was a missing SSP0.dll, that you can find in the gcc-9_2_0-5_oc00.zip - package.