Author Topic: Samba 4.9.0 based client  (Read 3890 times)

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #15 on: May 30, 2019, 08:43:22 pm »
Hi,
............……………………………….
Logs will help us understand what's happening.

Create a file ndpsmb.dbg in the root directory of the drive where netdrive is installed. Restart ndctl (or reboot).

try and access your windows 10 share - and after, send me a copy of ndpsmb.log (not sure where this will get created on a Warp 4 install).

Cheers,

Paul

Hi Paul, I've created  ndpsmb.dbg in C:\ , rebooted, started Netdrive and filled the smbfs parametres field with same parametres as x Samba resource working in the OS2 window, pressed on DONE : error alert.   And no ndpsmb.log found anywhere.
All I can show in the following image of how I filled the smbfs configuration page end the other image of the system error message.
the software in use is
-Samba client 4.9.4-4 i686 (rpm package from Arcaos Subscription repository)
-Heimdal 7.5.0-3 i686 (rpm package linked to samba package)
-Heimdal lib 7.5.0-3 i686 (rpm package linked to samba package)
-Netdrive  3.1.6.876 (executable package)
-smbfs plugin 2.1.5 GA (wpi package)
thank you

« Last Edit: May 30, 2019, 08:48:04 pm by mauro »

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #16 on: May 30, 2019, 08:46:01 pm »
mauro:
Can you post the specific versions of the installed components you have?


Hi Dariusz, here are the installed components:

-Samba client 4.9.4-4 i686 (rpm package from Arcaos Subscription repository)
-Heimdal 7.5.0-3 i686 (rpm package linked to samba package)
-Heimdal lib 7.5.0-3 i686 (rpm package linked to samba package)
-Netdrive  3.1.6.876 (executable package)
-smbfs plugin 2.1.5 GA (wpi package)

Paul Smedley

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 53
  • Posts: 447
    • View Profile
Re: Samba 4.9.0 based client
« Reply #17 on: May 31, 2019, 04:46:15 am »
Hi Mauro,

mauro:
Can you post the specific versions of the installed components you have?


Hi Dariusz, here are the installed components:

-Samba client 4.9.4-4 i686 (rpm package from Arcaos Subscription repository)
-Heimdal 7.5.0-3 i686 (rpm package linked to samba package)
-Heimdal lib 7.5.0-3 i686 (rpm package linked to samba package)
-Netdrive  3.1.6.876 (executable package)
-smbfs plugin 2.1.5 GA (wpi package)

If you really have 'smbfs plugin 2.1.5 GA (wpi package)' installed, this is your issue with Windows 10. the 2.1.5 package uses Samba 3.x which only understands the SMB1 protocol.

For security reasons, Windows 10 (by default) only talks SMB2+

There should be a rpm package for a ndpsmb that talks to -Samba client 4.9.4-4 i686 (rpm package from Arcaos Subscription repository)

Cheer,s

Paul.

Paul Smedley

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 53
  • Posts: 447
    • View Profile
Re: Samba 4.9.0 based client
« Reply #18 on: May 31, 2019, 04:48:14 am »
Also.... your parameters to configure the plugin are wrong....

you have \\192.168.56.1\Users as the share

This needs to be:

Server: 192.168.56.1
Share:  Users


mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #19 on: May 31, 2019, 09:23:53 pm »
well thank you, something has changed.
I've taken a ndsmb.dll 3.5.0 version from a zip archive (not rpm found in the repositories) , and used it to replace the old 2.1.5 GA version in c:\ndfs\ndplugs.

The result (see images) is no more error alerts when, after having filled the configuration fields as you indicated, I press DONE.
Good.
But then I do not see anything in NetDrive mounted resource panel, it remains empty.
The new mounted drive letter appears in WPS volumes, but empty.

« Last Edit: May 31, 2019, 09:29:31 pm by mauro »

Paul Smedley

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 53
  • Posts: 447
    • View Profile
Re: Samba 4.9.0 based client
« Reply #20 on: May 31, 2019, 11:43:44 pm »
Server entry is still wrong...

needs to be Server: 192.168.56.1 NOT \\192.168.56.1\

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #21 on: June 01, 2019, 02:06:24 pm »
Server entry is still wrong...

needs to be Server: 192.168.56.1 NOT \\192.168.56.1\

I went for this entry after having tested the different combinations of "\" symbol (only \\ before, only \ after, completely without), and with my choice was the only one without error messages yesterday.
But today the message is  : "The smbfs resource was not mounted to Mount point L:\   Error code: 58"

While the way you suggest gives this error message after pressing DONE: 
"The smbfs resource was not mounted to Mount point L:\   Error code: 65"


ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 34
  • Posts: 980
    • View Profile
Re: Samba 4.9.0 based client
« Reply #22 on: June 01, 2019, 08:11:55 pm »
Can you ping 192.168.56.1  In other words is that a valid IP address?

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 3
  • -Receive: 31
  • Posts: 146
    • View Profile
    • Wim's home page
Re: Samba 4.9.0 based client
« Reply #23 on: June 01, 2019, 09:17:45 pm »
Quote
I went for this entry after having tested the different combinations of "\" symbol (only \\ before, only \ after, completely without), and with my choice was the only one without error messages yesterday.
But today the message is  : "The smbfs resource was not mounted to Mount point L:\   Error code: 58"
Code: [Select]
[H:\]help sys58
SYS0058: The specified server cannot perform the requested operation.

EXPLANATION: You are attempting an operation that cannot be performed
by the specified server.

ACTION: Make sure that you have specified the correct computer name
and command, then retry the command.  If you continue to have problems,
contact your network administrator.
Quote
While the way you suggest gives this error message after pressing DONE:
"The smbfs resource was not mounted to Mount point L:\   Error code: 65"
Code: [Select]
[H:\]help sys65
SYS0065: Network access is denied.

EXPLANATION: You attempted to access a resource that is not available
to you.  It is possible that:
o  You do not have a valid account on the server sharing the resource.
o  Your account on this server has not been granted the permissions
   necessary to access the resource.

ACTION: Make sure that you specify the correct name of the resource
that you want to use and retry the command.  If you are still denied
access, contact your network administrator.
Seems to me that 192.168.56.1 as said by Paul Smedley is correct.

Wim

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #24 on: June 02, 2019, 09:07:12 am »
Seems to me that 192.168.56.1 as said by Paul Smedley is correct.

Wim

Hi Wim, as said, the thing is that the resource is available at a "smb:>" prompt in an OS2 command window, and (also said), if it is available there must be available in NetDrive. The issue could also be -just guessing- the password request that I skip just by hitting RETURN :

smbclient \\192.168.56.1\Users


gethostname failed
gethostname failed
Enter WORKGROUP\GUEST's password:

here I hit RETURN and I get this :

Try "help" to get a list of possible commands.
smb: \>

then I command
smb: \> dir

and the requested resource's folders are available

  .                                  DR        0  Sat Jul  7 13:06:16 2018
  ..                                 DR        0  Sat Jul  7 13:06:16 2018
  Default                           DHR        0  Wed Sep 26 20:29:58 2018
  Default.migrated                    D        0  Sun Sep  4 19:20:29 2016
  desktop.ini                       AHS      174  Sat Jun 16 17:26:53 2018
  Public                             DR        0  Wed Sep 26 20:28:39 2018
  user                                D        0  Sun Jul 31 08:38:03 2016

                239907945 blocks of size 4096. 178492899 blocks available
smb: \>

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 3
  • -Receive: 31
  • Posts: 146
    • View Profile
    • Wim's home page
Re: Samba 4.9.0 based client
« Reply #25 on: June 02, 2019, 10:32:20 am »
Seems to me that 192.168.56.1 as said by Paul Smedley is correct.

Wim

Hi Wim, as said, the thing is that the resource is available at a "smb:>" prompt in an OS2 command window, and (also said), if it is available there must be available in NetDrive.
Hi Mauro, unfortunately for you I have no experience with smb nor NetDrive at all, so I cannot help you further. Sorry.

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #26 on: June 02, 2019, 11:16:31 am »
Seems to me that 192.168.56.1 as said by Paul Smedley is correct.

Wim

Hi Wim, as said, the thing is that the resource is available at a "smb:>" prompt in an OS2 command window, and (also said), if it is available there must be available in NetDrive.
Hi Mauro, unfortunately for you I have no experience with smb nor NetDrive at all, so I cannot help you further. Sorry.

ok, thank you anyway for answering.  Samba implementation was tricky but at the end with good suggestions and attempts I succeeded to make it work at least by OS2 command line, while NetDrive is really a mistery. I believe it might be a version issue of application itself or ndsmb plugin version not matching with Samba version (although already tried to change them) or else some implementation is only good for ARCA OS but not for OS2 Warp 4.52.
« Last Edit: June 02, 2019, 11:19:53 am by mauro »

Sean Casey

  • Newbie
  • *
  • Thank You
  • -Given: 5
  • -Receive: 2
  • Posts: 47
    • View Profile
Re: Samba 4.9.0 based client
« Reply #27 on: June 02, 2019, 06:31:23 pm »

or ndsmb plugin version not matching with Samba version (although already tried to change them) or else some implementation is only good for ARCA OS but not for OS2 Warp 4.52.

i have installed NetDrive on vanilla Warp 4.52 using the plugin "ndpsmb-2.2.0-Beta4-20140226.wpi".  You can find this on http://trac.netlabs.org/samba


To map a drive within NetDrive, I use the settings per the attached.

Paul Smedley

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 53
  • Posts: 447
    • View Profile
Re: Samba 4.9.0 based client
« Reply #28 on: June 03, 2019, 10:49:41 am »
Server entry is still wrong...

needs to be Server: 192.168.56.1 NOT \\192.168.56.1\

I went for this entry after having tested the different combinations of "\" symbol (only \\ before, only \ after, completely without), and with my choice was the only one without error messages yesterday.
But today the message is  : "The smbfs resource was not mounted to Mount point L:\   Error code: 58"

While the way you suggest gives this error message after pressing DONE: 
"The smbfs resource was not mounted to Mount point L:\   Error code: 65"

Do you have a ndpsmb.log at all?

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: Samba 4.9.0 based client
« Reply #29 on: June 03, 2019, 09:01:39 pm »
Server entry is still wrong...

needs to be Server: 192.168.56.1 NOT \\192.168.56.1\

I went for this entry after having tested the different combinations of "\" symbol (only \\ before, only \ after, completely without), and with my choice was the only one without error messages yesterday.
But today the message is  : "The smbfs resource was not mounted to Mount point L:\   Error code: 58"

While the way you suggest gives this error message after pressing DONE: 
"The smbfs resource was not mounted to Mount point L:\   Error code: 65"

Do you have a ndpsmb.log at all?

LOOK BELOW !!!!!

still cannot believe, please don't wake me up!

I kept trying every variation of settings in smbfs parametres, and now I've found it needed the "workgroup" specification in the Workgroup field, and nousers/nopassword in the login table.

This is it, thank you a lot Paul, Sean, Dave, David, Dariusz, Ivan, Wim, everyone who supported me here, hope this thread will be an additional reference for those ones encountering issues in configuring Samba and NetDrive in OS2 Warp 4.52.